cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
901
Views
0
Helpful
0
Replies
Highlighted
Beginner

Configuration for Cisco 871 to work with an ISP provider for home or work

Good Day,

I just wanted to post a configuration that I did on a Cisco router 871. This configuration works for me. It is used for a non statis IP address or dynamic address from the Internet service provider. You need to have Nat configured and enabled on your router or routing switch for this to work. I find that it is hard to find a complete configuration listed with the right configuration on the web.

Je publis ici la configuration d'un routeur Cisco 871 pour qu'il fonctionne avec un fournisseur d'accès à l'Internet. Cette configuration fonctionne avec une une adresse dynamique.

sh run

Building configuration...

Current configuration : 3943 bytes

!

! Last configuration change at 21:13:54 UTC Fri Mar 1 2002 by admin

version 15.1

no service pad

service timestamps debug datetime msec show-timezone

service timestamps log datetime msec show-timezone

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname hostname

!

boot-start-marker

boot system flash:c870-advipservicesk9-mz.151-4.M6.bin

boot-end-marker

!

!

logging buffered 25000

!

aaa new-model

!

!

!

!

!

!

!

aaa session-id common

!

dot11 syslog

ip source-route

!

!

ip dhcp limited-broadcast-address

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.20

!

ip dhcp pool local

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

!

!

!

ip cef

ip domain lookup source-interface FastEthernet4

ip address-pool local

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

username admin privilege 15 password 7 0B5A435C13

!

!

!

!

!

!

!

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

description ISP

ip address dhcp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface Vlan1

ip address 192.168.1.1 255.255.255.0

ip broadcast-address 192.168.1.255

ip nat inside

ip virtual-reassembly in

!

ip forward-protocol nd

no ip http server

ip http secure-server

!

!

ip dns server

ip nat inside source list 1 interface FastEthernet4 overload

ip route 0.0.0.0 0.0.0.0 dhcp

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

!

!

!

!

!

!

control-plane

!

banner motd ^C

==============================================================================

Unauthorized Access Prohibited                     Acces non-autorise Defendu

Access Monitored                                               Acces surveille

==============================================================================

^C

!

line con 0

exec-timeout 30 0

no modem enable

line aux 0

line vty 0 4

exec-timeout 30 0

transport input all

!

scheduler max-task-time 5000

!

webvpn context Default_context

ssl authenticate verify all

!

no inservice

!

end

That it. I am still learning hoe NAT works in this case. It creates a new interface that allows you to route to the Internet. If NAT is not configured it will not work.

Hope this help

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards