cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

482
Views
0
Helpful
4
Replies
Highlighted
Beginner

Configuration suggestion for DHCP Snooping

Hi,

I need to apply DHCP snooping on 4500 series switches working as L2 in my Network. We have external DHCL Server in another location connected with 6500 series switch.   

                                                  Running EIGRP                                                      Configured Voice & Data Vlan both

DHCP Server -------- 6509 switch<----------------------------------->6509 Switch -------- 4500 switch ----------------------------------------------------------Ip Phones.               

                        (ving Redundant)                                  (ving Redundant)   

Scenario is attached for refernece.

I need to know whether the configuration which I mentioned in scenario is enough for apply DHCP snooping in my network. Please suggest ASAP as same is need to apply soon.

Thanks & Regards

Vinod

Everyone's tags (3)
4 REPLIES 4
Enthusiast

Re: Configuration suggestion for DHCP Snooping

Hope you made access switch as Relay agent (note: you should be able to reach DHCP server from access switch):

Yes you can run DHCP snooping. enable snooping globally and per vlan based, you are good to run it.

Example:

ip dhcp snooping vlan 10,20,30

no ip dhcp snooping information option

!    We are using a windows DHCP server, witch cannot use option 82.

ip dhcp snooping

On the trunk to the core switch

ip dhcp snooping trust

Please rate helpfull posts.

Regards,

srikanth

VIP Mentor

Configuration suggestion for DHCP Snooping

HI Vinod,

uSE THIS.

ip dhcp snooping vlan 1-5, 6-10

ip dhcp snooping

and on which port of core switch  ur dhcp server connected, on that port please apply"ip dhcp snooping trust"

and u can use:

example

!

interface Vlan2

ip address 10.73.2.254 255.255.255.0

ip helper-address 10.73.21.1

interface Vlan6

ip address 10.73.6.254 255.255.255.0

ip helper-address 10.73.21.1

to get automatic ip address on each client: in diff vlans

Regards

Please rate if it helps.

Beginner

Re: Configuration suggestion for DHCP Snooping

Thanks for suggestion Team, I will check and update you accordingly.

Hope you have checked the attached scenario. mentioned configuration is correct ?? Plz suggest

      

Here, Vlans I configured on L3 switch which connected to L2 switches is not configured on another L3 switch to whom DHCP server is connected.

Using EIGRP to advertise the network between both L3 switch.

Beginner

Configuration suggestion for DHCP Snooping

Hi Team,

As per attached document, we need to enable option 82 on L3 switch to whom L2 switches are connected. But what about other L3 switch on which we connected DHCP server. Do we need to configure anything on same ??

URL: http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst4500/12.2/15.02SG/configuration/guide/dhcp.html#wp1148856

Please suggest

Regards

CreatePlease to create content
Content for Community-Ad