cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
518
Views
0
Helpful
12
Replies
claurie
Beginner

Configuring Catalyst 3850 for QoS/Shaping on 802.1Q VLANs

Hi Community,

I am in desperate need of direction/assistance. In trying to achieve my aim, I keep going around in circles, not getting any closer.

I have a Catalyst 3850 with several VLAN Trunk Ports with multiple VLANs on each.

I need to apply shaping to the egress of each VLAN for two traffic classes: Voice and a single Data class

I wish to apply a guaranteed non buffered queue for the Voice and

A Shape Average queue for the data class

Each time I try a config I get the following error notification:

% Queuing actions supported only with dscp/cos/qos-group/precedence based classification!!!

I assume I am omitting a step but am lost.

Are there any step by step tutorials available that would cover setting up such a Config?

I am desperate for assistance.

Thanks

Craig

12 REPLIES 12
Joseph W. Doherty
Hall of Fame Expert

I don't really "know" a 3850's QoS features, especially regarding shaping.  I "know" the earlier 3750 had both an inexact port "shaping" feature, and supported egress queue "shaping", but it also supported only 4 egress queues, one of which could be configured PQ.

I believe [?] the 3850 supports 8 egress queues, of which 1 (maybe 2?) can be PQ.  Don't know what, "shaping" it supports.  (Its QoS features should be documented in the configuration manual and guide for your IOS version.)

What you might be able to do, is direct all your VLAN VoIP traffic to a single egress PQ and direct VLAN data traffic to up to 7 other queues, which support "shaping" per queue.  (They should support relative dequeuing priorities.)

If you identify the IOS being used, version and feature set, I could look over the documentation and, possibly, assist you further.

Hi Joseph,

Thanks for the response! My 3850 is running IOS Version 16.3.

Thanks
Craig

From a quick read of the user guide, the 3850 supports 8 egress queues, two of which can be configured as PQs, shaping on egress queues (but on physical ports).

What might work, assuming you don't need more than 8 classes, is to logically (using QoS groups) classify all traffic, VoIP to be directed to your physical (trunk) port's PQ, and up to 7 VLANs into physical (trunk) port queues, each shaped as desired.

Hi Joseph,
Thanks for taking the time to look into this and your feedback. From your comments, it is clear where I was always going wrong - I have been trying to effectively create 2 QoS queues within each VLAN Class-Map.
One further question - Does the 8 Queue limit apply to the switch across all physical ports, or is it 8 per Physical Port?
Thanks for your help - I appreciate you giving your time!
Cheers
Craig

8 per physical port.

Hi Joseph,

Thanks for your assistance thus far.

It would seem only 7 Queues are allowed per physical interface.

Also, the Catalyst 3850 will only allow the use of the same QoS-Group labels on multiple interfaces e.g.:

If I put the following policy on Int GE1/0/2

policy-map GE1/0/2_Shaping-Out
class Voice
priority level 1 10000
class QoS-Group_1
shape average 45000000
class QoS-Group_2
shape average 45000000
class QoS-Group_3
shape average 45000000
class QoS-Group_4
shape average 90000000
class QoS-Group_5
shape average 45000000
class QoS-Group_6
shape average 90000000

 

The only policy the switch will accept on a second interface GE1/0/4 is the following, where the same QoS-Goup classes/labels only are accepted, Input Marking policies are identical with the exception of different vlan IDs.

 

policy-map GE1/0/2_QoS-Groups
class vlan1008
set qos-group 1
class vlan1009
set qos-group 2
class vlan1010
set qos-group 3
class vlan1012
set qos-group 4
class vlan1013
set qos-group 5
class vlan1014
set qos-group 6

 

policy-map GE1/0/4_QoS-Groups
class vlan1006
set qos-group 1
class vlan1007
set qos-group 2
class vlan1020
set qos-group 3
class vlan1021
set qos-group 4
class vlan1022
set qos-group 4
class vlan1026
set qos-group 5
class vlan1017
set qos-group 6

 

policy-map GE1/0/4_Shaping-Out
class Voice
priority level 1 10000
class QoS-Group_1
shape average 90000000
class QoS-Group_2
shape average 45000000
class QoS-Group_3
shape average 90000000
class QoS-Group_4
shape average 90000000
class QoS-Group_5
shape average 90000000
class QoS-Group_6
shape average 90000000

 

Am I doing it correct?

 

Cheers

Hi Joseph,

Attached is the show policy-map int gigabit1/0/2 and 1/0/4 outputs.

It would seem that the Output policies are not functioning and all traffic (excluding the Voice) is being classed as class-default.

Any assistance, as always would be much appreciated.

 

Cheers

Sorry for the slow response - been working hard the last several days.

What do your class-maps look like and what's the actual ingress interfaces, both physical and logical for this traffic.

 

Hi Joseph,
No need to apologise! I have provided the Class-Maps, Policy-Maps and the relevant Interfaces below:
interface GigabitEthernet1/0/1 is the Upstream/Wan interface.

class-map match-any vlan1015
match vlan 1015
class-map match-any vlan1026
match vlan 1026
class-map match-any vlan1014
match vlan 1014
class-map match-any vlan1027
match vlan 1027
class-map match-any vlan1017
match vlan 1017
class-map match-any vlan1006
match vlan 1006


class-map match-any vlan1007
match vlan 1007
class-map match-any vlan1016
match vlan 1016
class-map match-any vlan1011
match vlan 1011
class-map match-any vlan1022
match vlan 1022
class-map match-any vlan1001
match vlan 1001
class-map match-any vlan1010
match vlan 1010
class-map match-any vlan1023
match vlan 1023
class-map match-any vlan1013
match vlan 1013
class-map match-any vlan1020
match vlan 1020
class-map match-any vlan1012
match vlan 1012
class-map match-any vlan1021
match vlan 1021
class-map match-any vlan1008
match vlan 1008
class-map match-any vlan1019
match vlan 1019
class-map match-any system-cpp-police-punt-webauth
description Punt Webauth
class-map match-any vlan1009
match vlan 1009

class-map match-any Voice
match dscp 5

class-map match-any QoS-Group_1
match qos-group 1
class-map match-any QoS-Group_2
match qos-group 2
class-map match-any QoS-Group_3
match qos-group 3
class-map match-any QoS-Group_4
match qos-group 4
class-map match-any QoS-Group_5
match qos-group 5
class-map match-any QoS-Group_6
match qos-group 6
class-map match-any QoS-Group_7
match qos-group 7
class-map match-any QoS-Group_8
match qos-group 8
class-map match-any QoS-Group_9
match qos-group 9

policy-map GE1/0/4_QoS-Groups
class vlan1007
set qos-group 2
class vlan1020
set qos-group 3
class vlan1021
set qos-group 4
class vlan1022
set qos-group 4
class vlan1026
set qos-group 5
class vlan1017
set qos-group 6
class vlan1027
set qos-group 7
class vlan1006
set qos-group 1

policy-map GE1/0/2_QoS-Groups
class vlan1008
set qos-group 1
class vlan1009
set qos-group 2
class vlan1010
set qos-group 3
class vlan1012
set qos-group 4
class vlan1013
set qos-group 5
class vlan1014
set qos-group 6
class vlan1016
set qos-group 7
policy-map GE1/0/2_Shaping-Out_Test
class Voice
priority level 1 10000
class QoS-Group_1
shape average 45000000
class QoS-Group_2
shape average 45000000
class QoS-Group_3
shape average 45000000
class QoS-Group_4
shape average 90000000
class QoS-Group_5
shape average 45000000
class QoS-Group_6
shape average 90000000
policy-map GE1/0/4_Shaping-Out_Test
class Voice
priority level 1 10000
class QoS-Group_1
shape average 90000000
class QoS-Group_2
shape average 45000000
class QoS-Group_3
shape average 90000000
class QoS-Group_4
shape average 90000000
class QoS-Group_5
shape average 90000000
class QoS-Group_6
shape average 90000000
!
!
!
!
!
interface GigabitEthernet1/0/1
description GW_CSW_M1 to TR_M1
no switchport
bandwidth 1000000
ip address 103.102.xxx.xxx 255.255.255.252
!
interface GigabitEthernet1/0/2
description ENNI 893Q
switchport mode trunk
speed nonegotiate
service-policy input GE1/0/2_QoS-Groups
service-policy output GE1/0/2_Shaping-Out_Test
!
interface GigabitEthernet1/0/4
description ENNI 897Q
switchport mode trunk
speed nonegotiate
service-policy input GE1/0/4_QoS-Groups
service-policy output GE1/0/4_Shaping-Out_Test
!

Sorry, still not clear to me.  Clarify flow of traffic, i.e. which interfaces are used and in what direction for what kind of traffic.

What has me most confused is ingress and egress policies on same interfaces.

"class-map match-any Voice
match dscp 5"

DSCP 5?  Not IPPrec 5 and/or DSCP EF?

 

Hi Joseph,
Apologies for the lack of clarity. Point taken with the Voice Class. I have updated to Match dscp ef
Also, this switch provides the Access layer for customer circuits (the VLANs) to connect to our Network Node. INT GE1/0/1 is the upstream link to our Gateway Router. All traffic from internet will come via this interface.
I hope this clears things up enough.
Cheers
Craig

So if g1/0/1 is the egress to the Internet, isn't that the interface you should be shaping on?

If g1/0/2 and g1/0/4 are ingress from access switches, then that would be the place to match and classify on, as you're doing with you ingress policy.  (BTW, I've always had trouble getting QoS group to work, correctly, but what you're doing, is, I believe, correct for these ingress classification policies.)