cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
151
Views
5
Helpful
4
Replies
Highlighted
Beginner

Configuring DHCP-relay with VLAN's

I have a problem. I'm doing a small lab for the courses.
I need to create 4 DHCP pools for 4 VLAN's on Router0. And then to configure DHCP-relay agent on Router1, so PC's in VLAN 300 and 400 could recieve IP addresses from DHCP pools.UgnBP_croper_ru.png

That's what I've done on Router0:

ip dhcp pool 100

network 10.10.192.0 255.255.240.0

default-router 10.10.207.254

ip dhcp pool 200

network 10.10.208.0 255.255.240.0

default-router 10.10.223.254

ip dhcp pool 300

network 10.10.224.0 255.255.240.0

default-router 10.10.239.253

ip dhcp pool 400

network 10.10.240.0 255.255.240.0

default-router 10.10.255.253

interface FastEthernet0/0.100

encapsulation dot1Q 100

ip address 10.10.207.254 255.255.240.0

!

interface FastEthernet0/0.200

encapsulation dot1Q 200

ip address 10.10.223.254 255.255.240.0

!

interface FastEthernet0/0.300

encapsulation dot1Q 300

ip address 10.10.239.254 255.255.240.0

!

interface FastEthernet0/0.400

encapsulation dot1Q 400

ip address 10.10.255.254 255.255.240.0


I also switched Switch0 and Switch1 ports which are connected to routers to trunk mode. But I don't understand, how I should configure DHCP relay agent on Router1 and which addresses I should give to the subinterfaces on Router1. I know you can use ip helper-address on Fa0/1 subinterfaces  of Router1, but I'm kinda confused about the IP addresses of all subinterfaces.
I really hope someone will help me with this problem!

4 REPLIES
VIP Advisor

Re: Configuring DHCP-relay with VLAN's

Hello,

 

is your attachment a renamed .pkt (Packet Tracer) file ? Which version did you use ?

Beginner

Re: Configuring DHCP-relay with VLAN's

not a file, accidentally uploaded a screenshot of topology. do you need the file? if so, I can upload it
VIP Advisor

Re: Configuring DHCP-relay with VLAN's

Hello,

 

that will be the best and fasted way to help. Save the .pkt file and rename it to a .jpg file, otherwise the system will not let you upload it...

Beginner

Re: Configuring DHCP-relay with VLAN's

done, edited the post. I'm using version 6.3

CreatePlease to create content
Ask the Expert- MPLS troubleshooting