cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
508
Views
0
Helpful
2
Replies
Highlighted
Beginner

Configuring EIGRP on 2 6509 that has HSRP interfaces

My main 6509 and I call it that because it is configured to be the Active partner in HSRP.  Below is the HSRP configuration for Switch 1 and Switch 2. I want to turn on HSRP for Switch 1.  It should be as simple as below.

router eigrp 10

Network 192.168.240.0

Network 192.168.242.0

Network 192.168.253.0

Network 192.168.254.0

autonomous-system 101
 

 

Should I use this same eigrp configuration for the standby HSRP device (Switch 2)?

Should I only advertise the networks that have vlan interfaces on my switches?

Also vlan 255 is a management address so I should not advertise it with a network statement on either switch? Also I should not be pointing the management address at a standby right?

Is there any thing missing from my configuration?

 

interface vlan 240

des VOIP

ip address 192.168.240.253 255.255.255.0

standby 240 ip 192.168.240.1

standby 240 priority 128

standby 240 preempt delay minimum 300

 

interface vlan 242

ip address 192.168.242.2 255.255.255.0

standby 242 ip 192.168.242.1

standby 242 priority 255

standby 242 preempt delay minimum 300

 

interface vlan 253

ip address 192.168.253.2 255.255.255.0

standby 253 ip 192.168.253.1

standby 253 priority 255

standby 253 preempt delay minimum 300

 

interface vlan 254

ip address 192.168.254.2 255.255.255.0

standby 254 ip 192.168.2542.1

standby 254 priority 255

standby 254 preempt delay minimum 300

 

interface vlan 255

ip address 192.168.1.253 255.255.255.0

standby 254 ip 192.168.1.1

standby 254 priority 110

standby 254 preempt delay minimum 300

 

Switch2

interface vlan 240

des VOIP

ip address 192.168.240.254 255.255.255.0

standby 240 ip 192.168.240.1

standby 240 priority 128

standby 240 preempt delay minimum 300


interface vlan 242

ip address 192.168.242.254 255.255.255.0

standby 242 ip 192.168.242.1

standby 242 priority 255

standby 242 preempt delay minimum 300


interface vlan 253

ip address 192.168.253.3 255.255.255.0

standby 253 ip 192.168.253.1

standby 253  priority 255

standby 253  preempt delay minimum 300


interface vlan 254

ip address 192.168.254.3 255.255.255.0

standby 254 ip 192.168.254.1

standby 254 priority 255

standby 254 preempt delay minimum 300


interface vlan 255

ip address 192.168.1.254 255.255.255.0

standby 254 ip 192.168.1.1

standby 254 priority 110

standby 254 preempt delay minimum 300

 

 

 

 

 

Everyone's tags (3)
2 REPLIES 2
Highlighted
Hall of Fame Expert

You need to configure both

You need to configure both switches with the same EIGRP domain and vlan info, but you should use passive interface for all your vlans except the transit vlan so the peering is established using the transit vlan. So create vlan as a transit vlan and give it ip address and don't make it passive.

HTH 

 

Highlighted
Beginner

Your HSRP priorities should

Your HSRP priorities should follow your spanning-tree root.  If switch 1 is your STP root it should also be router HSRP primary (higher priority).  I would avoid setting HSRP priority at the max of 255 as it doesn't leave room to preempt it with another device if you need to preform a manual switch over, I would pick a lower number such as 250, add standby xxx preempt, and leave your standby switch priority at default(100).

 

Your EIGRP configuration looks correct.  Are there any Layer3 links between these switches?  You may want to consider making some of those VLANs passive in EIGRP using either "passive-interface vlan xxx" or "passive-interface default" with "no passive-interface vlan xxx"

CreatePlease to create content
Content for Community-Ad