cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1401
Views
0
Helpful
5
Replies
Beginner

Connect 2 routers to cable modem

Hey guys i'm struggling here any help will be greatly appreciated.

i have 2 routers with a switch and pc connected to the switch.

i  am working on RIP and i enabled it on both routers.

my current set up is this:

PC---Switch(3550)---Router2(2610)---Router1(2610)--- Cable modem

I am able to ping from pc to Router1. I am able to ping 4.2.2.2 and google from Router1 but unable to ping it from Router 2 and pc.

Here is my config for Router1:

Current configuration : 1089 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.20.2 255.255.255.252

ip nat inside

!

interface Serial0/1

no ip address

shutdown

!

router rip

version 2

network 192.168.20.0

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 dhcp

!

no ip http server

no ip http secure-server

ip nat inside source list 1 interface Serial0/0 overload

!

access-list 1 permit 192.168.0.0 0.0.255.255

!

!

control-plane

!

!

line con 0

exec-timeout 0 0

password cisco

logging synchronous

login

line aux 0

line vty 0 4

password cisco

login

line vty 5 181

password cisco

login

!

!

end

Here is my config for Router2:

Current configuration : 978 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

interface FastEthernet0/0

ip address 192.168.30.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.20.1 255.255.255.252

clock rate 64000

!

interface Serial0/1

no ip address

shutdown

!

!

router rip

version 2

network 192.168.20.0

network 192.168.30.0

no auto-summary

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

line con 0

exec-timeout 0 0

password cisco

logging synchronous

login

line aux 0

line vty 0 4

password cisco

login

line vty 5 181

password cisco

login

!

!

end

Everyone's tags (5)
3 ACCEPTED SOLUTIONS

Accepted Solutions
Enthusiast

Re: Connect 2 routers to cable modem


Try to add default route 0.0.0.0/0 to router 2 that points to router 1.

Highlighted
Enthusiast

Re: Connect 2 routers to cable modem

Forgot to mention: you can also add redistribute static to your router rip configuration section.

Re: Connect 2 routers to cable modem

I think your NAT statement is wrong, serial 0/0 is your internal interface, you should specify fa0/0 in your nat statment if I am not mistaken.

this --> ip nat inside source list 1 interface fa0/0 overload

instead of -->

ip nat inside source list 1 interface Serial0/0 overload

5 REPLIES 5
Enthusiast

Re: Connect 2 routers to cable modem


Try to add default route 0.0.0.0/0 to router 2 that points to router 1.

Highlighted
Enthusiast

Re: Connect 2 routers to cable modem

Forgot to mention: you can also add redistribute static to your router rip configuration section.

Beginner

Re: Connect 2 routers to cable modem

I never did redistribution on a static route. I'll look it up and try it on Friday when I get back home. Thanks for the tips.

Beginner

Re: Connect 2 routers to cable modem

I added static redistribution to the rip config and added the ip static route to router 2 and was still unable to ping to outside websites.

Re: Connect 2 routers to cable modem

I think your NAT statement is wrong, serial 0/0 is your internal interface, you should specify fa0/0 in your nat statment if I am not mistaken.

this --> ip nat inside source list 1 interface fa0/0 overload

instead of -->

ip nat inside source list 1 interface Serial0/0 overload

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards