cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1701
Views
0
Helpful
3
Replies

Connecting an HP chassis to a Nexus 5K pair

g.hammond
Beginner
Beginner

Hi,

I am needing a little assistance in verifying a configuration of connecting an HP chassis w/3120 blade chassis to a pair of Nexus 5Ks. We ran into a very unusual issue with a certain chassis and I want to make sure my configuration is right.  On the blade chassis, I have 4 x 1Gig uplinks channeled together.  2 uplinks go to one Nexus and 2 go to the other.  Their config is as follows.  I need someone to look at the configuration of the ports below and verify that #1 it is correct, and second, if its not, what am I missing in the configuration.

Thanks,

Greg

On the chassis switch:

interface GigabitEthernet1/0/19

description Link to STLMON5K-1

switchport trunk native vlan 506

switchport trunk allowed vlan 1-263,265-4094

switchport mode trunk

channel-protocol lacp

channel-group 11 mode active

            

interface GigabitEthernet2/0/19

description Link to STLMON5K-1
switchport trunk native vlan 506

switchport trunk allowed vlan 1-263,265-4094

switchport mode trunk

channel-protocol lacp

channel-group 11 mode active

interface GigabitEthernet3/0/19
description Link to STLMON5K-2
switchport trunk native vlan 506
switchport trunk allowed vlan 1-263,265-4094
switchport mode trunk
channel-protocol lacp
channel-group 11 mode active

interface GigabitEthernet4/0/19

description Link to STLMON5K-2

switchport trunk native vlan 506

switchport trunk allowed vlan 1-263,265-4094

switchport mode trunk

channel-protocol lacp

channel-group 11 mode active

interface Port-channel11

description VpC to Nexus 5K

switchport trunk native vlan 506

switchport trunk allowed vlan 1-263,265-4094

switchport mode trunk

-----------------------------------------------------------------------

On the Nexus switches:

STLMON5K-1

interface port-channel200

  description stlp66bc01-sw 10.200.6.98

  switchport mode trunk

  switchport trunk native vlan 506

  vpc 200

interface Ethernet4/7

  description stlp66bc01-sw 10.200.6.98

  switchport mode trunk

  switchport trunk native vlan 506

  speed 1000

  channel-group 200 mode active

interface Ethernet4/7

  description stlp66bc01-sw 10.200.6.98

  switchport mode trunk

  switchport trunk native vlan 506

  speed 1000

  channel-group 200 mode active

STLMON5K-2

interface port-channel200

  description stlp66bc01-sw 10.200.6.98

  switchport mode trunk

  switchport trunk native vlan 506

  vpc 200

interface Ethernet4/7

  description stlp66bc01-sw 10.200.6.98

  switchport mode trunk

  switchport trunk native vlan 506

  speed 1000

  channel-group 200 mode active

interface Ethernet4/8

  description stlp66bc01-sw 10.200.6.98

  switchport mode trunk

  switchport trunk native vlan 506

  speed 1000

  channel-group 200 mode active

3 REPLIES 3

Reza Sharifi
Hall of Fame Expert Hall of Fame Expert
Hall of Fame Expert

Hi,

Your configuration is correct.  Is there a reason you are not using the same Portchannel ID on both sides?

Al though, it works fine when you use a different number on each side, but for simplicity, I would make them the same and also use the same id for vPC too.

You really don't need this command

channel-protocol lacp

as LACP will manage the channels.

Also, you already have vPC running between the 5ks right?

HTH

Thanks for the verification.  I have several blade chassis and use port channel 11 as the uplink to the network on all of them. 

vPC is running between the 5ks.

The issue I had run into was servers not being able to ping each other even though they were on the sam vlan.  Also, some servers could ping each other but couldn't connect to a service, like SQL, on another server. 

Hey I know it has been a long time. But do you remember if you ever resolved this issue and what the issue was? I am struggling with the same thing.

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: