cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1501
Views
0
Helpful
25
Replies
NetworkMan23
Beginner

Connecting L3 Devices through a L2 Switch

I seem to of been having issues with basic connectivity between a network-enabled PDU and a Cisco 4500-X. 

 

Please see the attached topology file for more information. 

 

I have a 4500-X with a management IP on it, connected in a port-channel to a 2960-X. An Intelligent PDU then hangs off the 2960-X and all interfaces are within VLAN 55. I have a IP on the PDU as 10.22.4.84 and its D.G. is 10.22.4.83.

 

However, I cant even ping the PDU from the 4500-X. Any help is appreciated. 

25 REPLIES 25

Using EtherChannels before devices,

 

Any help is appreciated here

Thanks for confirming that the connection is Etherchannel and for posting the outputs. It does confirm that the trunk is carrying vlan 55 and that the svi for vlan 55 is on the 4500 and is in the up/up state. Would you post the output of show interface status on the 2960 and identify which port is the connection for your device that you are attempting to ping?

 

I notice that the management interface on the 4500 is up/up but that the management interface on the 2960 is down. This is probably not related to your problem pinging but I wonder what is going on with this.

 

HTH

 

Rick

HTH

Rick

2960#
2960#show interface status

Port Name Status Vlan Duplex Speed Type
Gi1/0/1 Link to iPDU connected 11 a-full a-100 10/100/1000BaseTX
Gi1/0/2 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/3 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/4 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/5 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/6 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/7 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/8 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/9 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/10 notconnect 100 auto auto 10/100/1000BaseTX
Gi1/0/11 notconnect 1 auto auto 10/100/1000BaseTX

Port Name Status Vlan Duplex Speed Type
Gi1/0/12 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/13 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/14 1/2 LINK TO 4500-X connected trunk a-full a-1000 10/100/1000BaseTX
Gi1/0/15 2/2 Link to 4500-X connected trunk a-full a-1000 10/100/1000BaseTX
Gi1/0/16 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/17 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/18 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/19 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/20 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/21 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/22 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/23 notconnect 1 auto auto 10/100/1000BaseTX

Port Name Status Vlan Duplex Speed Type
Gi1/0/24 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/25 notconnect 1 auto auto Not Present
Gi1/0/26 notconnect 1 auto auto Not Present
Gi1/0/27 notconnect 1 auto auto Not Present
Gi1/0/28 notconnect 1 auto auto Not Present
Po5 Bundle to 4500-X connected trunk a-full a-1000
Fa0 Management link in notconnect routed auto auto 10/100BaseTX
2960#

Thanks for the output. Would you post the output of the command show vlan on the 2960?

 

HTH

 

Rick

HTH

Rick

2960#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi1/0/2, Gi1/0/3, Gi1/0/4
Gi1/0/5, Gi1/0/6, Gi1/0/7
Gi1/0/8, Gi1/0/9, Gi1/0/11
Gi1/0/12, Gi1/0/13, Gi1/0/16
Gi1/0/17, Gi1/0/18, Gi1/0/19
Gi1/0/20, Gi1/0/21, Gi1/0/22
Gi1/0/23, Gi1/0/24, Gi1/0/25
Gi1/0/26, Gi1/0/27, Gi1/0/28
11 iPDU services active Gi1/0/1
21 cisco_inside active
100 TEST_MGMT_VLAN active Gi1/0/10
101 Management_Access active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
11 enet 100011 1500 - - - - - 0 0
21 enet 100021 1500 - - - - - 0 0
100 enet 100100 1500 - - - - - 0 0
101 enet 100101 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
2960#

The discussion in the preceding posts has been based on the PDU being in vlan 55. The output that you posted tells us that there is no vlan 55 on this switch and that the PDU is assigned to vlan 11.

11 iPDU services active Gi1/0/1

 

HTH

 

Rick

HTH

Rick

Hi



Sorry, I have changed VLAN numbering since, VLAN 11 = 55. Hope this helps


All of the output we have been working with reflected using vlan 55. Now the vlan assignments have changed. Can you post the output of these commands on both switches

show ip interface brief

show interface status

show interface trunk

show vlan

and on the switch that has the svi for the vlan

show arp

 

HTH

 

Rick

HTH

Rick

OK I will do, however wherever you see vlan 55, it's the same as vlan 11.



Hope this helps.



Thanks


Hey



Do you have any further understanding of the situation? Vlan 11 = vlan 55



Thanks


Without the refreshed data that I requested I do not have any further understanding.

 

HTH

 

Rick

HTH

Rick