cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
574
Views
15
Helpful
7
Replies
Highlighted
Beginner

Connecting "fast ethernet" to "ethernet" is not working!

Hey there,

I connected "FE 0/1" (cisco 1841) to "Ethernet 1/0" ( NM-4E module in 2651 router). Both interfaces' status are up but their line protocol is down.

I sat both their speed to 10Mbps and their duplux to full but no luck.

Is this because i am using a straight-throught cable? According to my understanding all cisco routers uses "Auto-Mdix" feature which eleminates the need for cross-over cables.

Thanks,

Abdul,

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advisor

Hi,

Auto mdix needs autonegotiation and not all devices or modules  support this feature.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

7 REPLIES 7
Highlighted
Hall of Fame Guru

Abdul

According to my understanding all cisco routers uses "Auto-Mdix" feature which eleminates the need for cross-over cables.

Most switches support that feature but not necessarily routers. If you were using a switch module in the router then it would probably support it but i'm not sure the onboard ports do.

Jon

Highlighted
Advisor

Hi,

Auto mdix needs autonegotiation and not all devices or modules  support this feature.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

Highlighted

HI Alain,

Another good peice of information, I was not really aware of this. I was under the impression that auto mdix works and is independent of speed/duplex settings. There definitely must be a reason behind auto mdix needing auto nego ON. If you could put some light on that too please

Regards

Umesh

Highlighted

Hi,

although it is a very laconic explanation, it is explained here:

http://www.cisco.com/c/en/us/td/docs/routers/access/3200/hardware/guide/C3200ISR_HWRG/MR20fesm.pdf

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted

Alain,

You are right. As it turns out, the "NM-4E" module is very very old and it lacks autonegotiation feature thus no auto-mdix.

I used cross-over cables and everything works fine now.

Abdul,

Highlighted
Enthusiast

Do you see something in log?

As I understand you have L2 issue - have you tried with static "half-duplex" on both sides?

HTH,
Dragan

HTH,
Dragan
Highlighted

Alain reminds us that auto mdix needs autonegotiation and Abdul tells us that he is hard coding the speed and duplex. I think that the simple thing is to try a crossover cable and see if the connection works with that.

HTH

Rick

HTH

Rick
Content for Community-Ad