cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1185
Views
0
Helpful
3
Replies

Creating a Port-Channel on New N9K system

scottcummins
Beginner
Beginner

Good Day Cisco Community

I have a Dell PowerEdge R420 Server with 2 Broadcom NetExtreme ethernet adapters both 1GB. The server is loaded with Windows 2008 R2 Server

I am trying to team the adapters using the Broadcom Advanced Control Suite software using LACP. 

 

I have a 2 NEW Nexus 9504 core devices configured as a single core switch with two N9K-X9464PX blades each. I also have two NEXUS 2348TQ-E  set as FEX devices which expand my core device logically

 

My port channel is configured as such on BOTH Core systems

 

interface port-channel200

description **VV11 Server**
shutdown
switchport mode trunk
switchport trunk native vlan 999
switchport trunk allowed vlan 2-4094
spanning-tree port type edge trunk
spanning-tree bpduguard disable
flowcontrol send on
vpc 200

 

On both 9504's I have an ethernet port configured as such

 

interface Ethernet102/1/37

description **VV11 NIC 1**
switchport mode trunk
switchport trunk native vlan 999
switchport trunk allowed vlan 2-4094
spanning-tree port type edge trunk
spanning-tree bpduguard disable

 

When I try to add the port to Port Channel 200 I get the following no matter how I configure it

 

channel-group 200 mode on
command failed: port not compatible:[Emulated switch port type policy]
** You can use force option to override the port's parameters
** (e.g. "channel-group X force")
** Use "show port-channel compatibility-parameters" to get more information on failure.

 

I have created other port channels on here but they are used to connect other switches to the core, this a is the first server type device and it is not cooperating, can anyone assisty in why it will not allow me to add the ethernet ports to the port channel?

3 Replies 3

Mark Malone
Mentor
Mentor
Hi
You dont use the vpc bit when you already have it connected to a FEX
remove VPC 200 under the POand it will work or else use vpc and then use a standard port like e1/10 , non fex port

example from my NX FEXes with POs



interface port-channel26
description
switchport mode trunk
no lacp suspend-individual
switchport trunk allowed vlan 1-1005,1226



!Command: show running-config interface Ethernet118/1/13
!Time: Tue Mar 10 17:28:22 2020

version 7.3(3)N1(1)

interface Ethernet118/1/13
description
switchport mode trunk
switchport trunk allowed vlan 1-1005,1226
channel-group 26 mode active


Mark

 

That certainly helped in getting me a long way

 

So when I confiogured the second port on my other FEX, I go this error

 

gbnexus_9504-1(config-if)# channel-group 200 mode active
command failed: port not compatible:[Members in multiple FEX]
** You can use force option to override the port's parameters
** (e.g. "channel-group X force")
** Use "show port-channel compatibility-parameters" to get more information on failure

 

My config looks like this

 

  interface port-channel200
description **VV11**
switchport mode trunk
switchport trunk native vlan 999
switchport trunk allowed vlan 2-4094
spanning-tree port type edge trunk
spanning-tree bpduguard disable
no lacp suspend-individual

 

 

interface Ethernet102/1/37
description **VV11 NIC 1**
switchport mode trunk
switchport trunk native vlan 999
switchport trunk allowed vlan 2-4094
spanning-tree port type edge
channel-group 200 mode active
no shutdown

 

It gives me that error when trying to add the port on a different FEX  into the port channel

 

interface Ethernet101/1/42
description **VV11 NIC 2**
switchport mode trunk
switchport trunk native vlan 999
switchport trunk allowed vlan 2-4094
spanning-tree port type edge
no shutdown

 

 

 

 

 

This error occurs because the port channel will only work with both links are either connected to the same logical or physical switch. This is why we use the vPC configuration because it makes 2 switches look like one switch to the downstream device. Your FEX are connected to the core switch but still look like separate switches.

 

You can try pairing the FEX to both of your core switches. The only issue is that both of them will load on both core switches so if you have FEX100 on one side and FEX101 on the other when you do a sh int st you will see FEX100 and FEX101 ports on both switches. This should solve your issue with port channel connections to the FEX.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers