cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

5102
Views
0
Helpful
30
Replies
Highlighted

Destination Host Unreachable

So I've set up a small lab in GNS3, and I don't know why I can't ping to my default gateway as I've seem to keep getting destination host unreachable. I've narrowed down the problem to the switch I'm using, because without the switch I know I can ping the default gateway just fine. I can also ping from the router to the Switch just fine. The host is 10.0.4.2/28 with a default gateway of 10.0.4.1 running Windows 10 Education edition, and is on VMnet3. Everything in the diagram is running on VMxnet3. 

R1 config (Cisco CSR1000v 3.17-1):

 

R1#show run
Building configuration...

Current configuration : 1196 bytes
!
! Last configuration change at 18:17:48 UTC Thu Mar 23 2017
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
platform console serial
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!

 

!
!
!
!
!
!
!
!
!
!
subscriber templating
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CSR1000V sn 9Q8I81X14TB
!
spanning-tree extend system-id
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet1
no ip address
negotiation auto
!
interface GigabitEthernet1.1
encapsulation dot1Q 1 native
ip address 10.0.4.1 255.255.255.240
!
interface GigabitEthernet2
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet3
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4
no ip address
shutdown
negotiation auto
!
!
virtual-service csr_mgmt
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
stopbits 1
line vty 0
login
line vty 1
login
length 0
line vty 2 4
login
!
!
end

 

SW1 (Cisco IOSvL2 15.2.4055-1):

 

SW1#show run
Building configuration...

Current configuration : 3707 bytes
!
! Last configuration change at 18:32:36 UTC Thu Mar 23 2017
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
switchport trunk allowed vlan 1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
switchport mode access
media-type rj45
negotiation auto
spanning-tree portfast edge
!
interface GigabitEthernet0/2
media-type rj45
negotiation auto
!
interface GigabitEthernet0/3
media-type rj45
negotiation auto
!
interface GigabitEthernet1/0
media-type rj45
negotiation auto
!
interface GigabitEthernet1/1
media-type rj45
negotiation auto
!
interface GigabitEthernet1/2
media-type rj45
negotiation auto
!
interface GigabitEthernet1/3
media-type rj45
negotiation auto
!
interface GigabitEthernet2/0
media-type rj45
negotiation auto
!
interface GigabitEthernet2/1
media-type rj45
negotiation auto
!
interface GigabitEthernet2/2
media-type rj45
negotiation auto
!
interface GigabitEthernet2/3
media-type rj45
negotiation auto
!
interface GigabitEthernet3/0
media-type rj45
negotiation auto
!
interface GigabitEthernet3/1
media-type rj45
negotiation auto
!
interface GigabitEthernet3/2
media-type rj45
negotiation auto
!
interface GigabitEthernet3/3
media-type rj45
negotiation auto
!
interface Vlan1
ip address 10.0.4.3 255.255.255.240
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
banner exec ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
banner incoming ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
banner login ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
!
line con 0
line aux 0
line vty 0 4
!
!
end

 

Any help would be greatly appreciated, thanks!

30 REPLIES 30
Enthusiast

The supported switch in GNS3

The supported switch in GNS3 is a generic switch. However, try to hard code the speed/duplex on all active interfaces. I hope this helps. Good luck!

Well It's on auto neg, so it

Well It's on auto neg, so it should be fine right? Also in GNS3 they added templates for these VIRL appliances so I'm assuming they are supported. Thanks for the reply though.

Enthusiast

I guess I missed that VIRL

I guess I missed that VIRL and GNS3. I still recommend to hard code these ports and see how it goes. 

I hard coded the ports to

I hard coded the ports to full duplex, and still no luck. 

Enthusiast

And hard code the speed

And hard code the speed please.

I'll do this when I get home.

I'll do this when I get home.

Hall of Fame Master

I have looked at the posted

I have looked at the posted configs and they seem reasonable. I do not see an obvious problem with either config that would produce these symptoms.

I note in the screenshot of the attempted ping that the error message is coming from 10.0.4.2. This makes me wonder if it is perhaps an issue with the host. Or perhaps with the connection of the host to the switch.

Here are a few things that you might do in terms of troubleshooting on the devices:

- on the switch do show interface status. check on the status of the port connecting the host. also check the status of the interface connecting to the router.

- on the router do show ip interface brief. check the state of the connection to the switch.

- on the router do a show arp. look to see if the switch IP address and the host IP address are in the table.

HTH

Rick

R1(config)#do show ip int

R1(config)#do show ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet1 unassigned YES unset up up
GigabitEthernet1.1 10.0.4.1 YES manual up up
GigabitEthernet2 unassigned YES unset administratively down down
GigabitEthernet3 unassigned YES unset administratively down down
GigabitEthernet4 unassigned YES unset administratively down down


R1(config)#do show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.4.1 - 008a.1444.cf00 ARPA GigabitEthernet1.1
Internet 10.0.4.3 42 008a.1423.8001 ARPA GigabitEthernet1.1

SW1(config)#do show interface status

Port Name Status Vlan Duplex Speed Type
Gi0/0 connected trunk auto auto unknown
Gi0/1 connected 1 auto auto unknown
Gi0/2 connected 1 auto auto unknown
Gi0/3 connected 1 auto auto unknown
Gi1/0 connected 1 auto auto unknown
Gi1/1 connected 1 auto auto unknown
Gi1/2 connected 1 auto auto unknown
Gi1/3 connected 1 auto auto unknown
Gi2/0 connected 1 auto auto unknown
Gi2/1 connected 1 auto auto unknown
Gi2/2 connected 1 auto auto unknown
Gi2/3 connected 1 auto auto unknown
Gi3/0 connected 1 auto auto unknown
Gi3/1 connected 1 auto auto unknown
Gi3/2 connected 1 auto auto unknown
Gi3/3 connected 1 auto auto unknown

Hall of Fame Guru

There is no sign of the host

There is no sign of the host's mac address on the router. Can you ping 10.0.4.3 from the host ?

Jon

I cannot. 

I cannot. 

Hall of Fame Guru

Okay so I assume all ports by

Okay so I assume all ports by default are in vlan 1 on the switch ie. can you just check with "sh vlan brief".

If so then when you ping what do the arp tables on both devices look like ?

Jon

Hall of Fame Master

Can you post a screen shot of

Can you post a screen shot of a display of the arp table from the PC? Maybe also the output of route print

HTH

Rick

Thanks for the quick replies.

Thanks for the quick replies. Here is the arp table, and route print.

Hall of Fame Master

Thank you for the additional

Thank you for the additional information. The route print looks normal. I am surprised that the arp -a does not see any other device on the subnet. I am convinced that is why your attempts to ping are getting error messages from 10.0.4.2. It is not able to successfully arp for any other device. I believe that there is some problem with the connection of PC to switch. But I am not sure what that problem is. Is there possibly some VM issue?

HTH

Rick

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards