cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7246
Views
0
Helpful
30
Replies
Highlighted

Destination Host Unreachable

So I've set up a small lab in GNS3, and I don't know why I can't ping to my default gateway as I've seem to keep getting destination host unreachable. I've narrowed down the problem to the switch I'm using, because without the switch I know I can ping the default gateway just fine. I can also ping from the router to the Switch just fine. The host is 10.0.4.2/28 with a default gateway of 10.0.4.1 running Windows 10 Education edition, and is on VMnet3. Everything in the diagram is running on VMxnet3. 

R1 config (Cisco CSR1000v 3.17-1):

 

R1#show run
Building configuration...

Current configuration : 1196 bytes
!
! Last configuration change at 18:17:48 UTC Thu Mar 23 2017
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
platform console serial
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!

 

!
!
!
!
!
!
!
!
!
!
subscriber templating
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CSR1000V sn 9Q8I81X14TB
!
spanning-tree extend system-id
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet1
no ip address
negotiation auto
!
interface GigabitEthernet1.1
encapsulation dot1Q 1 native
ip address 10.0.4.1 255.255.255.240
!
interface GigabitEthernet2
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet3
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4
no ip address
shutdown
negotiation auto
!
!
virtual-service csr_mgmt
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
stopbits 1
line vty 0
login
line vty 1
login
length 0
line vty 2 4
login
!
!
end

 

SW1 (Cisco IOSvL2 15.2.4055-1):

 

SW1#show run
Building configuration...

Current configuration : 3707 bytes
!
! Last configuration change at 18:32:36 UTC Thu Mar 23 2017
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
switchport trunk allowed vlan 1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
switchport mode access
media-type rj45
negotiation auto
spanning-tree portfast edge
!
interface GigabitEthernet0/2
media-type rj45
negotiation auto
!
interface GigabitEthernet0/3
media-type rj45
negotiation auto
!
interface GigabitEthernet1/0
media-type rj45
negotiation auto
!
interface GigabitEthernet1/1
media-type rj45
negotiation auto
!
interface GigabitEthernet1/2
media-type rj45
negotiation auto
!
interface GigabitEthernet1/3
media-type rj45
negotiation auto
!
interface GigabitEthernet2/0
media-type rj45
negotiation auto
!
interface GigabitEthernet2/1
media-type rj45
negotiation auto
!
interface GigabitEthernet2/2
media-type rj45
negotiation auto
!
interface GigabitEthernet2/3
media-type rj45
negotiation auto
!
interface GigabitEthernet3/0
media-type rj45
negotiation auto
!
interface GigabitEthernet3/1
media-type rj45
negotiation auto
!
interface GigabitEthernet3/2
media-type rj45
negotiation auto
!
interface GigabitEthernet3/3
media-type rj45
negotiation auto
!
interface Vlan1
ip address 10.0.4.3 255.255.255.240
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
banner exec ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
banner incoming ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
banner login ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
!
line con 0
line aux 0
line vty 0 4
!
!
end

 

Any help would be greatly appreciated, thanks!

30 REPLIES 30
Highlighted

Well it works when plugged directly to the router so I was thinking it was something with the switch not forwarding arp packets. Here are some of the vmware pictures.

Highlighted

The switch isn't even seeing the arp packets at the moment. Out of interest when you connected directly to the router presumably you were not trunking ?

Jon

Highlighted

Yes nothing was trunking just the host connected to the router.

Highlighted

Not sure what else to say really. I initially was going to suggest just configuring the switch to router connection as an access port or using the main interface for the native vlan which you can do but as the switch doesn't  even see an arp request from the client I doubt that will make any difference.

Jon

Highlighted

I would say its the VM switch. I bet if you replace your VIRL switch with GNS3 Generic one it will work.

Highlighted

It does seem to be pointing that way :)

Jon

Highlighted

I'll try this when I get home, thanks!

Highlighted

Also, as your switch is a VIRL VM, then it lives outside GNS3 internal network. Change your VM network adapter setting to "bridged" mode. 

Highlighted

Just got home. Tried the new switch that is supported still no luck, take a look at the picture for the config of the supported switch. Just saying though, GNS3 did post appliances for the Cisco IOSvL2 so it is also supported by the way. My switch is in VMxnet3 which is perfectly fine on a host only adapter. That should change anything so I don't understand where you are going with that, as long as everything is on the same VMxnet, and VMnet as far as my understanding goes. Any other suggestions?

Highlighted

I looked at the picture of the supported switch and what I see looks fine.

It occurs to me that our testing so far has been using the router and switch attempting to access the PC and finding no arp content in the PC. I would suggest also doing a test with the PC attempting to access either the router or switch or both. Attempt a ping from the PC and as soon as it finishes do arp -a and post output.

And just before I hit enter for this suggestion an additional thought occurred to me. On the router enable debug arp before you do this test. Also enable either or both of logging monitor and logging buffered at level of debug. Do the test with PC attempting to ping. After the test check the logs on the router and see if there is debug output (which would indicate that the router saw an arp request from the PC)

HTH

Rick

HTH

Rick
Highlighted

Thanks for this suggestion, but as I reopened my project the switch, and I believe the router deleted all the configs. So I'll have to paste them back in. Currently at work, and i'll try this when I get home, thanks!

Highlighted

Sorry that the configs were deleted. It happens sometimes, especially with test environments. Good luck getting it back up and established again. Sometimes removing the config and then re-doing the config will clear up mysterious problems. I hope that is the case here.

Once you get it back up let us know how it is doing.

HTH

Rick

HTH

Rick
Highlighted

Any luck :)

Highlighted

Great. Can you please connect a VPCs host to this switch and check if you can ping your gateway? 

See attachment. 

Highlighted

I looked at the virtual editor output and notice that it is using an incorrect mask for the address. The virtual editor shows a mask of 255.0.0.0. I do not see how that could produce the symptoms that we are dealing with. But having noticed something not right I want to point it out - just in case it triggers someone else to come up with a different theory of what is happening.

HTH

Rick

HTH

Rick
Content for Community-Ad