cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6195
Views
6
Helpful
16
Replies
konopkad
Beginner

DHCP and VLAN on 3560

I setup VLANs on Catalyst 3560 (8 port, PoE). The switch is connected vial trunk link to Brocade SuperX 800 switch. When I plug in a laptop to one of the Voip VLANs on 3560, it gets DHCP lease fine. If I plug in Polycomm phone instead, it doesn't get DHCP lease. If I setup static IP on the phone, the phone works fine. Why the phone doesn't get DHCP? It must be something not configured on the 3560, I just don't know what. the phone with DHCP works fine if connected directly to the Brocade switch. What am I missing on the 3560?

VLAN101 is VOIP vlan and FastEthernet0/1 port is was tested.

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Catalyst3560
!

!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
switchport access vlan 101
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface GigabitEthernet0/1
switchport access vlan 30
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 30,101
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
no ip address
!
interface Vlan30
ip address 172.16.80.5 255.255.252.0
!
ip classless
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
  login
line vty 5 15
login
!
end

16 REPLIES 16

Thanks for confirming the vvid!

Start up delay should be caused by Spanning-tree.

By default, with the original configuraiton posted for port f0/1, it could take up to 30-45 seconds to get connectivity to the network (a mix of STP and DHCP timers etc)

#spanning-tree portfast

is part of best practice host port configuration (I would recommend it being configured on all host ports in the network).

Benefits:

- reduce start up time -> port goes straight into forwarding instead of going through the STP state transitions, listening, learning etc

- does not generate a TCN upon link up or down (improves accuracy of TCN flag in STP topology and troubleshooting)

You'll also see this recommendation in Cisco IP Phone guides such as:

http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_example09186a0080722cdb.shtml

(contact web-help@cisco.com if unable to access)

HTH

Eugene.

Thank you again!