cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
607
Views
0
Helpful
8
Replies

DHCP on 2811 not working

Hulk8647
Level 1
Level 1

Image attached. I am trying to figure out why DHCP is not working on the R1, 2811. I have configured dhcp with the following parameters:

R1#show run | sec dhcp
no ip dhcp use vrf connected
ip dhcp pool V10
   network 10.150.10.0 255.255.255.0
   default-router 10.150.10.1

ESW1 has a vlan 10.150.10.1 and I configured ip helper which is 11.11.11.11 it resides on R1:

ESW1#show run int vl 10
Building configuration...
Current configuration : 93 bytes
!
interface Vlan10
 ip address 10.150.10.1 255.255.255.0
 ip helper-address 11.11.11.11
end

R1#show ip int br | ex un
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.10.10.2     YES manual up                    up
FastEthernet0/1            172.10.20.2     YES manual up                    up
Loopback1                  11.11.11.11     YES manual up                    up

I am able to reach the 11.11.11.11 all the way from ESW3.

ESW3#ping 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/25/36 ms

My host R2 at the bottom is unable to get DHCP. It's interface is configured for DHCP. I have the host in vlan 10 and checks the status and it's all UP UP. I did debug on R1 and this is what I get:

R1#debug ip dh se
*Mar  1 00:09:04.807:   DHCPD: htype 1 chaddr c007.1bfc.0000
*Mar  1 00:09:04.811:   DHCPD: remote id 020a0000ac0a0a0200000000
*Mar  1 00:09:04.811:   DHCPD: circuit id 00000000
*Mar  1 00:09:04.811: DHCPD: Seeing if there is an internally specified pool cla                                                                                                                                                             ss:
*Mar  1 00:09:04.811:   DHCPD: htype 1 chaddr c007.1bfc.0000
*Mar  1 00:09:04.811:   DHCPD: remote id 020a0000ac0a0a0200000000
*Mar  1 00:09:04.811:   DHCPD: circuit id 00000000
*Mar  1 00:09:04.815: DHCPD: there is no address pool for 172.10.10.2.


It says " there is no address pool for 172.10.10.2." Why??? Why is it looking at 172.10.10.2? and not 10.150.10.0? Can anyone help? Am I missing a command? Or is the DHCP server too far from the ESW3? Everything below ESW1 and 2 is running trunks and above L3 links.

8 Replies 8

Richard Burts
Hall of Fame
Hall of Fame

This is indicating that R1 received a DHCP request, probably on FastEth0/0 or it had the address of FastEth0/0 in the gateway address field of the DHCP request. Is it possible that something is generating DHCP requests other than R2?

HTH

Rick

HTH

Rick

No, I checked, just R2.

If you are sure that the debug output represents the request from R2 then we need more details about how ESW! and perhaps ESW3 are configured.

HTH

Rick

HTH

Rick

This is ESW1. it's connected to ESW3 via trunk. not much going on there I can provide you the config if you need. Thanks for your help!! Also, f1/15 goes to R1 and 1/1 goes to ESW3

ESW1#show run
Building configuration...

Current configuration : 3311 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname ESW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip domain name look
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
macro name add_vlan
end
vlan database
vlan $v
exit
@
macro name del_vlan
end
vlan database
no vlan $v
exit
@
!
vtp file nvram:vlan.dat
archive
 log config
  hidekeys
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet1/1
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet1/2
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet1/3
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet1/4
 duplex full
 speed 100
!
interface FastEthernet1/5
 duplex full
 speed 100
!
interface FastEthernet1/6
 duplex full
 speed 100
!
interface FastEthernet1/7
 duplex full
 speed 100
!
interface FastEthernet1/8
 duplex full
 speed 100
!
interface FastEthernet1/9
 duplex full
 speed 100
!
interface FastEthernet1/10
 duplex full
 speed 100
!
interface FastEthernet1/11
 duplex full
 speed 100
!
interface FastEthernet1/12
 duplex full
 speed 100
!
interface FastEthernet1/13
 duplex full
 speed 100
!
interface FastEthernet1/14
 duplex full
 speed 100
!
interface FastEthernet1/15
 no switchport
 ip address 172.10.10.1 255.255.255.0
 duplex full
 speed 100
!
interface Vlan1
 ip address 192.168.0.1 255.255.255.0
!
interface Vlan10
 ip address 10.150.10.1 255.255.255.0
 ip helper-address 11.11.11.11
!
interface Vlan20
 ip address 10.150.20.1 255.255.255.0
 ip helper-address 11.11.11.11
!
interface Vlan30
 ip address 10.150.30.1 255.255.255.0
 ip helper-address 11.11.11.11
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.10.10.2
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
banner exec ^C

***************************************************************
This is a normal Router with a Switch module inside (NM-16ESW)
It has been pre-configured with hard-coded speed and duplex

To create vlans use the command "vlan database" in exec mode
After creating all desired vlans use "exit" to apply the config

To view existing vlans use the command "show vlan-switch brief"

Alias(exec)     : vl   - "show vlan-switch brief" command
Alias(configure): va X - macro to add vlan X
Alias(configure): vd X - macro to delete vlan X
***************************************************************

^C
alias configure va macro global trace add_vlan $v
alias configure vd macro global trace del_vlan $v
alias exec vl show vlan-switch brief
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4

Thanks for posting the config. I believe that this is the cause of your problem

no service dhcp

change it to enable the service dhcp and let me know if the behavior changes.

HTH

Rick

HTH

Rick

Hi,

Yeah, I noticed that later on, did not help though. What I did was I configured the same topology in packet-tracer and it works. It does not work in GNS3

Thanks for posting back with this information. It is very interesting that it turns out to be a bug in GNS3.

HTH

Rick

HTH

Rick

I was actually able to get it to work. I enabled DHCP service on ESW3. I didn't know you need the DHCP service enabled on all switched. I thought only the switch that are actually performing dhcp. I saw that you mentioned it, i thought you were talking about the main switch.

Thank you for your help!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card