cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

2566
Views
0
Helpful
9
Replies
Beginner

DHCP Relay on 4500X

Hi Guys,

 

We are facing DHCP relay issue on 4500X (VSS) core switch. The topology is simple, all the access switches has been connected to core on MEC ether channel (L2 trunk, no VLAN/VTP pruning). The DHCP server resided in data center on VM. FYI, It was working fine on Old core (6509)

The problem we are facing is we are not getting an IP from DHCP server. The SVI configured on core switch have IP helper address configured.

However, for testing I created a SVI on access switch (luckily they were 3750's) and put helper address on access SVI and it worked fine. 

So its look like 4500x some how not doing  DHCP relay. BTW, no DHCP snooping is enable. 

I have tried multiple codes 3.5.3 & 3.4.4 but no luck.

 

I appreciate your feedback and help here.

 

Thanks,

Asad Hasan

9 REPLIES 9
Cisco Employee

Hey Asad,Make sure service

Hey Asad,

Make sure service dhcp is configured on switch and also please share the logical topology as well.

Regards,

RS.

Beginner

Hi Rajeesh, Thanks for your

Hi Rajeesh,

 

Thanks for your reply. you mean service DHCP enable on core switch ? yes it is enabled.

sorry I don't have topology at this time. 

 

Regards,

Asad Hasan

 

Beginner

I have uploaded the running

I have uploaded the running configs as well. 

Thanks,

Asad Hasan

Beginner

Check the layer 2 topography

Check the layer 2 topography and run show spanning tree summary. If you run this from the edge switch ensure it is not the root switch, then run show spanning tree vlan xxx.

Check the right ports are trunking the vlan up and post the results back here.

Beginner

hi asadhasan, could fix your

hi

 

could fix your Catalyst 4500X-SFP16+ dhcp relay problem?

 

I faced something similar I believe, running 3.5.3 code:

 

Int vlan X

ip dhcp-helper XXXXX

 

int vlan Z

ip dhcp-helper ZZZZZ

 

now Voice phones on Vlan Z could not receive DHCP IPs where Vlan X and could therefore not register, clients in the data vlan could receive dhcp addresses. After Approx 1 hour 3 o clock in the morning I had to revert back, having the Cat 6500 performing the SVI termination again, rolling back on the Cat4500X as a pure L2 switch again..

 

can you remember what your issues where, if fixed?

please share.

 

Thanks

Colin

Highlighted
Beginner

Did you find the cause of the

Did you find the cause of the DHCP issue?

That would interest me very much. Please let me know.

Hi Asad,Can you upload the

Hi Asad,

Can you upload the output from "show ip route"

Also include the output from "ping 172.18.2.12 source 10.50.105.254"

Regards,

Justin

Beginner

Re: DHCP Relay on 4500X

Did you managed to solve that issue?
I currently facing something very similar to this.
VIP Advisor

Re: DHCP Relay on 4500X

Hello

Your config looks okay I also don't see any option 82 relay enabled either.

you could try debugging it to see whats is happening.

 

access-list 100 permit ip host 0.0.0.0 host 255.255.255.0
access-list 100 permit udp host 10.50.105.254 host 172.18.2.12 eq 67
access-list 100 permit udp host 10.50.105.254 host 172.18.2.12 eq 68
access-list 100 permit udp host 172.18.2.12 host 10.50.105.254 eq 67
access-list 100 permit udp host 172.18.2.12 host 10.50.105.254 eq 68

debug ip packet detail 100
debug dhcp detail

res
Paul

 

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad