cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
33845
Views
1
Helpful
13
Replies

DHCP request failed

Ali Al Habsi
Level 1
Level 1

              Greetings, I have a router conncected to a switch via trunk. And the switch is configures as a server, and the other 2 switches are clients, these two switches have 4 PCs each. Three are 5 VLANS configured. And 5 subinterfaces. But, when i want to receive a dynamic IP address...it fails. Please give me a solution to this problem. I will attach the file.

2 Accepted Solutions

Accepted Solutions

Hello Ali,

There were a few mistakes in the config, I'll upload the file...

The DHCP config was wrong, and there are some other minor faults with the config. I'll fix these and quickly note down so I can tell you what I changed.

Most of it was this:

ip dhcp excluded-address 192.168.10.1 192.168.10.99

ip dhcp excluded-address 192.168.20.1 192.168.20.99

ip dhcp excluded-address 192.168.30.1 192.168.30.99

ip dhcp excluded-address 192.168.40.1 192.168.40.99

!

ip dhcp pool pool1

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

dns-server 8.8.4.2

ip dhcp pool pool2

network 192.168.20.0 255.255.255.0

default-router 192.168.20.1

dns-server 8.8.5.2

ip dhcp pool pool3

network 192.168.30.0 255.255.255.0

default-router 192.168.30.1

dns-server 8.8.6.2

ip dhcp pool pool4

network 192.168.40.0 255.255.255.0

default-router 192.168.40.1

dns-server 8.8.7.2

!

interface FastEthernet0/0

no ip address

duplex full

speed 100

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

!

interface FastEthernet0/0.30

encapsulation dot1Q 30

ip address 192.168.30.1 255.255.255.0

!

interface FastEthernet0/0.40

encapsulation dot1Q 40

ip address 192.168.40.1 255.255.255.0

!

interface FastEthernet0/0.99

encapsulation dot1Q 99

ip address 192.168.99.2 255.255.255.0

Hope this helps.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

Because you need to exclude the addresses that have been used:

ip dhcp excluded-address 192.168.99.1 192.168.99.10

ip dhcp excluded-address 192.168.99.254

ip dhcp pool pool9

network 192.168.99.0 255.255.255.0

default-router 192.168.99.254

I have changed this in the attached.

Hope this helps.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

13 Replies 13

Bilal Nawaz
VIP Alumni
VIP Alumni

Could you kindly tell me the enable password for the router?

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Enable password:class
line console: cisco
line vty: cisco

Hello Ali,

There were a few mistakes in the config, I'll upload the file...

The DHCP config was wrong, and there are some other minor faults with the config. I'll fix these and quickly note down so I can tell you what I changed.

Most of it was this:

ip dhcp excluded-address 192.168.10.1 192.168.10.99

ip dhcp excluded-address 192.168.20.1 192.168.20.99

ip dhcp excluded-address 192.168.30.1 192.168.30.99

ip dhcp excluded-address 192.168.40.1 192.168.40.99

!

ip dhcp pool pool1

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

dns-server 8.8.4.2

ip dhcp pool pool2

network 192.168.20.0 255.255.255.0

default-router 192.168.20.1

dns-server 8.8.5.2

ip dhcp pool pool3

network 192.168.30.0 255.255.255.0

default-router 192.168.30.1

dns-server 8.8.6.2

ip dhcp pool pool4

network 192.168.40.0 255.255.255.0

default-router 192.168.40.1

dns-server 8.8.7.2

!

interface FastEthernet0/0

no ip address

duplex full

speed 100

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

!

interface FastEthernet0/0.30

encapsulation dot1Q 30

ip address 192.168.30.1 255.255.255.0

!

interface FastEthernet0/0.40

encapsulation dot1Q 40

ip address 192.168.40.1 255.255.255.0

!

interface FastEthernet0/0.99

encapsulation dot1Q 99

ip address 192.168.99.2 255.255.255.0

Hope this helps.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

OK.

Okay, so most of the config changes were on R1. This included removing the IP on fa0/0 since it was a trunk.

DHCP configuration was changed as shown in previous post.

There were conflicting IP's on vlan 99 - your management network i assume. So on R1 i made it:

int fa0/0.99

ip address 192.168.99.254 255.255.255.0

and changed the IP's on the switches. I also changed the default gateway. So I've fixed the problem and am able to ping everywhere. Please find attached completed file I hope this helps.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

What about PC0 AND R1 IP Address?

For PC0 you will need to create a DHCP pool for the 99 network.

ip dhcp pool pool9

network 192.168.99.0 255.255.255.0

default-router 192.168.99.1

I hope this helps

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

OK. But now in PC0, when i click the dhcp radio button, It gives me this "This address is already used in the network", and no IP Address is received. But it receives the default gateway.

Because you need to exclude the addresses that have been used:

ip dhcp excluded-address 192.168.99.1 192.168.99.10

ip dhcp excluded-address 192.168.99.254

ip dhcp pool pool9

network 192.168.99.0 255.255.255.0

default-router 192.168.99.254

I have changed this in the attached.

Hope this helps.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Thank you so much Bilal. I learned my mistakes.

Hey thats great! keep it up

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Okay I'm definitely having trouble with mines. I followed the instructions and went back over some work just to make sure that I had got it right, but it still gives me the same reply

What are the requirments ? You are missing pretty much everything including the most basic stuff. Have a look at the file attached. I have:

 

a) added a routing protocol (EIGRP) to your routers

b) deleted the SVIs configured on the upper left switch

c) configured an IP address for Vlan 1 on the Branch_1 router

d) configured IP helper addresses on the subinterfaces of the Branch_1 router

e) configured the link between the switch and the Branch_1 router as a trunk

 

I have a feeling that this is only a very small part of what is missing, but have a look and see if you can figure out the rest...

Review Cisco Networking products for a $25 gift card