cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
698
Views
4
Helpful
10
Replies
Highlighted
Beginner

Distribution Layer

Hello

In my scenario Core and Distribution is the same switch and we got a trunk to the Access-Switch. As we are growing we plan to have a distribution switch. what configuration goes on distribution switch.

Core is in VTP mode server and all Access-Switches in client mode.

Current config example of Core

vlan 5
name USERS

vlan 6
name SERVERS

vlan 7
  name Firewall

interface GigabitEthernet4/1
description SW1
switchport trunk encapsulation dot1q
switchport mode trunk

interface GigabitEthernet4/2
description SW2
switchport trunk encapsulation dot1q
switchport mode trunk

interface Vlan5
description Users
ip address 172.17.0.1 255.255.254.0
no ip redirects

interface Vlan6
  description SERVERS
  ip address 192.168.1.1 255.255.255.0
  no ip redirects

interface Vlan7
  description ASA
  ip address 10.10.5.1 255.255.255.252

router ospf 1

network 172.17.0.1 0.0.1.255 area 0

network 192.168.1.0 0.0.0.255 area 0

network 10.10.5.1 0.0.0.3 area 0

ip route 0.0.0.0 0.0.0.0 10.10.5.2

*****

Configuraiton on Access-Switches

interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
  switchport mode trunk

10 REPLIES 10
Highlighted
Engager

Re: Distribution Layer

what switch are you using for your core/distribution? we use 6500s for our core/distribution layer and expanded by adding more modules/blades on it. see useful link below for proper campus design guideline.

http://www.cisco.com/en/US/docs/solutions/Enterprise/Campus/campover.html#wp708814

Highlighted
Beginner

Re: Distribution Layer

Hello John

Can we connect two uplink from 6500 to same access-switch for redundancy purpose.

       ------------------------------------------------

6500                                                            Access_Switch

       ------------------------------------------------


From configuraiton point of view ; on both ports of 6500 and Access_Switch will it be

switchport trunk encapsulation dot1q

switchport mode trunk

Highlighted
Engager

Re: Distribution Layer

hi anthony,

i don't see the point having redundant connection between your access switch and your core/distribution switch. could you post or describe roughly your network diagram and explain what you're trying to achieve. normally, you would want to do the setup below:

6500 Switch A   ------------------------------------------------

                                                                                           Access_Switch

6500 Switch B   ------------------------------------------------

Highlighted
Beginner

Re: Distribution Layer

Hi John

6500 connects to Access_Switch over Fiber. If there is problem with Fiber then what are my options.

For redundancy purpose can we hook 6500 to access-switch using Giga-Ethernet as trunk.

6500 Switch A   -----------------over Fiber---------------------   Access_Switch1

6500 Switch A   ------------------over GigaEthernet--------- Access_Switch1

Both needs to be connected all times, if fiber is down then traffic should pass on GigaEthernet

It should also not cause any loop issue or asymteric flow

I was trying to understand the above?

Thanks

Anthony

Highlighted
Engager

Re: Distribution Layer

hi anthony,

it would still be a single point of failure if you connect your access switch to the 6500 core. i would recommend to connect your access switch to another core switch, if your budget permits. otherwise, you can just configure an etherchannel link as per your suggested setup.

Highlighted
Beginner

Re: Distribution Layer

Hi

How the configuration looks with One 6500

How the configuration looks with Two 6500

Thank you for supporting the post

<>

Anthony

Beginner

Re: Distribution Layer

Diverting from the original topic one thing that caught my eye is your OSPF design. Can you tell me why are you using discontinuous ip addresses in your Area 0?

Highlighted
Hall of Fame Cisco Employee

Re: Distribution Layer

Ahmed,

Sorry for jumping into discussion slightly abruptly but do you see any problems in using discontiguous addresses in OSPF in Area 0? Sure, it may make their summarization at area borders difficult but no functionality impediment will occur.

Best regards,

Peter

Highlighted
Beginner

Re: Distribution Layer

Hi Peter,

Thanks for the reply. All the study materials and best practices i have come along always used to emphasize on the need of proper OSPF design and grouping discontinous ip addresses in different areas. Since I am fairly new the cisco networking world I wanted to hear about how others actually implement their network. Is it a common practice to have discontinous IP addresses in a OSPF domain from your experience?

AJ

Highlighted
Hall of Fame Cisco Employee

Re: Distribution Layer

Hello Ahmed,

I agree with what you read - it is the best practice in OSPF to use contiguous network in a single area because it allows for easy and efficient address summarization if multiple areas are deployed. The problems with discontiguous networks were most visible in distance-vector routing protocols with automatic network summarization activated, as the automatic summarization, often coupled with other supplementary logic of accepting/ignoring routing information, resulted in one part of the network being unable to reach the other. Thus, using discontiguous networks in distance-vector protocols could indeed result in reachability issues if the automatic network summarization was activated.

The OSPF has no concept of automatic summarization (actually, in OSPF, the summarization is far less flexible than in distance-vector protocols which is a direct result of the link-state approach, not a particular OSPF limitation). Thus, OSPF will be happy with just any addressing, provided that the basic IP connectivity between neighboring routers is up and working. However, using haphazard addressing schemes in an OSPF domain is, as Mr. Jeff Doyle once put it, "an offense to our sense of network aesthetics" It will work but it is a sign of a poor planning, and it also prevents the OSPF from unraveling its full potential with allowing the most efficient address summarization at the area borders. Therefore, the recommendation to use contiguous addressing is indeed the best practice but not a necessary condition to run OSPF successfully.

Whether using discontigous networks in an OSPF area is a common practice... Well, certainly, it is not the best one but I believe it can be seen from time to time. I would personally also try to use contiguous addressing if possible. My whole point is that it is not going to cause any troubles.

Best regards,

Peter

CreatePlease to create content
Content for Community-Ad