cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
319
Views
20
Helpful
6
Replies
Highlighted
Beginner

Dropped DHCP Discover packet

I have a Catalyst 4948 switch running 12.2(54)SG and having an issue with one device receiving a DHCP address.

The Device is the new phone system, an Avaya IP Office 500 V2 R11.

Currently there is a Windows Server running DHCP issuing addresses and every other device can get an IP address except the IP Office. The DHCP server is plugged into port 44 and the IP Office is plugged into port 46.

They are both on VLAN 1. There are other VLANs programmed but not being used.

We set the IP office for DHCP and reboot and it never receives an IP address I can plug a laptop into port 46 and reboot and I receive an IP address.

I then setup a SPAN port to monitor port 46 with wireshark and also setup wireshark on the DHCP server and running them both at the same time I rebooted the IP office and I see the DHCP discover packet being sent out from the IP office on port 46  but it never gets to the DHCP server on port 44.

Meanwhile a laptop on port 46 works perfectly and receives and IP address and I see all of the packets go through

I then decided to try a different port on the switch and Moved the IP office to port 31 and still the same issue no IP address and the DHCP discover packet never gets through the switch to port 44

I then took a dumb 5 port netgear switch and plugged the DHCP server into port 1 and the IP office into port 2 and I reboot the IP office and it gets assigned an IP address from the DHCP server no issues.

I have rebooted the switch just in case there was some issue and still the same problem.

I have a minimal configuration in the switch (see below addressing has been changed)

Does anyone have any ideas on why this would be happening? Is there a way to trace/debug the packet in the switch to see what is causing it to be dropped?

Thanks

 


!
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service compress-config
!
hostname Cisco
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone EST -5
clock summer-time EST recurring
ip subnet-zero
ip domain-name domain.com
ip vrf mgmtVrf
!
!
!
vtp mode transparent
!
!
!
power redundancy-mode redundant
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 99
name DMZ
!
vlan 102
name Internet
!
vlan 103
name MPLS
!
!
!
interface FastEthernet1
ip vrf forwarding mgmtVrf
no ip address
speed auto
duplex auto
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet1/3
!
interface GigabitEthernet1/4
!
interface GigabitEthernet1/5
shutdown
!
interface GigabitEthernet1/6
shutdown
!
interface GigabitEthernet1/7
!
interface GigabitEthernet1/8
!
interface GigabitEthernet1/9
!
interface GigabitEthernet1/10
!
interface GigabitEthernet1/11
!
interface GigabitEthernet1/12
!
interface GigabitEthernet1/13
!
interface GigabitEthernet1/14
!
interface GigabitEthernet1/15
!
interface GigabitEthernet1/16
!
interface GigabitEthernet1/17
shutdown
!
interface GigabitEthernet1/18
!
interface GigabitEthernet1/19
!
interface GigabitEthernet1/20
!
interface GigabitEthernet1/21
!
interface GigabitEthernet1/22
!
interface GigabitEthernet1/23
!
interface GigabitEthernet1/24
!
interface GigabitEthernet1/25
!
interface GigabitEthernet1/26
!
interface GigabitEthernet1/27
!
interface GigabitEthernet1/28
!
interface GigabitEthernet1/29
!
interface GigabitEthernet1/30
!
interface GigabitEthernet1/31
!
interface GigabitEthernet1/32
!
interface GigabitEthernet1/33
!
interface GigabitEthernet1/34
!
interface GigabitEthernet1/35
!
interface GigabitEthernet1/36
!
interface GigabitEthernet1/37
!
interface GigabitEthernet1/38
!
interface GigabitEthernet1/39
!
interface GigabitEthernet1/40
!
interface GigabitEthernet1/41
!
interface GigabitEthernet1/42
!
interface GigabitEthernet1/43
!
interface GigabitEthernet1/44
!
interface GigabitEthernet1/45
switchport mode access
media-type rj45
!
interface GigabitEthernet1/46
switchport mode access
media-type rj45
!
interface GigabitEthernet1/47
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
!
interface GigabitEthernet1/48
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
!
interface Vlan1
ip address 10.10.10.2 255.255.255.0
!
ip default-gateway 10.10.10.1
ip route 0.0.0.0 0.0.0.0 10.10.10.1
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
monitor session 1 source interface Gi1/46
monitor session 1 destination interface Gi1/45
monitor session 1 filter packet-type good rx
ntp clock-period 17179566
ntp server 129.6.15.28
end

 

6 REPLIES 6
Highlighted
Beginner

Hi,

Can you please set on port 46 command: switchport voice vlan [id]?

Highlighted

Hi kubn2

Thank you, does it matter that there is no voice vlan right now. The data and voice are all on vlan 1.

I'll separate later but wanted to get working first. so no vlan configured.

Apologies but I also forgot to mention that I can set the IP Office to a static address on the network and I can access it without any issues, ping, web, and configuration through the software, all works fine if I set to Static address, as soon as I set to DHCP I do not receive an address.

Highlighted

Hello,

 

Avaya requires LLDP. Either enable that globally, or on the interface:

 

4948(config)#lldp run

 

4948(config-if)#lldp receive

4948(config-if)#lldp transmit

Highlighted

Georg,

I set lldp globally

4949(config)#lldp run

unfortunately I still have the same issue and the IP office is not getting an IP address.

I ran the wireshark again and I see the DHCP discover packet sent out from the IP office but it never gets to the DHCP server and so no IP address.

would you have any other ideas about how to get this to work or if I can run a debug that will allow me to see what is happening to the packet in the switch.

It appears as if the switch is dropping the packet to me, but I can't tell why.

Thank you

Highlighted
VIP Mentor

Hello

enable portfast in the port and test again

inx/x

spanning-tree portfast



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Paul,

Thank you for the idea, (and thank everyone for the assistance), it was decided to swap out the switch to get the system up and running for now. 

If I ever get a chance I will try the portfast suggestion to see what happens.

For now you were all helpful but I will close the discussion as I cannot try anymore suggestions.

Thank you

Content for Community-Ad