cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
920
Views
0
Helpful
1
Replies

Dual ISP active/Active coonnection on single router

Hi All,

I am working on a network which has two ISP connections (Active/Active) terminating on router (ASR1000). From the LAN side (6500 switch) all the traffic need to be route on ISP1 but some of the specific subnets like 10.250.0.0/16 need to be route on ISP2 connection.

I am planning to use PBR and NAT with route maps. It will be helpful if any documents or refrences are provided.ches

(access switches)---------(core switch)----------(routers)----------------(ISP1)

                                                                    ----------------------(ISP2) 

Thanks in advance.

1 Reply 1

The following config in lab enviroment worked fine. Route Map s250 used for PBR and Route maps isp1 and isp2 used for natting.

Any advices will be helpful.

interface FastEthernet0/0

desc ISP1

ip address 1.1.1.1 255.255.255.0

ip nat outside

interface FastEthernet0/1

  desc ISP2

ip address 2.2.2.1 255.255.255.0

ip nat outside

!

interface FastEthernet1/0

desc LAN

ip address 10.255.1.206 255.255.255.252

ip nat inside

ip policy route-map s250

!

ip local policy route-map s250

ip route 0.0.0.0 0.0.0.0 1.1.1.2

ip route 0.0.0.0 0.0.0.0 2.2.2.2 50

ip route 10.0.0.0 255.0.0.0 10.255.1.205

ip nat pool isp1 1.1.1.1 1.1.1.1 netmask 255.255.255.0

ip nat inside source route-map isp1 pool isp1 overload

ip nat inside source route-map isp2 interface FastEthernet0/1 overload

!

access-list 1 deny 10.250.1.0 0.0.0.255

access-list 1 permit any

access-list 2 permit 10.250.1.0 0.0.0.255

access-list 10 permit 10.250.1.0 0.0.0.255

!

!

route-map s250 permit 10

match ip address 10

set ip next-hop 2.2.2.2

!

route-map isp1 permit 10

match ip address 1

set interface FastEthernet0/0

!

route-map isp2 permit 20

match ip address 2

set interface FastEthernet0/1

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card