cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2230
Views
0
Helpful
2
Replies

Duplicate VLAN addresses??

JohnNarey
Level 1
Level 1

Hey everyone,

Need more advice please. If you didn't already know I am a 3rd year Networking and Systems Support student so please don't laugh if I am being a complete nooby no sense! lol.

I am having a some difficulty VLAN addressing on the dual the layer 3 switches. On both DLS switches I beleive the VLAN IP addresses should match each other?? Or am I wrong in saying do?? Reason I ask is because I am being displayed with Duplcate addresses of the VLANs. I have DLS1 & DLS2 configured with the following VLANs:

Capture.JPG

DLS1

interface Vlan1

ip address 172.16.0.1 255.255.255.0

!

interface Vlan100

ip address 172.16.1.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan200

ip address 172.16.2.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan300

ip address 172.16.3.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan400

ip address 172.16.4.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan500

ip address 172.16.5.1 255.255.255.0

ip helper-address 172.16.0.10

DLS2

interface Vlan1

ip address 172.16.0.1 255.255.255.0

!

interface Vlan100

ip address 172.16.1.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan200

ip address 172.16.2.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan300

ip address 172.16.3.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan400

ip address 172.16.4.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan500

ip address 172.16.5.1 255.255.255.0

ip helper-address 172.16.0.10

DLS1 - Full Show Run

hostname DLS1

!

!

!

!

!

ip routing

!

!

!

!

!

!

!

!

!

!

spanning-tree mode rapid-pvst

spanning-tree portfast default

spanning-tree vlan 1,100,200,300,400,500 priority 24576

!

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/6

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/7

channel-group 1 mode desirable

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/8

channel-group 1 mode desirable

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Port-channel 1

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast disable

!

interface Vlan1

ip address 172.16.0.1 255.255.255.0

!

interface Vlan100

ip address 172.16.1.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan200

ip address 172.16.2.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan300

ip address 172.16.3.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan400

ip address 172.16.4.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan500

ip address 172.16.5.1 255.255.255.0

ip helper-address 172.16.0.10

!

ip classless

!

!

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

!

end

DLS2 - Full Show Run

hostname DLS2

!

!

!

!

!

ip routing

!

!

!

!

!

!

!

!

!

!

spanning-tree mode rapid-pvst

spanning-tree vlan 1,100,200,300,400,500 priority 28672

!

!

!

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/4

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/5

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/6

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/7

channel-group 1 mode desirable

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/8

channel-group 1 mode desirable

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Port-channel 1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Vlan1

ip address 172.16.0.1 255.255.255.0

!

interface Vlan100

ip address 172.16.1.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan200

ip address 172.16.2.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan300

ip address 172.16.3.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan400

ip address 172.16.4.1 255.255.255.0

ip helper-address 172.16.0.10

!

interface Vlan500

ip address 172.16.5.1 255.255.255.0

ip helper-address 172.16.0.10

!

ip classless

!

!

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

!

end

Can you see of I have done this wrong? If someone could check my configs too that would be great.

Thank you!

2 Replies 2

DuncanM2008
Level 1
Level 1

Hi John,

I think you might be getting confused with a function / technology called HSRP.

Basically if you have two layer 3 switches serving clients and want a HA configuration where if one fails the other will take over Layer 3 forwarding operations you need HSRP (which sounds like what your trying to achieve).

So in terms of your configurations each DLS should have a different IP for each Vlan and then under each Vlan interface you configure a HSRP group with the "virtual IP" that clients will use as a default gateway.

I hope this makes some sense if you want to know more about HSRP let me know.

Thanks,

Dunc

Sent from Cisco Technical Support iPhone App

Thanks Duncan,

Yeah I will be using HA in terms of Gateway Load Balancing Protocol I haven't gotten that far as I am doing a top down design and unfortunetly PacketTracer does not support HSRP or GLBP. Configuration will need to happen in the lab but until then I am getting familar with the commands. Presentation is in 6 weeks to show a fully operational campus network with 5 branch offices. Plenty of time. I hope!

Thanks again.

Review Cisco Networking products for a $25 gift card