cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

24806
Views
16
Helpful
16
Replies
Contributor

%EC-SP-5-CANNOT_BUNDLE2 - Switch incorrectly sees port in Dynamic Trunking Mode

Take this configuration on a 6500 with 2 WS-X6716-10-GE modules installed.

interface Port-channel1

description Switch02:Po1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

!

interface TenGigabitEthernet1/1

description Switch02:Te1/1

switchport

switchport mode trunk

switchport nonegotiate

channel-group 1 mode on

!

interface TenGigabitEthernet2/1

description Switch02:Te2/1

switchport

switchport mode trunk

switchport nonegotiate

channel-group 1 mode on

shutdown

!

Now I do this:

conf t

int Te2/1

no shut

This error message is generated:

%EC-SP-5-CANNOT_BUNDLE2: Te2/1 is not compatible with Te1/1 and will
be suspended (trunk mode of Te2/1 is trunk, Te1/1 is dynamic)

The million dollar question - Why would it see Te1/1 as being in dynamic trunking mode? 

16 REPLIES 16
Advisor

Re: %EC-SP-5-CANNOT_BUNDLE2 - Switch incorrectly sees port in Dy

Shutdown the port channel by shutting down the port channel SVI  . Then try to bring it up , with a no shut on the port channel SVI , this will bring both ports up at the same time.  Sometimes they do not  like having a single port in the channel being brought up by itself.  Also make sure the other end matches exactly seeing you are forcing the port channel to an on state.

Contributor

%EC-SP-5-CANNOT_BUNDLE2 - Switch incorrectly sees port in Dynami

glen.grant wrote:

Shutdown the port channel by shutting down the port channel SVI  . Then try to bring it up , with a no shut on the port channel SVI , this will bring both ports up at the same time.  Sometimes they do not  like having a single port in the channel being brought up by itself.  Also make sure the other end matches exactly seeing you are forcing the port channel to an on state.

I agree this may work, but it doesn't really address the problem.  If both the logical and physical interfaces have 'switchport nonegotiate' configured, why would the switch see it in Dynamic Trunking mode?

One thing I did try was removing 'switchport nonegotiate' from Te2/1.  Then I got this:

%EC-SP-5-CANNOT_BUNDLE2: Te2/1 is not compatible with Te1/1 and will be suspended (dtp nonegotiate of Te2/1 is 0, Te1/1 id 1)

It's now saying DTP is disabled for Te1/1.  In other words, it is NOT in dynamic trunking mode.  Since that directly contradicts the earlier message, my conclusion is this is a software bug. 

Contributor

I noticed a similar log when

I noticed a similar log when I was completing a configuration.

%EC-5-CANNOT_BUNDLE2: Gi1/0/11 is not compatible with Po1 and will be suspended (vlan mask is different)

I had mistyped the allowed vlan on an interface.  This caused the allowed VLAN list to be different on the port-channel that I created and the interface.

The port came up after I corrected this issue.  I just thought I would share this for anyone seeing a similar issue.

Hall of Fame Community Legend

Re: %EC-SP-5-CANNOT_BUNDLE2 - Switch incorrectly sees port in Dy

Because in both of your physcial interface, you don't have the command "switchport trunk encapsulation dot1q" while this line exist in Po 1.

VIP Expert

%EC-SP-5-CANNOT_BUNDLE2 - Switch incorrectly sees port in Dynami

I am surprised the router will let you configure the mode as trunk without specifying the encapsulation first.

Switch(config-if)#switchport

Switch(config-if)#switchport mode trunk

Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.

Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport mode trunk               

Switch(config-if)#

Contributor

%EC-SP-5-CANNOT_BUNDLE2 - Switch incorrectly sees port in Dynami

Reza Sharifi wrote:

I am surprised the router will let you configure the mode as trunk without specifying the encapsulation first. 

The 6500s and 4900s do not seem to support 'switchport trunk encapsulation' on physical interfaces at all.  My assumption is since these platforms only support 802.1Q, Cisco just removed the command?

Odd that they kept it there for logical interfaces.  Kind of confusing.


Contributor

Re: %EC-SP-5-CANNOT_BUNDLE2 - Switch incorrectly sees port in Dy

The 'show int switchport' command also agrees that the physical port is NOT in dynamic trunking mode:

Switch01#sh int te1/1 switchport

Name: Te1/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk (member of bundle Po1)

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Off

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Operational Native VLAN tagging: disabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Hall of Fame Community Legend

%EC-SP-5-CANNOT_BUNDLE2 - Switch incorrectly sees port in Dynami

Ok ... I think I remember this.

Firstly, you need to delete the port-channel interface (no interface po1).  Next, you need to remove the channel-group from both Ten 1/1 and Ten 1/2.

After this is done, do you put the "channel-group 1 mode on" back in.

conf t

no int po 1

int r ten 1/1 - 2

no channel-group 1 mode on

channel-group 1 mode on

end

Try this and let us know.

Contributor

Re: %EC-SP-5-CANNOT_BUNDLE2 - Switch incorrectly sees port in Dy

Yes, I think blowing away the Channel and re-creating it would work.  However I'm trying to find a procedure that has as little downtime as possible. 

Alternatively I think this would work:

1) Create a channel Po2

2) Migrate Te2/2 to it

3) Shutdown Te1/1, then migrate it to the new channel

3) Delete Po1

Since it's a Layer 2 channel and both switches run RSTP, the only downtime would be shutting the old channel and RSTP flipping root ports, which would be under 1 second.

Contributor

%EC-SP-5-CANNOT_BUNDLE2 - Switch incorrectly sees port in Dynami

Well, at least I'm not alone - http://www.cciezone.com/?p=167

Highlighted
Beginner

Hey........thanks for this I

Hey........thanks for this I just had this same problem on some old gear....your statement above got my port-channel going.

Beginner

Had the same issue and worked

Had the same issue and worked for me, too. Thanks!

Beginner

Re: Had the same issue and worked

Dear Friend, how did it work for you?

 

I'm having the same issue with my VSL plz help, my port-channel is also not coming up.

 

BR

Contributor

%EC-SP-5-CANNOT_BUNDLE2 - Switch incorrectly sees port in Dynami

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards