cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
834
Views
0
Helpful
2
Replies
Highlighted

Editing and copying config Cisco 876 router to another - not working dhcp

Hello,

i have to configure 80 Cisco 876 routers, so i planned to copy config via tftp from one configured router to PC, edit it in text editor (change ip addresses, dhcp pools, vpn keys...) and then copy it via tftp to another router, etc... Configuration looks fine and it works when i paste it in cli, but when i copy it via tftp i'm getting strange problems like dhcp not working or snmp not accessible. Am I missing something.

Here's config from router with dhcp problem:

ROUTER#sh run

version 15.1

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname ROUTER

boot-start-marker

boot-end-marker

!

!

logging buffered 4000000

enable secret 4   *******************************

!

no aaa new-model

clock timezone GMT 1 0

clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 3:00

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-733367932

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-733367932

revocation-check none

rsakeypair TP-self-signed-733367932

!

!

crypto pki certificate chain TP-self-signed-733367932

certificate self-signed 01

        quit

dot11 syslog

no ip source-route

ip dhcp excluded-address 172.30.248.129

!

ip dhcp pool DHCP

network 172.30.248.128 255.255.255.240

default-router 172.30.248.129

domain-name **********

dns-server 192.168.0.3

lease 7

!

!

!

ip cef

no ip bootp server

ip domain name hpa

login block-for 120 attempts 2 within 100

login delay 10

login quiet-mode access-class PERMIT-SSH

login on-failure log

login on-success log

!

!

!

!

archive

log config

  hidekeys

username USER privilege 15 secret 4 ***************************

!

!

ip tcp synwait-time 10

ip tftp source-interface Vlan2

ip ssh version 2

!

!

crypto isakmp keepalive 15 10 periodic

!

!

!

!

!

crypto ipsec client ezvpn ***********

connect auto

group TG_LOCATION_EasyVPN key ****************

mode network-extension

peer xxx.xxx.xxx.xxx

username USERNAME password ***********

xauth userid mode local

!

!

!

!

!

interface Null0

no ip unreachables

!

interface BRI0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

encapsulation hdlc

shutdown

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

shutdown

no atm ilmi-keepalive

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

switchport access vlan 2

no ip address

spanning-tree portfast

!

interface FastEthernet2

switchport access vlan 2

no ip address

spanning-tree portfast

!

interface FastEthernet3

switchport access vlan 2

no ip address

spanning-tree portfast

!

interface Vlan1

description OUTSIDE

ip address dhcp

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

crypto ipsec client ezvpn *******

!

interface Vlan2

description INSIDE

ip address 172.30.248.129 255.255.255.240

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

no autostate

crypto ipsec client ezvpn ****** inside

!

ip forward-protocol nd

no ip http server

ip http authentication local

ip http secure-server

!

!

ip access-list standard PERMIT-SSH

permit xxx.xxx.xxx.xxx

permit xxx.xxx.xxx.xxx

ip access-list standard SNMP_PERMIT

permit xxx.xxx.xxx.xxx

!

!

logging source-interface Vlan2

logging xxx.xxx.xxx.xxx

logging xxx.xxx.xxx.xxx

no cdp run

!

!

!

snmp-server community ***********************

snmp-server location ***************

!

control-plane

!

banner login ^C

******************************************************************************

^C

!

line con 0

login local

no modem enable

transport output telnet

line aux 0

login local

transport output telnet

line vty 0 4

access-class PERMIT-SSH in

login local

transport input telnet ssh

!

scheduler max-task-time 5000

scheduler allocate 4000 1000

scheduler interval 500

ntp server xxx.xxx.xxx.xxx

end

2 REPLIES 2
Highlighted
Advisor

Hi,

sh ip int br to see shutdown interfaces.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted

Interfaces are up up

Content for Community-Ad