cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
81584
Views
44
Helpful
31
Replies

EIGRP continually flapping

pugs17211721
Beginner
Beginner

This is the message that I am getting from my 1941w router. I have a isakmp tunnel built with a GRE tunnel going through it. I keep getting the following message, continously.

Nov 16 08:58:09.352 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 08:59:47.361 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 08:59:51.217 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 09:01:27.230 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 09:01:27.782 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 09:03:03.792 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 09:03:04.372 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 09:04:40.381 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 09:04:40.909 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 09:06:13.774 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 09:06:18.282 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 09:07:54.296 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 09:07:58.436 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 09:09:29.521 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 09:09:30.233 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

The other end of the device is a 2801 router and it doesnt show anything in the logs. Anyone have any ideas? Thanks.

31 Replies 31

You are advertising the tunnel source in the eigrp statement.   If this is the preferred route on the remote end you end up with recursive routing.  Recommended to remove "network 172.20.0.0" and put in 172.20.255.96 0.0.0.3 so you are not advertising the tunnel source through the tunnel routing protocol.

Dan

I had a similar problem and got it resolved..

On the dmvpn spoke, (GRE over ipsec) the tunnel was continually flapping.

the public ip address on the dmvpn spoke is 99.X.X.X

Upon debug I realized that there is a static route on the peer (hub router) poining to 99.x.x.x which is again redistributed into eigrp..so spoke router is now having this as a local route as well as a route redistributed via eigrp ..so it was falpping..

i fixed this by implementing a block route-map..

hope this helps...

Regards Vinayak

What I did to fix my issue that I was having above was to lower my MTU on the tunnel interface. After I changed that to 1400 everything else has worked smoothly.

Peter Paluch
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

Hello,

Oh yes - that's yet another issue to have in mind - large routing tables compounded with MTU issues on tunnel interfaces. Thanks for sharing and reminding us of that!

Best regards,

Peter

MajidShirzadeh
Beginner
Beginner

Hi Guys !

I got DUAL-5-NBRCHANGE error after I turn up a site to MPLS network, could you help me with that please ?

Feb  1 11:35:12.008 Central: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(512) 1: Neighbor 192.168.201.74 (Tunnel18) is down: holding time expired

Feb  1 11:50:01.486 Central: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(512) 1: Neighbor 192.168.201.74 (Tunnel18) is up: new adjacency

Feb  1 19:25:50.005 Central: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(512) 1: Neighbor 10.1.150.6 (GigabitEthernet8/33) is down: interface down

Feb  1 19:26:03.742 Central: %SYS-5-CONFIG_I: Configured from console by mgriffin on vty0 (10.1.211.93)

Feb  1 19:29:12.434 Central: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(512) 1: Neighbor 10.1.150.6 (GigabitEthernet8/33) is up: new adjacency

Feb  1 19:33:40.546 Central: %SYS-5-CONFIG_I: Configured from console by mgriffin on vty0 (10.1.211.93)

Feb  1 21:31:38.013 Central: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(512) 1: Neighbor 192.168.201.66 (Tunnel16) is down: Interface PEER-TERMINATION received

Feb  1 21:31:41.509 Central: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(512) 1: Neighbor 192.168.201.66 (Tunnel16) is up: new adjacency

Peter Paluch
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

Majid,

The reason may very well be similar to the issues already described in this thread. Have you carefully went each suggestion posted here so far and made sure that none of them applies to you? In particular, are you sure you do not advertise the network in which the tunnel endpoint resides through the EIGRP running over that tunnel?

Best regards,

Peter

Here is my MTU size!

Core site, MTU Size on tunnel interface =17868 and customer tunnel MTU size = 1514, so what do you think ?

I set mine at 1400, but how I got there was through trial and error. I was at 1514, adjusted it to 1300 and it worked better. Then i slowly workd my way up the chain to find out where the stable point is and left it ther.

hlopez606
Beginner
Beginner

I have the same error, what I can do?

 

1y13w: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.20.250 (Vlan2) is up: new adjacency
1y13w: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.20.250 (Vlan2) is down: holding time expired

Perhaps you can give us some more information about your environment? How often does this happen?

 

The error message indicates that holding time expired. This means that you have established a neighbor relationship, that you have sent EIGRP packets to the neighbor and the neighbor has not responded.  The holding time is the amount of time that you wait for a response. So there is a possibility that the real issue may be on the neighbor and not on your router.

 

HTH

 

Rick

HTH

Rick

deepak george
Beginner
Beginner

Dear Members,

 

Do we have a solution for the same as we faced the same issue wherein the tunnel keeps flapping with the same error message, however there is no downtime reported. Please advise what to do

prabinchand
Beginner
Beginner

HELLO GUYS,

whatever you guys said i tried it all but noone of them worked for me..

 

 

Hello,

 

this post is very old. What is your specific problem ?

hello george sir,

here's my config and error is attached below:

ERROR: "Tunnel, retry limit exceed"

when i advertise tunnel and LAN netwokr using EIGRP.

 

hello sir,

but got new problem "Tunnel, retry limit exceed" when i advertise tunnel and LAN netwokr using EIGRP.

please help sir,

 

NOTE: error is attached below.

 

CONFIGURATION:

SPOKE2

!
!
interface Tunnel1
ip address 172.16.10.3 255.255.255.0
no ip redirects
no ip split-horizon eigrp 1
ip nhrp map multicast 1.1.1.1
ip nhrp map multicast 1.1.1.2
ip nhrp map 172.16.10.1 1.1.1.1
ip nhrp map 172.16.10.2 1.1.1.2
ip nhrp network-id 1
ip nhrp holdtime 10
ip nhrp nhs 172.16.10.1 priority 1 cluster 1
ip nhrp nhs 172.16.10.2 priority 2 cluster 1
ip nhrp nhs cluster 1 max-connections 1
ip nhrp nhs fallback 5
tunnel source FastEthernet0/0
tunnel mode gre multipoint
!
interface Tunnel2
ip address 125.25.25.3 255.255.255.0
no ip redirects
no ip split-horizon eigrp 1
ip nhrp map multicast 2.2.2.1
ip nhrp map multicast 2.2.2.2
ip nhrp map 125.25.25.1 2.2.2.1
ip nhrp map 125.25.25.2 2.2.2.2
ip nhrp network-id 2
ip nhrp nhs 125.25.25.1 priority 1 cluster 2
ip nhrp nhs 125.25.25.2 priority 2 cluster 2
ip nhrp nhs cluster 2 max-connections 1
ip nhrp nhs fallback 5
delay 6000
tunnel source FastEthernet1/1
tunnel mode gre multipoint
!
interface FastEthernet0/0
ip address 1.1.1.4 255.255.255.0
speed auto
duplex auto
!
interface FastEthernet0/1
ip address 192.168.20.1 255.255.255.0
speed auto
duplex auto
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
ip address 2.2.2.4 255.255.255.0
speed auto
duplex auto
!
!
router eigrp 1
network 125.25.25.0 0.0.0.255
network 172.16.10.0 0.0.0.255
network 192.168.20.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!

-----------------------------------------------------------------------------------------------

HUB-ACTIVE

!
ip tcp synwait-time 5
!
!
!
!
!
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
crypto isakmp key FORISP1 address 1.1.1.3
crypto isakmp key FORISP2 address 2.2.2.3
!
!
crypto ipsec transform-set ISP1SET esp-3des esp-md5-hmac
mode tunnel
crypto ipsec transform-set ISP2SET esp-3des esp-md5-hmac
mode tunnel
!
!
!
crypto map ISP1MAP 1 ipsec-isakmp
set peer 1.1.1.3
set transform-set ISP1SET
match address 100
!
crypto map ISP2MAP 2 ipsec-isakmp
set peer 2.2.2.3
set transform-set ISP2SET
match address 100
!
!
!
!
!
interface Tunnel1
ip address 172.16.10.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 1
tunnel source FastEthernet0/0
tunnel mode gre multipoint
!
interface Tunnel2
ip address 125.25.25.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 2
delay 60000
tunnel source FastEthernet1/1
tunnel mode gre multipoint
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.0
standby 2 ip 1.1.1.5
standby 2 priority 110
standby 2 preempt
standby 2 name WAN-INT
speed auto
duplex auto
crypto map ISP1MAP redundancy WAN-INT
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
standby 1 ip 192.168.10.5
standby 1 priority 110
standby 1 preempt
standby 1 name INLAN
speed auto
duplex auto
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
description ***ISP-2-SECONDARY***
ip address 2.2.2.1 255.255.255.0
standby 3 ip 2.2.2.5
standby 3 priority 110
standby 3 preempt
standby 3 name wlan2
speed auto
duplex auto
crypto map ISP2MAP redundancy wlan2
!
!
router eigrp 1
network 125.25.25.0 0.0.0.255
network 172.16.10.0 0.0.0.255
network 192.168.10.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.10.3
ip route 192.168.60.0 255.255.255.0 1.1.1.3
ip route 192.168.60.0 255.255.255.0 2.2.2.3 10
!
access-list 100 permit ip 192.168.50.0 0.0.0.255 192.168.60.0 0.0.0.255
!
!

-----------------------------------------------------------------------------------------------

HUB-STANDBY

!
ip tcp synwait-time 5
!
!
!
!
!
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
crypto isakmp key FORISP1 address 1.1.1.3
crypto isakmp key FORISP2 address 2.2.2.3
!
!
crypto ipsec transform-set ISP1SET esp-3des esp-md5-hmac
mode tunnel
crypto ipsec transform-set ISP2SET esp-3des esp-md5-hmac
mode tunnel
!
!
!
crypto map ISP1MAP 1 ipsec-isakmp
set peer 1.1.1.3
set transform-set ISP1SET
match address 100
!
crypto map ISP2MAP 2 ipsec-isakmp
set peer 2.2.2.3
set transform-set ISP2SET
match address 100
!
!
!
!
!
interface Tunnel1
ip address 172.16.10.2 255.255.255.0
no ip redirects
no ip split-horizon eigrp 1
ip nhrp map multicast dynamic
ip nhrp network-id 1
delay 7000
tunnel source FastEthernet0/0
tunnel mode gre multipoint
!
interface Tunnel2
ip address 125.25.25.2 255.255.255.0
no ip redirects
no ip split-horizon eigrp 1
ip nhrp map multicast dynamic
ip nhrp network-id 2
delay 8000
tunnel source FastEthernet1/1
tunnel mode gre multipoint
!
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.0
standby 2 ip 1.1.1.5
standby 2 preempt
standby 2 name WAN-INT
speed auto
duplex auto
crypto map ISP1MAP redundancy WAN-INT
!
interface FastEthernet0/1
ip address 192.168.10.2 255.255.255.0
standby 1 ip 192.168.10.5
standby 1 preempt
standby 1 name INLAN
speed auto
duplex auto
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
description ***ISP-2-SECONDARY***
ip address 2.2.2.2 255.255.255.0
standby 3 ip 2.2.2.5
standby 3 preempt
standby 3 name wlan2
speed auto
duplex auto
crypto map ISP2MAP redundancy wlan2
!
!
router eigrp 1
network 125.25.25.0 0.0.0.255
network 172.16.10.0 0.0.0.255
network 192.168.10.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.10.3
ip route 192.168.60.0 255.255.255.0 1.1.1.3
ip route 192.168.60.0 255.255.255.0 2.2.2.3 10
!
access-list 100 permit ip 192.168.50.0 0.0.0.255 192.168.60.0 0.0.0.255
!
!

Hello,

 

what is the WAN interface ? It is difficult to understand your routing, so if you have a diagram of your topology, post that as well.

 

At first glance, 192.168.10.0 is your LAN ? Or your WAN ? Make sure you advertise only the tunnels and the LAN in EIGRP...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers