cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

764
Views
0
Helpful
13
Replies
Beginner

EIGRP load balancing

Hello

i have a lab with the following characteristics (graphic attached).

- 1x VSS

- 2x normal Router

- between these two Routers and VSS works EIGRP

 

Metric R1:

Link1 = 10000 (FD), 7000 (RD)

Link2 + Link3 = 15000 (FD), 10000 (RD)

 

Metric R2:

Link2 = 10000 (FD), 7000 (RD)

Link1 + Link3 = 15000 (FD), 10000 (RD)

 

The feasible condition is meet because RD (1000) <= FS (1000)?

My Problem I did not get the second route for the subnet 10.10.10.0/24 in my routing table. I want to configure equal-cost multi-path on Router R1 and R2 to use both links for routing.

What can I do? Do I have a understanding Problem with EIGRP?

 

Offset-lists have global influence in route distribution?

Route-maps have local influence in route distribution?

 

 

 

13 REPLIES 13
VIP Mentor

Re: EIGRP load balancing

Hello,

 

hard to say without seeing the configs, can you post them ?

Beginner

Re: EIGRP load balancing

Router 1 and 2 have the same config (ip addresses are different but in the same subnet):

interface Vlan10
 ip vrf forwarding TEST
 ip address 10.10.1.1 255.255.255.0

interface Vlan20
 ip vrf forwarding TEST
 ip address 10.10.2.1 255.255.255.0

router eigrp 1
 address-family ipv4 vrf TEST
  redistribute static metric 100000 0 255 1 1500
  network 10.10.1.0 0.0.0.255
network 10.10.2.0 0.0.0.255 autonomous-system 1 exit-address-Family

The VSS router do distribute two routes for subnet 10.10.10.0/24

sh ip eigrp topology all-links
P 10.10.10.0/24, 1 successors, FD is 10000
        via 172.28.11.154 (10000/7000), Vlan10 (route link 1)
        via 172.28.11.34 (15000/10000), Vlan20 (route Link 2+3)

 

 

VLAN10 = Subnet Link1
VLAN20 = Subnet Link3

VIP Mentor

Re: EIGRP load balancing

Hello,

 

sh ip eigrp topology all-links
P 10.10.10.0/24, 1 successors, FD is 10000
via 172.28.11.154 (10000/7000), Vlan10 (route link 1)
via 172.28.11.34 (15000/10000), Vlan20 (route Link 2+3)

 

You have only one successor (the one with the lowest metric, 10000). In order to achieve load balancing, you have to calculate the variance value:

 

15000/10000 = 1,5 (which equals variance 2)

 

So under the EIGRP process, configure 'variance 2'...

 

Does that make sense ? 

Beginner

Re: EIGRP load balancing

Variance was also my first idea. But the second route would not be a successor. the sh ip route output is still the same.

Could this be an EIGRP aspect in Routing Loop prevention?

 

Beginner

Re: EIGRP load balancing

The problem is the feasibility condition was not met for the second route. The feasibility condition states that a neighbor must be closer to the destination than I have been since the route last went active, or FC = RD < FD. Notice I did not say or equal to.

 

It does not matter what you configure for variance. The second route will not be considered for unequal-cost load balancing until the RD is less than the FD of the successor route, that is 9999 or less, because it is not a feasible successor.

 

Hope that answers your question.

VIP Mentor

Re: EIGRP load balancing

You are absolutely right. 

 

FD can be influenced a.o. by setting the delay parameter on the interface facing the downstream routers. I tried to recreate your setup, and my FD and RD values are different, but try setting a delay of 100. The goal is to make sure the FD is greater than the RD on both routes in the topology table. You still need the variance...

Highlighted
Beginner

Re: EIGRP load balancing

I tried to manipulate the delay. But this setting influence the whole global routing.

Is it possible to manipulate the delay only local?

A route-map does not bring the effect. 

VIP Mentor

Re: EIGRP load balancing

Hello,

 

use an inbound offset list to increase the feasible distance of the successor:

 

access-list 1 permit 10.10.10.0 0.0.0.255

 

router eigrp 1
address-family ipv4 vrf TEST
offset-list 1 in 20 Vlan10

variance 2

 

This should result in the below output:

 

sh ip eigrp topology all-links
P 10.10.10.0/24, w successors, FD is 10020
via 172.28.11.154 (10020/7000), Vlan10
via 172.28.11.34 (15000/10000), Vlan20

Participant

Re: EIGRP load balancing


 I want to configure equal-cost multi-path on Router R1 and R2 to use both links for routing.

What can I do? Do I have a understanding Problem with EIGRP?

For equal cost multi path you need equal cost paths. The best you can achieve is unequal cost load balancing after you manipulate route in topology table to become feasible successor.

Beginner

Re: EIGRP load balancing

Very cool.

@Georg Pauwen: Your configuration work. But the metric is distributed to R2. So offset-lists are global Now, Is there a risk of a routing loop?

The feasible condition prevents routing Loops? Now I manipulate the condition.

I think in this case because of VSS use this could not be a routing loop?

I think on R2 it is not possible to make load balancing because of a routing Loop (both R1 + R2 make load balancing)?

VIP Mentor

Re: EIGRP load balancing

Hello,

 

in my lab (and the example I gave you) the inbound offset list affects the local topology table on R1 only. Not sure why in your case the metric is distributed to other routers. Is yours a physical lab or a GNS3 lab ?

 

Either way, manipulating the parameters is obviously tricky business, and if there is a routing loop you will notice that very soon (increased CPU, increased bandwidth utilization).

Beginner

Re: EIGRP load balancing

I use physical devices.

Are offset-lists local?

Another way could be route-maps? Have they only local influence? 

VIP Mentor

Re: EIGRP load balancing

Hello,

 

route maps are used for redistribution (from or to another routing protocol), so they won't be of much help.

Offset lists are local, they change the values only in the local topology table.

CreatePlease to create content
Content for Community-Ad