cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2118
Views
75
Helpful
37
Replies

eigrp one of subnet not updated

Arie
Level 1
Level 1

Can anyone explains me why R2 is not getting information from R1 about his inner subnet: 172.16.1.0?

R1 has in eigrp network classfull subnet added: 172.16.0.0 so 172.16.1.0 should be attached and R2 should receive it inside his routing table.

Funny thing is R2 has similar situation (also network 172.16.0.0 added) and R1 can see R2's 172.16.2.0 

Topology:

Heres my configs:

R1

R1#sh run
Building configuration...

Current configuration : 717 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname "R1"
!
!
ip subnet-zero
!
!
!
!
!
interface Ethernet0
ip address 192.168.10.5 255.255.255.252
half-duplex
no cdp enable
!
interface FastEthernet0
ip address 172.16.1.1 255.255.255.0
speed auto
no cdp enable
!
interface Serial0
ip address 172.16.3.1 255.255.255.252
clockrate 64000
no fair-queue
no cdp enable
!
interface Serial1
no ip address
shutdown
no cdp enable
!
router eigrp 1
network 172.16.0.0
network 192.168.10.4 0.0.0.3
no auto-summary
!
ip classless
no ip http server
!
!
no cdp run
!
line con 0
line aux 0
line vty 0 4
login
!
no scheduler allocate
end

R1#

R2


R2#sh run
Building configuration...

Current configuration : 759 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
ip address 172.16.3.2 255.255.255.252
!
interface Serial0/1/1
ip address 192.168.10.9 255.255.255.252
clock rate 64000
!
router eigrp 1
network 172.16.0.0
no auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

37 Replies 37

ok please keep me posted. 

Thank you in advance.




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

see above:

R1(config)#int loopback 100
R1(config-if)#ip address 172.16.1.1 255.255.255.0
% 172.16.1.0 overlaps with FastEthernet0
R1(config-if)#ip address 172.16.1.2 255.255.255.0
% 172.16.1.0 overlaps with FastEthernet0
R1(config-if)#

yeap, you must first remove the ip 172.16.1.1 under the interface Fast0

interface FastEthernet 0
no ip add 172.16.1.1 255.255.255.0

then

Interface loopback0
ip add 172.16.1.1 255.255.255.0




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

added, now i see on R2's routing table 172.16.1.1 appears

192.168.10.0/30 is subnetted, 2 subnets
D 192.168.10.4 [90/2195456] via 172.16.3.1, 01:20:03, Serial0/1/0
C 192.168.10.8 is directly connected, Serial0/1/1
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D 172.16.1.0/24 [90/2297856] via 172.16.3.1, 00:00:48, Serial0/1/0
C 172.16.2.0/24 is directly connected, FastEthernet0/0
C 172.16.3.0/30 is directly connected, Serial0/1/0

Whats wrong with previous configuration then?

Great, 

The interface Fa0 should have communication with the other end, so try to connect a computer to the port FastEthernet 0 using a crossover cable. Test the connectivity with a ping from the PC to the ip 172.16.1.1

And assign to the computer the IP 172.16.1.2 255.255.255.0

Also please remove the loopback created previously. 

In a real environment if there is nothing connected to the port, the subnet will not be advertised by the routing protocol. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Will check give me a moment.

Note that behind 172.16.2.0 there is also nothing but subnet is broadcasted correctly.

Thanks,

yeap that is weird, but now we can try connecting the computer. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

i defined for PC:

IP: 172.16.1.2 /24

GW: 172.16.1.1 /24

Ping result:

Destination host unreachable

Request timed out

Request timed out

Request timed out

Any other idea what could be wrong here?

Hi

Is the FastEthernet 0 configured with the IP 172.16.1.1? but remember to remove the interface loopback created previously.




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

forgot to remove loopback - did and now pc can ping gw .1.

I checked whether am i able to ping 172.16.2.1 from PC - OK

and from R2 to ping PC - OK

seems to be working but have no idea why it happend.

no worries my friend, good to know we have ping between the devices.

Please verify the routing table in R2




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

routing table fine now :)

192.168.10.0/30 is subnetted, 2 subnets
D 192.168.10.4 [90/2195456] via 172.16.3.1, 01:45:55, Serial0/1/0
C 192.168.10.8 is directly connected, Serial0/1/1
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D 172.16.1.0/24 [90/2172416] via 172.16.3.1, 00:04:06, Serial0/1/0
C 172.16.2.0/24 is directly connected, FastEthernet0/0
C 172.16.3.0/30 is directly connected, Serial0/1/0

What was the problem ?:)

Great!

In real environment if the interface is not connected to other device it will be seen as down. So it probably was originated for the simulator. 

So if the interface is down, the router will not advertise the subnet because it looks like inactive.

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Note that interface was up. I am not working on simulator i have my real rack lab at home for CCNA, CCNP and CCIE (haha)

See here what you've fixed (screenshoot of my rack): https://1drv.ms/i/s!AqKrvcy76bbDhC9HvgGDVhRLf9kO

At the bottom starts with Cisco 1700 (our R1) - maybe because it's old :D ?
Next up is Cisco 1841 (R2), and then Cisco 2801 (R3) (which i use for Voice in future)

Now i think that we could check also topology and topology all-links (R2), Maybe there was entry for but somehow EIGRP was treaded it as FS, what do you think could it be possible? But that's just a shoot...

heyy very good!!! which model of routers are you using? R2 should have as best path to R1 to reach the subnet 172.16.1.0/24 unless this subnet is configured on other device or metrics like bandwidth or delay were modified but your config does not show that. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
Review Cisco Networking products for a $25 gift card