cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
436084
Views
796
Helpful
109
Replies

Error opening tftp (Timed out)

Yadhu Tony
Beginner
Beginner

Hello,

I installed a new router and trying to backup the initial configuration to our tftp server. But getting the error " %Error opening tftp://172.17.0.39/corporate-confg (Timed out)"

I can ping the tftp server from router. There is no firewall in between router and tftp server. Other network devices in the same subnet can upload / download from tftp server. Only this router can't use the tftp. I tried to install a seperate tftp server and tried but no hope with the freshly installed router. Router running config is attached. Please help me.

Regards,
Tony

Regards,
Tony

http://yadhutony.blogspot.com
109 Replies 109

Thank you Sir. It helped! :)) 

Command worked perfect....thanks

ip tftp source-interface gig0/0/0 was very helpful,

it fixed my problem.

Thanks

Out of the 20 things that could prevent tftp file transfers from working, this was number 19.

 

Thanks for the post.

It solved, thanks

 

helpful.......thank you

 

Alaa 

Hi Michael,
manythanks, been trying for hours, my ping ok both ways, but this command fixed, never hd issue before but maybe its just needed on sone routers.
thanks again

short and to the point. Thank you!

it worked! On a cisco2911.

Gracias from Argentina

Saved the day!
Thank you @Michael Baldoza .

this was very helpful! 
thnx 

Solved for me. 

I had this same problem.  I use a Linux tftp server with owner and group with same name as the username from the switch/ router I upload and download configs / images with.

Since the switch was not configured with username and I was not logged in with username, I was getting the timeout error. 

I changed the permissions on the file on the Linux box to allow others read access to the bin file in question and voilà I stopped receiving these errors.

I had the same problem. The fix for me was Windows Firewall. I allowed my TFTP Server app on both Private and Public and afterward the transfer worked first try.

Had timeout problem using Solarwinds TFTP on Windows 10.    The fix was to add Solarwinds TFTP Server to the allowed apps.  Only added it on the Private network. 

Had to browse to the folder the file was in to add it. 

"C:\Program Files (x86)\SolarWinds\TFTP Server\SolarWinds TFTP Server.exe".  

Works great now.

Thanks djrees@live.com. Yes, it works great for me as well by follow your steps here. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: