cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
215
Views
0
Helpful
4
Replies
Highlighted

Error trying to upgrade 3850 from 03.x to 16.x

Hi,

I had trouble upgrading 3850 switch from the older version 03.xx to 16.xx.   since it's bundle, I was supposed to expand the new .bin file and then reboot on the new .conf file.   It has been working fine with other 3850's.  however this last one gave me a lot of errors and continue booting to the same .conf file.  I had to boot in rommon in order to load the older version.  however, i need to upgrade since this old version is giving trouble with the power supply.  below the errors.

 

>>> Boot Failed - pulling status and logs:

â bootflash_clean.service

   Loaded: loaded (/lib/systemd/system/bootflash_clean.service; enabled; vendor preset: enabled)

   Active: failed (Result: exit-code) since Tue 2020-07-28 11:04:34 Universal; 73ms ago

  Process: 753 ExecStart=/etc/init.d/bootflash_clean.sh (code=exited, status=203/EXEC)

Main PID: 753 (code=exited, status=203/EXEC)

 

[   11.548651] localhost systemd[1]: Starting bootflash_clean.service...

[   11.557128] localhost systemd[1]: bootflash_clean.service: Main process exited, code=exited, status=203/EXEC

[   11.557965] localhost systemd[1]: Failed to start bootflash_clean.service.

[   11.558832] localhost systemd[1]: bootflash_clean.service: Unit entered failed state.

[   11.559706] localhost systemd[1]: bootflash_clean.service: Failed with result 'exit-code'.

 

â boothelper_autoupgrade.service

   Loaded: loaded (/lib/systemd/system/boothelper_autoupgrade.service; enabled; vendor preset: enabled)

   Active: failed (Result: exit-code) since Tue 2020-07-28 11:04:34 Universal; 76ms ago

  Process: 756 ExecStart=/etc/init.d/binos_boothelper_funcs.sh boot_helper_upgrade_start (code=exited, status=203/EXEC)

Main PID: 756 (code=exited, status=203/EXEC)

 

[   11.550092] localhost systemd[1]: Starting boothelper_autoupgrade.service...

[   11.560589] localhost systemd[1]: boothelper_autoupgrade.service: Main process exited, code=exited, status=203/EXEC

[   11.561507] localhost systemd[1]: Failed to start boothelper_autoupgrade.service.

[   11.562369] localhost systemd[1]: boothelper_autoupgrade.service: Unit entered failed state.

[   11.563207] localhost systemd[1]: boothelper_autoupgrade.service: Failed with result 'exit-code'.

 

â chasfs.service - Setup ChasFS

   Loaded: loaded (/lib/systemd/system/chasfs.service; static; vendor preset: enabled)

   Active: failed (Result: exit-code) since Tue 2020-07-28 11:04:34 Universal; 147ms ago

  Process: 714 ExecStart=/etc/init.d/chasfs_boottime.sh (code=exited, status=203/EXEC)

Main PID: 714 (code=exited, status=203/EXEC)

 

[   11.449347] localhost systemd[1]: Starting Setup ChasFS...

[   11.482084] localhost systemd[1]: chasfs.service: Main process exited, code=exited, status=203/EXEC

[   11.482924] localhost systemd[1]: Failed to start Setup ChasFS.

[   11.502724] localhost systemd[1]: chasfs.service: Unit entered failed state.

[   11.504789] localhost systemd[1]: chasfs.service: Failed with result 'exit-code'.

 

â mount_packages.service - Mount packages

   Loaded: loaded (/lib/systemd/system/mount_packages.service; enabled; vendor preset: enabled)

   Active: failed (Result: exit-code) since Tue 2020-07-28 11:04:34 Universal; 203ms ago

  Process: 485 ExecStart=/mount_packages.sh (code=exited, status=1/FAILURE)

Main PID: 485 (code=exited, status=1/FAILURE)

 

[    6.629334] localhost systemd[1]: Starting Mount packages...

[    6.676649] localhost mount_packages.sh[485]: booted_item=/flash/cat3k_caa-universalk9.16.06.07.SPA.conf

[    6.686800] localhost mount_packages.sh[485]: bootloader_version=

[    6.688696] localhost mount_packages.sh[485]: skipping piso processing

[    6.689524] localhost mount_packages.sh[485]: package.conf boot

[    6.762698] localhost mount_packages.sh[485]: Packages directory:       [/flash]

[    6.763582] localhost mount_packages.sh[485]: Provisioning file:        [/tmp/packages.conf]

[    6.764403] localhost mount_packages.sh[485]: Provisioning file content:

[    6.765204] localhost mount_packages.sh[485]: --/tmp/packages.conf------------------------

[    6.767481] localhost mount_packages.sh[485]: sha1sum: a795c1cbcf9f379f13d6d656fc63f954f9e7c85a

[    6.768283] localhost mount_packages.sh[485]: iso   rp 0 0   rp_base        cat3k_caa-rpbase.16.06.07.SPA.pkg

[    6.769095] localhost mount_packages.sh[485]: iso   rp 0 0   rp_core        cat3k_caa-rpcore.16.06.07.SPA.pkg

[    6.769859] localhost mount_packages.sh[485]: iso   rp 0 0   rp_daemons     cat3k_caa-rpcore.16.06.07.SPA.pkg

[    6.770646] localhost mount_packages.sh[485]: iso   rp 0 0   rp_iosd        cat3k_caa-rpcore.16.06.07.SPA.pkg

[    6.771434] localhost mount_packages.sh[485]: iso   rp 0 0   rp_webui       cat3k_caa-webui.16.06.07.SPA.pkg

[    6.772246] localhost mount_packages.sh[485]: iso   rp 0 0   srdriver       cat3k_caa-srdriver.16.06.07.SPA.pkg

[    6.773051] localhost mount_packages.sh[485]: iso   rp 0 0   rp_security    cat3k_caa-rpcore.16.06.07.SPA.pkg

[    6.773817] localhost mount_packages.sh[485]: iso   rp 0 0   guestshell     cat3k_caa-guestshell.16.06.07.SPA.pkg

[    6.774636] localhost mount_packages.sh[485]: iso   fp 0 0   fp             cat3k_caa-rpcore.16.06.07.SPA.pkg

[    6.775484] localhost mount_packages.sh[485]: ----------------------==/tmp/packages.conf--

[    7.504684] localhost mount_packages.sh[485]: Production Image

[    7.543203] localhost mount_packages.sh[485]: Processing nfs directives ...

[    7.571557] localhost mount_packages.sh[485]: Processing mount directives ...

[    7.599798] localhost mount_packages.sh[485]: Processing link_iso directives ...

[    7.628052] localhost mount_packages.sh[485]: Processing iso directives ...

[    7.649936] localhost mount_packages.sh[485]: defer checking of /flash/cat3k_caa-rpbase.16.06.07.SPA.pkg

[    7.764656] localhost mount_packages.sh[485]: ISO linking /tmp/sw/rp/0/0/rp_base/mount

[    7.765523] localhost mount_packages.sh[485]:          -> /flash/cat3k_caa-rpbase.16.06.07.SPA.pkg

[    7.789482] localhost mount_packages.sh[485]: defer checking of /flash/cat3k_caa-rpcore.16.06.07.SPA.pkg

[    8.109878] localhost mount_packages.sh[485]: ISO linking /tmp/sw/rp/0/0/rp_core/mount

[    8.110715] localhost mount_packages.sh[485]:          -> /flash/cat3k_caa-rpcore.16.06.07.SPA.pkg

[    8.257790] localhost mount_packages.sh[485]: ISO linking /tmp/sw/rp/0/0/rp_daemons/mount

[    8.258637] localhost mount_packages.sh[485]:          -> /flash/cat3k_caa-rpcore.16.06.07.SPA.pkg

[    8.332967] localhost mount_packages.sh[485]: ISO linking /tmp/sw/rp/0/0/rp_iosd/mount

[    8.333818] localhost mount_packages.sh[485]:          -> /flash/cat3k_caa-rpcore.16.06.07.SPA.pkg

[    8.354588] localhost mount_packages.sh[485]: defer checking of /flash/cat3k_caa-webui.16.06.07.SPA.pkg

[    8.367763] localhost mount_packages.sh[485]: can't stat file: /flash/cat3k_caa-webui.16.06.07.SPA.pkg

[    8.395483] localhost mount_packages.sh[485]: hexdump: /flash/cat3k_caa-webui.16.06.07.SPA.pkg: No such file or directory

[    8.396334] localhost mount_packages.sh[485]: hexdump: all input file arguments failed

[    8.404753] localhost mount_packages.sh[485]: mount: /flash/cat3k_caa-webui.16.06.07.SPA.pkg: failed to setup loop device: No such file or directory

[   10.413328] localhost mount_packages.sh[485]: Could not mount package /flash/cat3k_caa-webui.16.06.07.SPA.pkg

[   11.422788] localhost mount_packages.sh[485]: Could not mount package /flash/cat3k_caa-webui.16.06.07.SPA.pkg

[   11.423543] localhost mount_packages.sh[485]: Failed to process provisioning file (/tmp/packages.conf).

[   11.424535] localhost systemd[1]: mount_packages.service: Main process exited, code=exited, status=1/FAILURE

[   11.425421] localhost systemd[1]: Failed to start Mount packages.

[   11.445903] localhost systemd[1]: mount_packages.service: Unit entered failed state.

[   11.447113] localhost systemd[1]: mount_packages.service: Failed with result 'exit-code'.

 

â nfs-server.service - NFS Server

   Loaded: loaded (/lib/systemd/system/nfs-server.service; enabled; vendor preset: enabled)

   Active: failed (Result: exit-code) since Tue 2020-07-28 11:04:34 Universal; 4s ago

  Process: 759 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=1/FAILURE)

 

[   11.533230] localhost exportfs[759]: exportfs: can't open /etc/exports for reading

[   11.552773] localhost systemd[1]: Starting NFS Server...

[   11.564044] localhost systemd[1]: nfs-server.service: Control process exited, code=exited status=1

[   11.564859] localhost systemd[1]: Failed to start NFS Server.

[   11.570245] localhost systemd[1]: nfs-server.service: Unit entered failed state.

[   11.571088] localhost systemd[1]: nfs-server.service: Failed with result 'exit-code'.

 

â sshd.service - SSH Daemon

   Loaded: loaded (/lib/systemd/system/sshd.service; static; vendor preset: enabled)

   Active: failed (Result: exit-code) since Tue 2020-07-28 11:04:34 Universal; 8s ago

  Process: 728 ExecStart=/bin/mcp_pkg_wrap rp_security /etc/init.d/sshd start (code=exited, status=203/EXEC)

 

[   11.467660] localhost systemd[1]: Starting SSH Daemon...

[   11.540126] localhost systemd[1]: sshd.service: Control process exited, code=exited status=203

[   11.540945] localhost systemd[1]: Failed to start SSH Daemon.

[   11.541861] localhost systemd[1]: sshd.service: Unit entered failed state.

[   11.542710] localhost systemd[1]: sshd.service: Failed with result 'exit-code'.

>>> Rebooting

Failed to connect to bus: No such file or directory

Failed to connect to bus: No such file or directory

octeon_wdt: WDT device closed unexpectedly.  WDT will not stop!

reboot: Restarting system

 

Thanks,

4 REPLIES 4
Highlighted
Hall of Fame Community Legend

What is the uptime of this switch?
Highlighted

Now is 3 days and 8 hours.
Highlighted

Post the complete output to the command "dir".
Highlighted

cat3k_caa-wcm.16.03.08.SPA.pkg this package is missing.  I re-do everything and still missing this package.  can I just copy it from another switch?  would still work the upgrade?

thanks,

Content for Community-Ad