cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1105
Views
0
Helpful
7
Replies
Highlighted

etherchannel between Nexus 2232 and blade switch 3020, flapping !

Hi,

I try to connect a cisco blade switch 3020 to Nexus 2232 with etherchannel, but when I connect the second link a obtain flapping on vlans !

Aug  7 09:06:30.569 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 0050.565c.0e6a in vlan 100 is flapping between port Gi0/18 and port Gi0/17

Aug  7 09:06:31.140 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 001c.58e3.e38c in vlan 101 is flapping between port Gi0/18 and port Gi0/17

....

Can someone help me why the vlans are flapping ? it's something wrong on the config ?

thx in advance

Chris

-->NEXUS config

interface port-channel6

  switchport mode trunk

  spanning-tree bpdufilter enable

  speed 1000

  duplex full

interface Ethernet102/1/1

  switchport mode trunk

  spanning-tree bpdufilter enable

  speed 1000

  duplex full

  channel-group 6

interface Ethernet103/1/1

  switchport mode trunk

  spanning-tree bpdufilter enable

  speed 1000

  duplex full

  channel-group 6

-->Blade switch config :

interface Port-channel2

switchport mode trunk

switchport nonegotiate

end

!

interface GigabitEthernet0/17

switchport mode trunk

switchport nonegotiate

media-type rj45

duplex full

channel-group 2 mode active

end

!

interface GigabitEthernet0/18

switchport mode trunk

switchport nonegotiate

media-type rj45

speed 1000

duplex full

channel-group 2 mode active

end

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Community Legend

Re: etherchannel between Nexus 2232 and blade switch 3020, flapp

but sorry what is the difference between mode active and ON ?

When you say "channel-group BLAH mode ON" it is NEITHER LACP nor PAGP.

Your Nexus configuration states a default value but your 3020 has stated ACTIVE.  This is a configuration mismatch.

Can I ask if you can mark this thread as "Answered"?

View solution in original post

7 REPLIES 7
Hall of Fame Community Legend

etherchannel between Nexus 2232 and blade switch 3020, flapping

Aug  7 09:06:30.569 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 0050.565c.0e6a in vlan 100 is flapping between port Gi0/18 and port Gi0/17

Aug  7 09:06:31.140 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 001c.58e3.e38c in vlan 101 is flapping between port Gi0/18 and port Gi0/17

Host with MAC address of "0050.565c.0e6a" is a VMware.

Host with MAC address of "001c.58e3.e38c" is Cisco.

MAC is flapping into two different interfaces possibly because your eitherchannel may not be UP.

On the 3020, can you please post the output to the command "sh etherchann 6 summary"?

etherchannel between Nexus 2232 and blade switch 3020, flapping

On the 3020,

sh etherchannel 2 summary

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 2

Number of aggregators:           2

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

2      Po2(SD)         LACP      Gi0/17(I)   Gi0/18(D) 

Hall of Fame Community Legend

Re: etherchannel between Nexus 2232 and blade switch 3020, flapp

That answers the question.

"I" means it's in "stand alone" and not in etherchannel.  "D", of course, means DOWN.

In your 3020, can you change the etherchannel config to the following?

interface range G0/17 - 18

switchport mode trunk

switchport trunk encap dot1q

channel group 2  mode ON

etherchannel between Nexus 2232 and blade switch 3020, flapping

ok, now I have change on both and the result is :

sh etherchannel 2 summary

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 2

Number of aggregators:           2

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

2      Po2(SU)          -        Gi0/17(P)   Gi0/18(P)

THANK YOU VERY MUCH !

but sorry what is the difference between mode active and ON ?

Hall of Fame Community Legend

Re: etherchannel between Nexus 2232 and blade switch 3020, flapp

but sorry what is the difference between mode active and ON ?

When you say "channel-group BLAH mode ON" it is NEITHER LACP nor PAGP.

Your Nexus configuration states a default value but your 3020 has stated ACTIVE.  This is a configuration mismatch.

Can I ask if you can mark this thread as "Answered"?

View solution in original post

etherchannel between Nexus 2232 and blade switch 3020, flapping

1000 THANKS

Best Regards

Christophe

Hall of Fame Community Legend

etherchannel between Nexus 2232 and blade switch 3020, flapping

Glad to be of some form of assistance.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards