08-05-2014 07:55 AM - edited 03-07-2019 08:16 PM
First time configuring etherchannel. I have followed the documentation, watched videos, etc. The channel is up, but wanted to verify I did it right - and have not missed something.
Scenario:
Connecting a brand new 3650X into a 3750. The 3750 is the "Core" and does the layer 3 routing, etc. The 3650 is going to become a new Server Backbone - should participate on VLAN 10 only. All servers in our data farm will connect into it (eventually).
Normally we just create one trunk port on each switch and call it done (we do not have a big data farm/and or IT team) but I wanted to start looking at Etherchannel, etc.
Config - Core:
interface GigabitEthernet2/0/12
description ***Trunk to 203 - Server Backbone***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
switchport nonegotiate
Server Backbone:
interface GigabitEthernet1/0/1
description ***Server Backbone - Switch 3 - Trunk***
switchport trunk allowed vlan 10
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
interface Port-channel1
switchport trunk allowed vlan 10
switchport mode trunk
switchport nonegotiate
(Does not have the encapsulation command, as not available in that IOS - assuming it is automatic?).
Basically I am looking to improve throughput and redundancy. Is there anything else I should add and/or change about what was configured?
(NOTE: I know these may or may not be the best switches to use - but they are what we can afford on our budget).
Solved! Go to Solution.
08-05-2014 10:47 AM
Therea are two ports on the core and 2 on the backbone switch. I just cut an pasted an interface from each (they are both configured the same).
08-05-2014 10:16 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Well, of course, you want more than one link in your port-channel, both for additional aggregate bandwidth and additional redundancy.
You may want to review whether you're using the optimal hashing algorithm for your port-channel.
08-05-2014 10:49 AM
See above.
Not sure what you mean by Optimal Hashing Algorithm (let me know what I have to look for). Thanks for the reply.
08-05-2014 05:01 PM
3750X e.g.
http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750x_3560x/software/release/12-2_55_se/configuration/guide/3750xscg/swethchl.html#wp1275731
http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750x_3560x/software/release/12-2_55_se/configuration/guide/3750xscg/swethchl.html#wp1276203
08-05-2014 10:47 AM
Therea are two ports on the core and 2 on the backbone switch. I just cut an pasted an interface from each (they are both configured the same).
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide