cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

3543
Views
3
Helpful
9
Replies
Beginner

Etherchannel - Layer 2 or 3

Hey there!

We are about to connect to another building with different IP ranges using an airlaser and an microwave link. We have two Cisco 3560X providing connection to the different LANs of the two buildings. Between the two Ciscos we use a transfer network and VLAN with an own IP Range, so the two 3560X have to route the different IP ranges. Both switches have an IP address in the transfer VLAN used as next hop for routing.

Our plan is to configure airlaser and microwave as an Etherchannel. Question is if we should use a layer 2 or a layer 3 etherchannel? What is the difference? Wouldn´t layer 2 be faster than layer 3? Will layer 2 cause trouble with routing or load balancing?

Would be thankful for a quick answer!

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Etherchannel - Layer 2 or 3

Hi Frieh ,

              Though u have used this VLAN on both switch and u made your port access Layer , It same like L3 etherchannel , instead defining ip address on interface port-channel 1 ,you have defined on L3 SVI and made your switch port to act like L2 port ,  it will pass all traffic via access link , though u have given routing for this VLAN IP address . This is good one on layer 2 switch .

         If you have used your switchport as L3 port it avoid vlan databse ,STP , which only carries Pagp protocol or LACP internally . If its trunk port between 2 switch only option is  its can be used only as L2 port on your both switch  . You cannot define L3 ether channel over there .

HTH

Thanks

san

HTH Regards Santhosh Saravanan
9 REPLIES 9
Beginner

Re: Etherchannel - Layer 2 or 3

Hi Freih ,

              As you said ur 2 building switches has 2 differnet vlan which doing routing based on your routing table , In this senario its better to have L3 ether channel , you can have L3 Ether channel defined on your switch .

config on both switch

interface portchannel 1

no switch port

ip address x.x.x.x 255.255.255.252

interface range fastethernet 0/23-24

channel-protocol pagp
channel-group 1 mode auto

L2 ether channel can be used on trunk port to avoid STP looping .

HTH

Thanks

San

HTH Regards Santhosh Saravanan
Beginner

Re: Etherchannel - Layer 2 or 3

Here is the link for l3 ether channel configuration

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.1_19_ea1/configuration/guide/swethchl.html

HTH

Thanks

san

HTH Regards Santhosh Saravanan
Beginner

Re: Etherchannel - Layer 2 or 3

Hi San,

thanks for your quick answer. But why is it better to use a layer 3 etherchannel? Because we already have to use routing between the different ip ranges?

BTW for information the config of one of our switches:

[...]

interface Port-channel1
switchport access vlan 100
switchport mode access
flowcontrol receive desired
spanning-tree portfast

interface GigabitEthernet0/1
description Po1 Airlaser
switchport access vlan 100
switchport mode access
speed 100
duplex full
flowcontrol receive desired
spanning-tree portfast
channel-group 1 mode desirable

[...]

VLAN 100 has an IP address on both siwtches for routing purposes.

it works, but now I think about configurationg a layer 3 etherchannel...

Beginner

Re: Etherchannel - Layer 2 or 3

Hi Frieh ,

              Though u have used this VLAN on both switch and u made your port access Layer , It same like L3 etherchannel , instead defining ip address on interface port-channel 1 ,you have defined on L3 SVI and made your switch port to act like L2 port ,  it will pass all traffic via access link , though u have given routing for this VLAN IP address . This is good one on layer 2 switch .

         If you have used your switchport as L3 port it avoid vlan databse ,STP , which only carries Pagp protocol or LACP internally . If its trunk port between 2 switch only option is  its can be used only as L2 port on your both switch  . You cannot define L3 ether channel over there .

HTH

Thanks

san

HTH Regards Santhosh Saravanan
Beginner

Re: Etherchannel - Layer 2 or 3

hello

Here is mine

CORE#sh interfaces port-channel 9 status

Port      Name               Status       Vlan       Duplex  Speed Type
Po10      here-to-B     connected    trunk     a-full a-1000

CORE#sh interfaces port-channel 9 etherchannel
Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
0     00     Gi1/0/11 On                 0
  0     00     Gi2/0/11 On                 0

!
interface Port-channel9
description from-here-to-B
switchport trunk encapsulation dot1q
switchport trunk native vlan Y
switchport trunk allowed vlan Y,XX,XX,XX,XX,XX,XX
switchport mode trunk
!

!
interface GigabitEthernet1/0/11
description from-here-to-B
switchport trunk encapsulation dot1q
switchport trunk native vlan Y
switchport trunk allowed vlan Y,XX,XX,XX,XX,XX,XX
switchport mode trunk
channel-group 10 mode on
!

!
interface GigabitEthernet2/0/11
description from-here-to-B
switchport trunk encapsulation dot1q
switchport trunk native vlan Y
switchport trunk allowed vlan Y,XX,XX,XX,XX,XX,XX
switchport mode trunk
channel-group 10 mode on
!

and in the other side the same!

Tell me if it works

Good Luck

Beginner

Re: Etherchannel - Layer 2 or 3

Hello ro,

you configured a trunk between your switches. I chose a switchport because of the management interfaces of the microwave link switches.While the connection is transparent and looks like a direct connection from cisco to cisco switch, the mircrowave link management is embedded in the connection.

This management IP has no VLAN configuration, so I guess it would not be accessible if I configure a trunk - but I also have to say that this is my first configuration of microwave link hardware.

Regards

FH

Beginner

Re: Etherchannel - Layer 2 or 3

Hi San,

right, the switches have to work on Layer3 (=routing) when passing traffic from one switch VLAN interface to the other. So in my case I would guess that it is all the same if I configure a layer 2 oder layer 3 etherchannel. I suppose that STP and a VLAN database would not affect transfer negatively.

To use a layer 3 channel I would have to configure "no switchport" corresponding to the link you left here (thanks for that). But if it is all the same - I can save the time!?

Beginner

Re: Etherchannel - Layer 2 or 3

At the end etherchannel works - but you hardly get access to the management of the connecting devices in the channel. And because of the devices the link between the ciscos do not go down if the laser / microwave is broken.

That is not really handy - but thanks for your posts!

Highlighted
Beginner

Re: Etherchannel - Layer 2 or 3

I configured L3 on both switches but i m confused how am i supposed to assign "port-channel IP address" on PC in order to ping other side? Or do not required to so anything after creating L3 etherchannel?

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards