cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1204
Views
5
Helpful
4
Replies
Beginner

EtherSwitch configuration on Cisco 2921

This is my first time to deal with EtherSwitch module, I have router Cisco CISCO2921/K9 and EtherSwitch module "SM-X-ES3-24-P: EtherSwitch SM L3" installed on it. I have many questions about how it does work:

 

1- If I want to create a routed interface (Layer 3 port), when I type "no switchport" command it says "command rejected, not allowed on this interface", Does that mean this switch not support Layer 3 feature? Hint: EtherSwitch license is lanbase and image is C3560E-UNIVERSALK9-M

 

2- from Router privilege mode I can't see switch interfaces status when I type "show ip interface brief", just shows the router's interfaces plus 2 extra Gi ports, and when entered switch privilege mode I see 26 ports instead of 24 ports, are those 2 ports have link to the extra 2 Gi ports on router?

 

3- Do I need to create VLAN id on both router and switch to have intra-connectivity between router and switch?, I mean I have subnets connected to other interfaces on the router and I want these subnets to reach other subnets created on the EtherSwitch, will it be direct connected automatically and no need to run routing protocol?

 

4- I have many branches will be connected to the router via EtherSwitch ports, How the WAN will be configered? , just create interface VLAN on Etherswitch and enable routing protocol on it and in the other side (branch) configure sub-interface with dotq1 encapsulation (if we assume ISP has connected our branches us through Layer 2 connectivity) or do you have a better solution (in case of L2 and L3 ISP backbone connection)?

 

Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

Re: EtherSwitch configuration on Cisco 2921

Hello,

 

basically, you need to configure a trunk between the switch module and the router, in order to connect them to each other. The GigabitEthernet1/0 port on the router is connecting to GigabitEthernet0/26 on the switch.
The Vlans need to be created manually on both the router and the switch.


Below is a sample configuration:

 

2921_Router#show run

interface GigabitEthernet1/0
description Link to Switch Module
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet1/0.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0

 

2921_Switch#show run

 

vlan 2
name VLAN2
!
interface GigabitEthernet0/26
description Link to Router
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan2
ip address 192.168.2.2 255.255.255.0

 

4 REPLIES 4
VIP Mentor

Re: EtherSwitch configuration on Cisco 2921

Hello,

 

basically, you need to configure a trunk between the switch module and the router, in order to connect them to each other. The GigabitEthernet1/0 port on the router is connecting to GigabitEthernet0/26 on the switch.
The Vlans need to be created manually on both the router and the switch.


Below is a sample configuration:

 

2921_Router#show run

interface GigabitEthernet1/0
description Link to Switch Module
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet1/0.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0

 

2921_Switch#show run

 

vlan 2
name VLAN2
!
interface GigabitEthernet0/26
description Link to Router
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan2
ip address 192.168.2.2 255.255.255.0

 

Beginner

Re: EtherSwitch configuration on Cisco 2921

So, I think I treat the switch as a separate device, then if I want to connect site1 to the HQ the configuration will be like this:

 

HQ_Router config

interface GigabitEthernet1/0
description Link to Switch Module
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet1/0.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.252

 

HQ_EtherSwitch config

vlan 2
name VLAN2
!
interface GigabitEthernet0/26
description Link to Router
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/1

description Link to Site1

switchport mode access

switchport access vlan 2

!

 

Site1 config

Interface GigabitEthernet0/0

description Link to HQ

ip address 192.168.2.2 255.255.255.252

!

 

After quick research I found this info "G1/0 on the router side connects to G0/25 on the switch module, and the routers G1/1 connects to G0/26 on the switch module" which answered my second question, Can I balance traffic between router and switch  

by allowing some VLANs to go via g0/25 (issue this command under interface mode switchport trunk allow vlan a,b,c) and other VLANs go via g0/26 (switchport trunk allow vlan x,y,z)?

 

 

Beginner

Re: EtherSwitch configuration on Cisco 2921

Thank you, it worked.
Highlighted
Beginner

Re: EtherSwitch configuration on Cisco 2921

 
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards