cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3177
Views
0
Helpful
4
Replies
Highlighted
Beginner

EtherSwitch Service Module (ES) Configuration 2811 & Cat3750

Hi All,

I have a 2811 router configured and working with a EtherSwitch Service Module, details below:

NME-16ES-1G-P: EtherSwitch SM 16 10/100T PoE + 1 GE Port adapter, 1 port

The current config attached shows the 2811 has a configured Service-Engine 0/0 and a Gigabit-Ethernet 1/0.

They are configured in such a way, to provide access to the integrated Cat3750 16 Port module.

I currently have the following 7 Vlans configured on the 3750 and I've configured fa1/0/16 as a Trunk port.

The Fa1/0/16 Trunk port has a Physical ethernet connection to the the 2811 Fa0/0.

The 2811 Fa0/0 is configured with Sub-Interfaces, which reflect the Vlans configured on the Cat3750.

This configuration works perfect I have no issue with the config. However I do have two questions I would really appreciate some clarity.

Q1) The Cisco Documentation states you can achieve what I have configured on FA1/0/16 via the GigaBit port 1/0/2

Note taken from Cisco pdf:

If the ES module or the devices connected to this ES module need to communicate to the external network via

the host router, this port (GigabitEthernet1/0/2) needs to be a Layer 3 port or it needs to be a member of Layer

3 VLAN. See the Configure Routing section of this document to understand how to configure the routing on

I have tried to configure the Gigabit 1/0/2 as stated above, but have been unsuccessful any configuration suggestions would help.

Q2) Etherswitch Module Interface Gigabit 1/0/1 on the 3750

The Etherswitch module, physically has 1 x gigabit interface, however the configuration of the Cat3750 shows

Gi1/0/1 & GI1/0/2.

GI1/0/2 is Virtually Binded / Configured to the Service-Engine and the Gi1/0 on the 2811 router.

However there is no phyical connection of the Gigabit interface on the ES Module.

My question: Can the Gigabit Port be physically used as a uplink / switchport aceess. i.e Phisically connect a ethernet cable from the port to another device, or is the Gi 1/0/1 config on Cat-3750 Virtually associated to the GI1/0 on the 2811 router.

Thanks for taking the timeout to read.

Cheers

Etherswitch.jpg

4 REPLIES 4
Enthusiast

Re: EtherSwitch Service Module (ES) Configuration 2811 & Cat375

There is no need to have a physical cable between the module and the router.  On the switch, the gig1/0/2 is bound to the 2811's gig1/0.  This is a gigabit connection across the backplane.  You can set them up just like you have a physical cable running between them.  I typically create subinterfaces for each VLAN on the router and make it a trunk port on the switch, then use the 2811 as the default gateway for each VLAN.  Regarding the switch's 1/0/1 port, I believe that's just a placeholder that can't be used for anything; perhaps the IOS developers felt that interfaces should come in pairs.

Highlighted
Beginner

Re: EtherSwitch Service Module (ES) Configuration 2811 & Cat375

Hi Munoz,

Do you have the configuration for setting the GI1/0/2 to a Trunk port ?

I have followed Cisco recommendation for configuring the EtherSwitch Module as a Service Module on the 2811 and the IP Address configuration at

either end of the Gigabit interface. You will note from the attached image the Cat3750 Gigabit port GI1/0/2 is configured as Layer 3 interface.

With this configuration there would would be no access to the  Session Access to the Service Module.

Please see attached Cisco Doc.

Cheers

Charles

Highlighted
Beginner

Re: EtherSwitch Service Module (ES) Configuration 2811 & Cat375

I tackled this problem today.  I have a slightly different config: my router is a 3945 and my ES SM is the 16-

port GigE one, but the concept is roughly the same.  I wanted to send VLANs 151-154 over to the Router so that it could route.

I decided to assign VLAN 45 as the "internal" VLAN for communications between the two.  I am guessing that if I had used native tagging, that would probably have worked on VLAN1, but I never use VLAN1 if I can avoid it, so I assigned 45.

I can't guarantee that all the config I did was required, but it does all work.

On the host Router (3945), I did this:

interface GigabitEthernet1/0
description SM-ES3G-16-P module inside of Router
no ip address
!
interface GigabitEthernet1/0.45
description Internal MGMT VLAN to Etherswitch SM
encapsulation dot1Q 45
ip address 10.10.10.241 255.255.255.248
!
interface GigabitEthernet1/0.151
description AZ1 port 5 test
encapsulation dot1Q 151
ip address 207.182.51.129 255.255.255.248
!
interface GigabitEthernet1/0.152
description AZ1 port 6 test
encapsulation dot1Q 152
ip address 207.182.51.137 255.255.255.248
!
interface GigabitEthernet1/0.153
description CA1 port 5 test2
encapsulation dot1Q 153
ip address 207.182.51.145 255.255.255.248
!
interface GigabitEthernet1/0.154
description CA1 port 6 test2
encapsulation dot1Q 154
ip address 207.182.51.153 255.255.255.248
!

Then on the switch, I wanted to assign ports 1-2 to VLAN 151, ports 3-4 to VLAN 152, etc.

In the case of this switch, the "internal" port is 0/18 because they are all gig.

Thus:

lan 45
name OPUSGWINT
!
vlan 151 
name TSTTOP5
!
vlan 152
name TSTTOP6
!
vlan 153
name TSTBOT5
!
vlan 154
name TSTBOT6

interface GigabitEthernet0/1
switchport access vlan 151
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/2
switchport access vlan 151
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/3
switchport access vlan 152
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/4
switchport access vlan 152
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/5
switchport access vlan 153
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/6
switchport access vlan 153
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/7
switchport access vlan 154
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/8
switchport access vlan 154
switchport mode access
spanning-tree portfast
interface GigabitEthernet0/18
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
!
interface Vlan45
ip address 10.10.10.242 255.255.255.248

Joel Snyder / Opus One

Highlighted

Hi 

Hi 

I am having simillar probelm a 2951 switch and Etherswitch service module SM-X-ES3-16-P.

I am not able to enable thr routing between the two and i nee dto enabel HSRP as well between the two.

The solution suggested will not work as i will not able to access the internal service module from the router then.

it gives me this message

IP address required to access service module.

Please advise.

CreatePlease to create content
Content for Community-Ad