cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
639
Views
0
Helpful
6
Replies

Excess Defer frames on each Mitel ip phone port

YVI
Beginner
Beginner

Hi,

 

I have an issue with Mitel ip phones on my lan. Each switchport which has a phone connected to, shows a high output drop count, and doing a "show controllers" indicate high Excess Defer frames. Users have problems with call transfer, and crappy sound sometimes. 

 

My setup is :

- WS-C3850-48P with 03.06.06E cat3k_caa-universalk9

- Mitel 6863i ip phones

- auto speed & duplex set on each port ; 100Mb/s full duplex active (6863i is 10/100) 

- lldp enabled

 

Here is a typical switchport configuration :

 

interface GigabitEthernet1/0/36
switchport access vlan 452
switchport mode access
switchport voice vlan 552
trust device cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
service-policy input AutoQos-4.0-CiscoPhone-Input-Policy
service-policy output AutoQos-4.0-Output-Policy

 

 

This evening i tried to force 100/Full on some ports, clear counters and clear controllers. I'll see if it changes anything.

 

Thanks in advance for your advice.

 

Regards

 

YVI

6 Replies 6

Giuseppe Larosa
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Hello Shodan,

follow the thread and check the cabling on each affected port with TDR tests

 

https://community.cisco.com/t5/switching/deferred-frames-on-full-duplex-link-on-3850/td-p/3025843/page/2

 

Deferred frames should not appear in a working full duplex link. As they refer to frames dropped after 16 attempts to send for detected collisions. So the question becomes testing the cabling as first step

 

https://community.cisco.com/t5/switching/deferred-frames-on-full-duplex-link-on-3850/td-p/3025843

 

There is a link to TDR document made by Leo

 

Hope to help

Giuseppe

 

Hi Giuseppe,
Many thanks for your quick answer. I was thinking it may be related to Mitel phones as EDF appears only on ports connected to ip phones. Theses are 10/100 models and setting some ports to 100/full didn't solve the issue. I will test the cables to be sure, but that would mean that every cable is defect...?

Thanks
YVI

Giuseppe Larosa
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Hello Shodan,

testing the cables is just the first troubleshooting step I suggest just to verify there are no issues with cables.

As you noted it is unlikely that all the cables going to Mitel IP phones are faulty.

If the cables are good, there is an interoperability issue with the IP phones.

But the first step is still to verify OSI layer1  (bottom to up layer approach).

 

Edit:

Excess Defer Frames and Defer Frames are not the same thing. The Defer frames are related to half duplex operation as explained in the following tech note:

https://www.cisco.com/c/en/us/support/docs/interfaces-modules/port-adapters/12768-eth-collisions.html#topic2

 

Excess Defer Frames are instead related to bursts of traffic or QoS operation see the following thread

 

https://community.cisco.com/t5/switching/catalyst-3850-high-total-output-drops-and-output-errors/td-p/3726497

 

As suggested by Georg it would be useful to check

show policy-map interface gi1/0/x

 

to verify if the output drops equal to Excess Defer frames are also reported here and in what traffic class they happen.

However, all the other threads about Excess Defer frames in C3850 are related to server to server communication at high speed.

 

Hope to help

Giuseppe

 

 

Hello,

 

I once (quite a while ago, so I am not sure what he newer models do) worked with Mitel phones and Cisco switches, and I seem to remember that the Mitel phones boot in the native Vlan to find the DHCP server (and applicable options such as option 43), and then after finding the DHCP server, reboot and grab the voice Vlan. 

The switchport config you posted should work, but you can also try to configure the port as a trunk and set the native Vlan on the trunk:

 

interface GigabitEthernet1/0/36
switchport mode trunk
switchport trunk native vlan 452
switchport trunk allowed vlan 452,552
trust device cisco-phone
auto qos voip cisco-phone
spanning-tree portfast trunk
service-policy input AutoQos-4.0-CiscoPhone-Input-Policy
service-policy output AutoQos-4.0-Output-Policy

 

Not sure to be honest if this has anything to do with the deferred frames. What does the service policy actually do on the interface ? Can you post the output of 'show policy-map interface GigabitEthernet1/0/36' ?

Hi all,

 

First, thanks for your replies.

 

Here are the results of some TDR tests on interfaces that show EDF. First result is from a switch-to-switch link with no EDF, all the others from "faulty" ip phones links.

 

 

Interface Speed Local pair Pair length Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Gi1/0/13 1000M Pair A 32 +/- 10 meters Pair A Normal
Pair B 32 +/- 10 meters Pair B Normal
Pair C 32 +/- 10 meters Pair C Normal
Pair D 32 +/- 10 meters Pair D Normal

TDR test last run on: July 14 09:18:46

Interface Speed Local pair Pair length Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Gi1/0/28 100M Pair A 0 +/- 1 meters Pair A Normal
Pair B 0 +/- 1 meters Pair B Normal
Pair C 27 +/- 1 meters N/A Short
Pair D 28 +/- 1 meters N/A Short

TDR test last run on: July 14 09:13:52

Interface Speed Local pair Pair length Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Gi1/0/30 100M Pair A 0 +/- 1 meters Pair B Normal
Pair B 0 +/- 1 meters Pair A Normal
Pair C 34 +/- 1 meters N/A Short
Pair D 34 +/- 1 meters N/A Short

TDR test last run on: July 14 09:15:21

Interface Speed Local pair Pair length Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Gi1/0/34 100M Pair A 0 +/- 1 meters Pair A Normal
Pair B 0 +/- 1 meters Pair B Normal
Pair C 40 +/- 1 meters N/A Short
Pair D 40 +/- 1 meters N/A Short

 

 

What is "short" result ? Is it ok with Fast ethernet ?

 

I'll post another reply with policy-map results.

 

YVI

 

 

Hi again,

 

Here are the policy-map results from some EDF interfaces. I don't know anything about QoS, we are just using Cisco's AutoQos ( shame on me:)  ). Service policy is set automatically on each port when applying Cisco AutoQos.

 

 

 

Switch#show policy-map interface GigabitEthernet1/0/34
GigabitEthernet1/0/34

Service-policy input: AutoQos-4.0-CiscoPhone-Input-Policy

Class-map: AutoQos-4.0-Voip-Data-CiscoPhone-Class (match-any)
0 packets
Match: cos 5
0 packets, 0 bytes
5 minute rate 0 bps
QoS Set
dscp ef
police:
cir 128000 bps, bc 8000 bytes
conformed 0 bytes; actions:
transmit
exceeded 0 bytes; actions:
set-dscp-transmit dscp table policed-dscp
conformed 0000 bps, exceeded 0000 bps

Class-map: AutoQos-4.0-Voip-Signal-CiscoPhone-Class (match-any)
0 packets
Match: cos 3
0 packets, 0 bytes
5 minute rate 0 bps
QoS Set
dscp cs3
police:
cir 32000 bps, bc 8000 bytes
conformed 0 bytes; actions:
transmit
exceeded 0 bytes; actions:
set-dscp-transmit dscp table policed-dscp
conformed 0000 bps, exceeded 0000 bps

Class-map: AutoQos-4.0-Default-Class (match-any)
0 packets
Match: access-group name AutoQos-4.0-Acl-Default
0 packets, 0 bytes
5 minute rate 0 bps
QoS Set
dscp default

Class-map: class-default (match-any)
0 packets
Match: any

Service-policy output: AutoQos-4.0-Output-Policy

queue stats for all priority classes:
Queueing
priority level 1

(total drops) 0
(bytes output) 34123636

Class-map: AutoQos-4.0-Output-Priority-Queue (match-any)
0 packets
Match: dscp cs4 (32) cs5 (40) ef (46)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 5
0 packets, 0 bytes
5 minute rate 0 bps
Priority: 30% (30000 kbps), burst bytes 750000,

Priority Level: 1

Class-map: AutoQos-4.0-Output-Control-Mgmt-Queue (match-any)
0 packets
Match: dscp cs2 (16) cs3 (24) cs6 (48) cs7 (56)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 3
0 packets, 0 bytes
5 minute rate 0 bps
Queueing

queue-limit dscp 16 percent 80
queue-limit dscp 24 percent 90
queue-limit dscp 48 percent 100
queue-limit dscp 56 percent 100
(total drops) 0
(bytes output) 0
bandwidth remaining 10%

queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Multimedia-Conf-Queue (match-any)
0 packets
Match: dscp af41 (34) af42 (36) af43 (38)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 4
0 packets, 0 bytes
5 minute rate 0 bps
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 10%
queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Trans-Data-Queue (match-any)
0 packets
Match: dscp af21 (18) af22 (20) af23 (22)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 2
0 packets, 0 bytes
5 minute rate 0 bps
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 10%
queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Bulk-Data-Queue (match-any)
0 packets
Match: dscp af11 (10) af12 (12) af13 (14)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 1
0 packets, 0 bytes
5 minute rate 0 bps
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 4%
queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Scavenger-Queue (match-any)
0 packets
Match: dscp cs1 (8)
0 packets, 0 bytes
5 minute rate 0 bps
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 1%
queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Multimedia-Strm-Queue (match-any)
0 packets
Match: dscp af31 (26) af32 (28) af33 (30)
0 packets, 0 bytes
5 minute rate 0 bps
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 10%
queue-buffers ratio 10

Class-map: class-default (match-any)
0 packets
Match: any
Queueing

(total drops) 981410
(bytes output) 482049651
bandwidth remaining 25%
queue-buffers ratio 25

 

 

 

Switch#show policy-map interface GigabitEthernet1/0/30
GigabitEthernet1/0/30

Service-policy input: AutoQos-4.0-CiscoPhone-Input-Policy

Class-map: AutoQos-4.0-Voip-Data-CiscoPhone-Class (match-any)
0 packets
Match: cos 5
0 packets, 0 bytes
5 minute rate 0 bps
QoS Set
dscp ef
police:
cir 128000 bps, bc 8000 bytes
conformed 0 bytes; actions:
transmit
exceeded 0 bytes; actions:
set-dscp-transmit dscp table policed-dscp
conformed 0000 bps, exceeded 0000 bps

Class-map: AutoQos-4.0-Voip-Signal-CiscoPhone-Class (match-any)
0 packets
Match: cos 3
0 packets, 0 bytes
5 minute rate 0 bps
QoS Set
dscp cs3
police:
cir 32000 bps, bc 8000 bytes
conformed 0 bytes; actions:
transmit
exceeded 0 bytes; actions:
set-dscp-transmit dscp table policed-dscp
conformed 0000 bps, exceeded 0000 bps

Class-map: AutoQos-4.0-Default-Class (match-any)
0 packets
Match: access-group name AutoQos-4.0-Acl-Default
0 packets, 0 bytes
5 minute rate 0 bps
QoS Set
dscp default

Class-map: class-default (match-any)
0 packets
Match: any

Service-policy output: AutoQos-4.0-Output-Policy

queue stats for all priority classes:
Queueing
priority level 1

(total drops) 0
(bytes output) 34160621

Class-map: AutoQos-4.0-Output-Priority-Queue (match-any)
0 packets
Match: dscp cs4 (32) cs5 (40) ef (46)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 5
0 packets, 0 bytes
5 minute rate 0 bps
Priority: 30% (30000 kbps), burst bytes 750000,

Priority Level: 1

Class-map: AutoQos-4.0-Output-Control-Mgmt-Queue (match-any)
0 packets
Match: dscp cs2 (16) cs3 (24) cs6 (48) cs7 (56)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 3
0 packets, 0 bytes
5 minute rate 0 bps
Queueing

queue-limit dscp 16 percent 80
queue-limit dscp 24 percent 90
queue-limit dscp 48 percent 100
queue-limit dscp 56 percent 100
(total drops) 0
(bytes output) 0
bandwidth remaining 10%

queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Multimedia-Conf-Queue (match-any)
0 packets
Match: dscp af41 (34) af42 (36) af43 (38)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 4
0 packets, 0 bytes
5 minute rate 0 bps
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 10%
queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Trans-Data-Queue (match-any)
0 packets
Match: dscp af21 (18) af22 (20) af23 (22)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 2
0 packets, 0 bytes
5 minute rate 0 bps
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 10%
queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Bulk-Data-Queue (match-any)
0 packets
Match: dscp af11 (10) af12 (12) af13 (14)
0 packets, 0 bytes
5 minute rate 0 bps
Match: cos 1
0 packets, 0 bytes
5 minute rate 0 bps
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 4%
queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Scavenger-Queue (match-any)
0 packets
Match: dscp cs1 (8)
0 packets, 0 bytes
5 minute rate 0 bps
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 1%
queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Multimedia-Strm-Queue (match-any)
0 packets
Match: dscp af31 (26) af32 (28) af33 (30)
0 packets, 0 bytes
5 minute rate 0 bps
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 10%
queue-buffers ratio 10

Class-map: class-default (match-any)
0 packets
Match: any
Queueing

(total drops) 394245
(bytes output) 422272804
bandwidth remaining 25%
queue-buffers ratio 25

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers