cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

194
Views
0
Helpful
7
Replies
Highlighted
Beginner

Failover using ISP Metro

I have using cisco 3560x.

Site TA : 3560x

Site KA : 3560x

I'm using vlan routing for communication between site TA and site KA.

and I have 2 provider metro-e, ISP T and ISP B.

1.JPG

How to make if ISP T is fail, ISP B is running automatically?

now if ISP T fail, I must shutdown port ISP T for running ISP B.

I think if using port channel then fail over is run.

 

Please advice. Thanks

7 REPLIES 7
VIP Advisor

Re: Failover using ISP Metro

Depends how your switch configured, since we do not know the configuration  i suggest to have look IP SLA 

 

Make 2 routing

apply IP SLA track - if one of the links fail, shift the traffic to failover link. if the primary link come back, wait for a period of time to check the stability and shift the traffic back to primary.

 

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipsla/configuration/xe-3se/3650/sla-xe-3se-3650-book/sla_icmp_echo.html

BB
*** Rate All Helpful Responses ***
Beginner

Re: Failover using ISP Metro

Config for site TA :

interface Port-channel6
 description ACC-VLAN8-METRO
 switchport access vlan 8
 switchport mode access
!
!
interface GigabitEthernet0/8
 description METRO-KRWG-TNG (TELKOM)
 switchport access vlan 8
 switchport mode access
 shutdown
 channel-group 6 mode active
!
!
interface GigabitEthernet0/12
 description METRO-KRWG-TNG (BIZNET)
 switchport access vlan 8
 switchport mode access
 channel-group 6 mode active
!
!
interface Vlan8
 description VLAN-METRO
 ip address 10.20.10.1 255.255.255.0
!
!
ip route 172.31.0.0 255.255.0.0 10.20.10.2

for site KA:

interface Port-channel6
 description ACC-VLAN8-METRO
 switchport access vlan 8
 switchport mode access
!
interface GigabitEthernet0/8
 description METRO-KRWG-TNG (TELKOM)
 switchport access vlan 8
 switchport mode access
 channel-group 6 mode active
!
interface GigabitEthernet0/12
 description METRO-KRWG-TNG (BIZNET)
 switchport access vlan 8
 switchport mode access
 channel-group 6 mode active
!
interface Vlan8
 description VLAN-METRO
 ip address 10.20.10.2 255.255.255.0
!
ip route 192.168.0.0 255.255.0.0 10.20.10.1

I have not using IP SLA, what should be a concern if I using IP SLA?

VIP Advisor

Re: Failover using ISP Metro

Can you update the diagram which one is TA and KA

 

After reviewing the config you have of the port in shutdown mode. what is the reason

interface GigabitEthernet0/8
 description METRO-KRWG-TNG (TELKOM)
 switchport access vlan 8
 switchport mode access
 shutdown
 channel-group 6 mode active

 

can you post show version of each switch to check what kind of License you have for your IOS

 

Other question, when they extended L2 between these sites, Port-channel automatically Loadbalance the Links ?

Bot the links in Port-channel group, so if 1 link godown all the traffic should move to other link

 

until i miss something here, please clairfy?

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Failover using ISP Metro

I do shutdown for interface GI0/8 because ISP T is down. If I do not shutdown, my ISP B can not up.

show version →
License Level: ipbase
License Type: Permanent
Next reload license Level: ipbase

cisco WS-C3560X-24 (PowerPC405) processor (revision A0) with 262144K bytes of memory.
Processor board ID FDO1706Z08Q
Last reset from power-on
10 Virtual Ethernet interfaces
1 FastEthernet interface
28 Gigabit Ethernet interfaces
2 Ten Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : 4C:4E:35:EE:1A:80
Motherboard assembly number : 73-12554-08
Motherboard serial number : FDO17060959
Model revision number : A0
Motherboard revision number : A0
Model number : WS-C3560X-24T-S
Daughterboard assembly number : 800-32786-02
Daughterboard serial number : FDO17060246
System serial number : FDO1706Z08Q
Top Assembly Part Number : 800-31331-07
Top Assembly Revision Number : B0
Version ID : V04
CLEI Code Number : COMJU00ARD
Hardware Board Revision Number : 0x04


Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 30 WS-C3560X-24 15.0(2)SE1 C3560E-UNIVERSALK9-M

I need a fail over for a while I not need a load balance.
Yes. If one port link go down , then traffic move to other link.

 

using flex link?

Beginner

Re: Failover using ISP Metro

show version

License Level: ipbase
License Type: Permanent
Next reload license Level: ipbase

cisco WS-C3560X-24 (PowerPC405) processor (revision A0) with 262144K bytes of memory.
Processor board ID FDO1706Z08Q
Last reset from power-on
10 Virtual Ethernet interfaces
1 FastEthernet interface
28 Gigabit Ethernet interfaces
2 Ten Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : 4C:4E:35:EE:1A:80
Motherboard assembly number     : 73-12554-08
Motherboard serial number       : FDO17060959
Model revision number           : A0
Motherboard revision number     : A0
Model number                    : WS-C3560X-24T-S
Daughterboard assembly number   : 800-32786-02
Daughterboard serial number     : FDO17060246
System serial number            : FDO1706Z08Q
Top Assembly Part Number        : 800-31331-07
Top Assembly Revision Number    : B0
Version ID                      : V04
CLEI Code Number                : COMJU00ARD
Hardware Board Revision Number  : 0x04


Switch Ports Model              SW Version            SW Image
------ ----- -----              ----------            ----------
*    1 30    WS-C3560X-24       15.0(2)SE1            C3560E-UNIVERSALK9-M

Yes , I want using fail over. if one link is go down, the traffic move to other link.

for a while load balance, i not use load balance.

VIP Advisor

Re: Failover using ISP Metro

Can you post both the side full configuration and show interface information (more) connected to the provider interface, both the side to understand more?

BB
*** Rate All Helpful Responses ***
Beginner

Re: Failover using ISP Metro

for interface to provider like this :

!
username admin privilege 15 password 7 047802150C2E1F1B5F491D
no aaa new-model
clock timezone Jakarta 7 0
system mtu routing 1500
ip routing
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/8 description METRO-KRWG-TNG (TELKOM) switchport access vlan 8 switchport mode access shutdown channel-group 6 mode active ! ! interface GigabitEthernet0/12 description METRO-KRWG-TNG (BIZNET) switchport access vlan 8 switchport mode access channel-group 6 mode active ! ip route 172.31.0.0 255.255.0.0 10.20.10.2

no more config.

 

 

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards