cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

1180
Views
5
Helpful
2
Replies

GLBP negotiation problems between routers

Hello,

Can some body helps us with this problem, please:

We are implementing in many on-line topologies the option: GLBP between routers with the purpose to send traffic to both routers at the same time. Boths routers are connected to the same switch Cisco (model: 3560 or 3750).

This works fine, good.

What is the problem:

  1. One router "A" have the following address:
      • ip address 10.2.200.4 255.255.0.0
      • glbp1 ip address 10.2.200.1
  2. The other router "B" has:
      • ip address 10.2.200.3 255.255.0.0
      • glbp 1 ip address 10.2.200.1

When we make a traceroute from a user connected to the switch, the first hope is: 10.2.200.4 and so on. This is O.K.

When we simulate that router "A" is out of service, the first hope is: 10.2.200.3.

When we restorage the normal operation in router "A" the first hope stay at: 10.2.200.3.

WE NEED THAT THE FIRST HOPE BE: 10.2.200.4 AFTER THE ROUTER "A" IS O.K.

Router "A" has the higher priority.

Can some body tell us if there is any an optional command inside GLBP with which the first hope change to: 10.2.200.4?

Waiting your sooner anwer,

Sincerely.

Roger.

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: GLBP negotiation problems between routers

Have you configured glbp forwarder preempt ? Preempt need to be enabled to achieve the result.

glbp forwarder preempt

To configure a router to take over as active virtual forwarder (AVF) for a Gateway Load Balancing Protocol (GLBP) group if it has higher priority than the current AVF, use the glbp forwarder preempt command in interface configuration mode. To disable this feature, use the no form of this command.

glbp group forwarder preempt [delay minimum seconds]

no glbp group forwarder preempt [delay minimum]

Doc here: http://www.cisco.com/en/US/docs/ios/12_2t/12_2t15/feature/guide/ft_glbp.html#wp1043971

2 REPLIES 2
Cisco Employee

Re: GLBP negotiation problems between routers

Have you configured glbp forwarder preempt ? Preempt need to be enabled to achieve the result.

glbp forwarder preempt

To configure a router to take over as active virtual forwarder (AVF) for a Gateway Load Balancing Protocol (GLBP) group if it has higher priority than the current AVF, use the glbp forwarder preempt command in interface configuration mode. To disable this feature, use the no form of this command.

glbp group forwarder preempt [delay minimum seconds]

no glbp group forwarder preempt [delay minimum]

Doc here: http://www.cisco.com/en/US/docs/ios/12_2t/12_2t15/feature/guide/ft_glbp.html#wp1043971

Highlighted

Re: GLBP negotiation problems between routers

Hello,

We have configured the GLBP with the command:

glbp forwarder preempt

but both routers shows only:

glbp 1 preempt

The models of routers are: 2811 y 2801.

The IOS for 2811 is: C2800NM-adventerprisek9-mz.123-14.T7

The IOS for 2801 is: c2801-adventerprisek9-mz.124-24.T3

The router 2811 has priority: 200 and the 2801 has priority: 180.

To overcome the problem so the traffic can not be routed to router 2801 (backup) we have changed the priority of the routers as follows:

The router 2811 has priority: 180 and the 2801 has priority: 200

Under this configuration the traffic is routed by default by 2811 which is what we want..

If your consider to change the IOS of the routers so they can recognize the command: glbp forwarder preempt, advise what IOS is the correct, please.

Thanking you in advance.

Roger

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards