cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
803
Views
0
Helpful
12
Replies
Highlighted
Beginner

Host MAC in vlan is flapping between switch ports

Dears,

 

I have a weird device (connected redundantly) to a stack of 2 Catalyst 9300 switches which is flooding me with below:

 

%SW_MATM_MACFLAP_NOTIF: Host 000.e107.9718 in vlan 802 is flapping between port Gi1/0/2 and port Gi2/0/2

 

Surprisingly, both ports on the connected devices have a shared MAC and IP address, and both are in forwarding state on the switch side (one port is not blocked by the spanning-tree). Both ports on switch are green and working fine and connected device (via redundant ports) is able to successfully communicate.

 

If I configure port-channel to bundle these 2 ports, then connected device stops communicating as it doesn't support LACP.

 

Any suggestions to get rid of this OR at least block the logging msg only for these particular interfaces so my buffer doesn't get filled with superfluous information. I cannot run the 'no logging on' command as it will stop all the other logging msgs.

 

Kind Regards!

12 REPLIES 12
Highlighted
Hall of Fame Expert

Hi,

One option is to replace the patch cables connecting to this device. Also, as for Portchannel, you can try and configure mode "on" if the device does not support LACP.

HTH

Highlighted

Thanks Reza, but I even tried bundling the ports with channel-group mode 'ON' 

 

The connected device is basically an IP audio interface (used for public address system) and has two I/O ports with a shared MAC address.

 

It is connected to my CAT9300 stack via dual-link connection (one for master and other for the slave unit).

 

I tried configuring port-channel with channel-group 'ON' but device stopped communicating as I wasn't able to ping it.

 

With normal configuration when both ports are configured as access ports,  switch keeps them both in forwarding state  and device has no issues in communication.

 

Is there a way I can turn off the logging only for this particular msg as other events must have to be logged.

 

 

Highlighted

Hello

Keep the two ports in a administrative access mode and append on them into a flex link, That way one port will be in a forwarding state the other will be in suspended state.

conf t

feature flexlink

int x/x

description active port

switchport backup interface x/x



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Thanks Paul, I'm going to try the flex link config.

Do let me know if I below is the configuration needed:

 

Interface range g1/0/2, g2/0/2

switchport access vlan 802

switchport mode access

no shut

!

!

int g1/0/2

description active port

switchport backup interface g2/0/2

 

 

Highlighted
VIP Expert

You can configure the port-channel as mode "ON" and make access-vlan that port-channel.

 

what server is this?

 



BB


*** Rate All Helpful Responses ***

Highlighted

The connected device is basically an IP audio interface (used for public address system) and has two I/O ports with a shared MAC address.

 

It is connected to my CAT9300 stack via dual-link connection (one for master and other for the slave unit).

 

I tried configuring port-channel with channel-group 'ON' but device stopped communicating as I wasn't able to ping it.

 

With normal configuration when both ports are configured as access ports,  switch keeps them both in forwarding state  and device has no issues in communication.

 

Is there a way I can turn off the logging only for this particular msg as other events must have to be logged.

 

 

Highlighted

As per your description - since both connected to the same switch, Do you need both the port to be enabled on the end device? 

 

 

 

 



BB


*** Rate All Helpful Responses ***

Highlighted

Yes, the requirement is to provide the redundant connectivity to the end device.

 

No idea why spanning tree isn't blocking the 2nd port and keeping only the one (port at a time) in forwarding state.

Highlighted

Design point of view you were not getting any redundant here since Switch is only 1 here.

 

since this is an Audio device, anyway call or video will break while shift over takes place from one port to another port (or you may have lag brief).

 

You can try other options suggested in the post, or if do not like to make complicated, you can achieve EEM script to enable other redundant port, when the First port goes down.

 

 



BB


*** Rate All Helpful Responses ***

Highlighted

As I mentioned earlier, there are two CAT9300 units stacked together and both are connected to the end device via 1 link.

Highlighted

Thank you for the clarification- i may have missed the switch has to stack of 2 switches.

 

As suggested you can use below reference guide:

 

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3550/software/release/12-2_25_see/configuration/guide/swflink.html



BB


*** Rate All Helpful Responses ***

Highlighted

Hello


@umer zubairi wrote:

Yes, the requirement is to provide the redundant connectivity to the end device.

No idea why spanning tree isn't blocking the 2nd port and keeping only the one (port at a time) in forwarding state.


As these are two separate switches then flexlink isn't applicable in this current topology.

Note:- If you apply flexlink in switch stack or on a single switch then STP is disabled on its ports and if then the primary port goes down in a flexlink then the specified backup will begin to forward traffic, 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Content for Community-Ad