cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1836
Views
15
Helpful
7
Replies

How can I translate inside networks to a different inside global address to the one assigned to my serial port using NAT overload?

To expand on the title. I have a router connected to an ISP router with a serial connection. I am given 1 public address of 199.199.199.1. How can I use Nat overload to translate all inside network address to that one address. My serial ports have a different IP (172.72.255.241 for my side and 172.72.255.242 for ISP side). All the guides I can find uses nat overload that translates all inside addresses to the address assigned on the serial port. How can I translate the inside networks to 199.199.199.1 instead of 172.72.255.241.

1 Accepted Solution

Accepted Solutions

ohh, yes packet tracer is a great simulator but it has software limitations, in real devices you will see all the options, well, you could try just for testing in packet tracert and if the command is available.

Imagine you have one GigaEthernet interface available:

interface g0/1
ip add 199.199.199.1 255.255.255.252  (we are going to change the subnet mask because /32 is not allowed like in loopbacks)
no keepalive     <-- to keep up up the interface 
no shutdown

Then complete the config 

ip nat inside source list PRIVATE-NET interface lg0/1 overload

Now as you are using packet tracer, on the neighbor router (simulating is the ISP) You should create a static route to know the IP 199.199.199.1

ISP-Router

ip add 199.199.199.1 255.255.255.255 172.72.255.241

In order to know the subnet through the router client. 

Not sure if the command is available in packet tracer but in order to check the functionability you could enable a debug: debup ip nat translations. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

View solution in original post

7 Replies 7

e.ciollaro
Level 4
Level 4

Hi

configure the public ip over a Loopback interf and configure:

ip nat inside source list  ... interface Loopbackxxx overload

It should work

Bye,

enrico

PS Rate if useful

Hi

I agree with e.ciollaro's comment,

Try with this config:

Interface loopback 199
ip add 199.199.199.1 255.255.255.255

interface serial X/X
ip add 172.72.255.241 255.255.255.252
ip nat outside

interface gX/X
description INTERNAL-NETWORK
ip address a.b.c.d <subnet mask>
ip nat inside

ip access-list standard PRIVATE-NET
permit ip <your internal networks to translate> example:
permit ip 10.0.0.0 0.255.255.255.255

ip nat inside source list PRIVATE-NET interface loopback 199 overload

ip route 0.0.0.0 0.0.0.0 172.72.255.242 name INTERNET

Hope it is useful.

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

It appears this is not possible using the '?' after "ip nat inside source list 1 interface" the only options are: Ethernet, FastEthernet, GigabitEthernet and Serial. There is no option for loopback

Hi

Have you already created the loopback?

Interface loopback 199
ip add 199.199.199.1 255.255.255.255

R1(config)#ip nat inside source list Private-Nets interface ?
Async Async interface
Auto-Template Auto-Template interface
BVI Bridge-Group Virtual Interface
CDMA-Ix CDMA Ix interface
CTunnel CTunnel interface
Dialer Dialer interface
Ethernet IEEE 802.3
GMPLS MPLS interface
LISP Locator/ID Separation Protocol Virtual Interface
LongReachEthernet Long-Reach Ethernet interface
Loopback Loopback interface
Lspvif LSP virtual interface
MFR Multilink Frame Relay bundle interface
Multilink Multilink-group interface
Null Null interface
Tunnel Tunnel interface
Vif PGM Multicast Host interface
Virtual-PPP Virtual PPP interface
Virtual-Template Virtual Template interface
Virtual-TokenRing Virtual TokenRing
vmi Virtual Multipoint Interface

it should allow you to include it, what router model and IOS you have?




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

I am using packet tracer with the 2901 router. This is what show up when I do the '?' command: http://imgur.com/HJXfnkW

ohh, yes packet tracer is a great simulator but it has software limitations, in real devices you will see all the options, well, you could try just for testing in packet tracert and if the command is available.

Imagine you have one GigaEthernet interface available:

interface g0/1
ip add 199.199.199.1 255.255.255.252  (we are going to change the subnet mask because /32 is not allowed like in loopbacks)
no keepalive     <-- to keep up up the interface 
no shutdown

Then complete the config 

ip nat inside source list PRIVATE-NET interface lg0/1 overload

Now as you are using packet tracer, on the neighbor router (simulating is the ISP) You should create a static route to know the IP 199.199.199.1

ISP-Router

ip add 199.199.199.1 255.255.255.255 172.72.255.241

In order to know the subnet through the router client. 

Not sure if the command is available in packet tracer but in order to check the functionability you could enable a debug: debup ip nat translations. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hi

     i configure the nat like this:

ip nat pool 111 199.199.199.1 199.199.199.1 netmask 255.255.255.0

access-list 123 permit ip 10.1.1.0 0.0.0.255 131.108.1.0 0.0.0.255

ip nat inside source list  123 pool 111 overload

it looks well ,is there some problem i mistake .

:-)

:-)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card