cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
188
Views
5
Helpful
4
Replies
Beginner

How do I configure a Nexus switch for Simple LAN connectivity

Hi everyone,

 

I have very limited networking background. I recently bought a Nexus 5596T switch for a simple LAN connectivity between my hosts computer and several servers. I realised that the Nexus is a managed switch unlike the Catalysts I am so used to Plug-and-Play. The Nexus also comes with a L3 layer license. I am unfamiliar with L3 switching/routing.

 

I have tens of hosts computers, Nexus 5596T, a Dell R740 Server running Windows Server 2016. There is no internet connectivity required, and no gateway. How do I configure the switch so that the devices can talk to each other and send files like how it would be if I plug in a Catalyst switch?

 

I have set all the ethernet ports to the same VLan 8, no shutdown. However they are still unable to detect each other.

 

I appreciate your time for answering my question. Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

Re: How do I configure a Nexus switch for Simple LAN connectivity

Hello,

 

make sure you have created the Vlan (8) as below, and that the ports are configured as in the example:

 

N5596T# configure terminal
N5596T(config)# vlan 8
N5596T(config-vlan)# name HOME
N5596T(config-vlan)# state active
N5596T(config-vlan)# no shutdown

 

N5596T# configure terminal
N5596T(config)# interface ethernet 1/10
N5596T(config-if)# switchport access vlan 8
N5596T(config-if)# spanning-tree portfast

4 REPLIES 4
VIP Mentor

Re: How do I configure a Nexus switch for Simple LAN connectivity

Hello,

 

make sure you have created the Vlan (8) as below, and that the ports are configured as in the example:

 

N5596T# configure terminal
N5596T(config)# vlan 8
N5596T(config-vlan)# name HOME
N5596T(config-vlan)# state active
N5596T(config-vlan)# no shutdown

 

N5596T# configure terminal
N5596T(config)# interface ethernet 1/10
N5596T(config-if)# switchport access vlan 8
N5596T(config-if)# spanning-tree portfast

Beginner

Re: How do I configure a Nexus switch for Simple LAN connectivity

Thank you Georg! Appreciate your help. The devices are able to see each other after configuring the spanning tree.

 

Although the NX-OS has slightly different commands. I managed to set it using the following 

 

N5596T(config-if)# spanning-tree port type edge

 

Not sure if it is the same but the "help" mentioned it is PortFast so I think ya.

Anyway it is working now. Thank you.

VIP Mentor

Re: How do I configure a Nexus switch for Simple LAN connectivity

Hello,

 

you are right, 'spanning-tree port type edge' is the NX-OS equivalent of the IOS 'spanning-tree portfast' command...

 

Glad you got it all working...

Highlighted
VIP Advisor

Re: How do I configure a Nexus switch for Simple LAN connectivity

Hello

Just like to ask :

Are your wanting to route between vlans?
Does your vlan 8 require a L3 interface?
Will you be using a Fabirc extenders between the N5K and the servers?
Will you be wanting to mange this switch remotely

 

For any l3 interface or remote mgt like telnet or ssh you need to enable the feature for it.

conf t

feature interface vlan
int vlan 8
ip address x.x.x.x y.y.y.y.y

enabling telnet-ssh vtp
feature telnet 
feature ssh
feature vtp



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad