cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

1216
Views
0
Helpful
14
Replies
Beginner

how to Attach Wifi Modem with VLANs

Greeting

I am unable to connect a Wifi Modem wiith 2960 Switch having VLAN 1,Attached is the network diagram,what configurations i have to modified it,

   (VLAN 10) 2960----------3750------------3750-----------2960 (VLAN1 )

I need to Connect A Wifi Modem on VLAN 1 ,Connectivity is working fine between VLAN 10 and VLAN 1.

What should be the next step to Connect Wifi Modem to VLAN 1 so that Users on VLAN 10 should connect to Internet..

Please reply and see the Attached Network Diagram

14 REPLIES 14
Rising star

how to Attach Wifi Modem with VLANs

HI Muhammad,

Need few informations here.

What is your 2960 switch port configuration looking like where you have connected the wifi modem?

Also what is your LAN side ip address for the wifi modem?

Regards

Najaf

Please rate when applicable or helpful !!!

Beginner

how to Attach Wifi Modem with VLANs

Dear

2960 is in default condition (All devices are in VLAN1)

int vlan 1

ip address 192.168.1.227 255.255.255.0

Workstations

Ip details are 192.168.1.X ,Subnet Mask is 255.255.255.0,Default gateway is 192.168.1.227

Local IP of Modem is 192.168.2.1 /I can changed it as VLAN 1

Rising star

how to Attach Wifi Modem with VLANs

Hi,

Do you have 2960 configured as L3?

Regards

Najaf

Please rate when applicable or helpful !!!

Beginner

how to Attach Wifi Modem with VLANs

No sir,It is Layer 2

Highlighted
Rising star

how to Attach Wifi Modem with VLANs

Hi,

If this is L2 you can not have this configured as the default gateway for the clients. You need to have some L3 device to act as the default gateway for your workstation.

Can you assign Local IP of Modem from the range 192.168.1.x and check if you are able to ping the modem ip from the workstation?

Regards

Najaf

Please rate when applicable or helpful !!!

Beginner

how to Attach Wifi Modem with VLANs

Hi

I have connected a WIFI modem (ISP Provided) and configured IP of 192.168.1.228  and make a static route to this IP

ip route 0.0.0.0 0.0.0.0 192.168.1.228

All users on VLAN 1 is connected to Internet

But Users on other VLAN10(left side of picture) is unable to connect to internet

while I redistrubte static route to EIGRP..

please Reply

Regards

M.Navaid Javaid

Rising star

how to Attach Wifi Modem with VLANs

Hi,

Good to hear that you have internet on VLAN 1. May I know where you have put this static default route which points to 192.168.1.228. Is it on switch?

I assume the reason why you dont have internet from VLAN 10 is due to fact that your modem does not know about 192.168.15.x (vlan 10) network and hence it doesn't route to this network. I would assume that there is not much configuration you can do this modem to make this work. I'm not sure which wifi router you have there but if you could make this router aware of 192.168.15.x network you should be able to get internet working on from vlan 10.

Hope this helps.

Regards

Najaf

Please rate when applicable or helpful !!!

Beginner

how to Attach Wifi Modem with VLANs

I made default Route on 3750 Switch but i have redistribute default route to EIGRP but did not get internet from VLAN 10

Rising star

how to Attach Wifi Modem with VLANs

Hi Muhammad,

Redistributing the default route to EIGRP is not going to help you here much.Default route will help you to send all the traffic to your wifi modem on 3750. But the modem should have a route back to your other network (in your case vlan 10 -

192.168.15.x) for this to work. This is the issue which you are currently facing now. As far as your wifi modem is consered it know only the directly connected network 192.168.1.x and it doesn't have any clue of about 192.168.15.x network.

Another option you could try is enable NATing on 3750 which will translate all 192.168.15.x network to 192.168.1.x. At this point i dont know what is your configuration looking like on 3750 and hence not able to suggest much from the configuration presepctive.

I hope you are able to understand what i'm trying to say here.


Hope this helps.

Regards

Najaf

Please rate when applicable or helpful !!!

Beginner

how to Attach Wifi Modem with VLANs

Dear Najaf

3750 did not have NAT feature,but I have one Routed port on eache 3750X switch and while other 12 ports are Mini GBIC support Only.what Option should You suggest me for this

Rising star

how to Attach Wifi Modem with VLANs

Hi,

Which is this 3750x? I dont see any 3750x on your diagram. I wouldn't be able suggest anything with out understanding the exsisting configurations on your devices.

Regards

Najaf

Please rate when applicable or helpful !!!

Beginner

how to Attach Wifi Modem with VLANs

Dear

In original this is 3750X but i used 3560 in Packet tracer

3750X ON LEFT

!

enable password cisco

!

!

!

ip routing

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/1

no switchport

ip address 10.0.0.2 255.0.0.0

duplex auto

speed auto

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 192.168.1.99 255.255.255.0

!

router eigrp 10

network 192.168.1.0

network 10.0.0.0

auto-summary

!

ip classless

!

!

!

ip dhcp excluded-address 192.168.10.0 192.168.10.50

!

ip dhcp pool VLAN10POOL

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

dns-server 192.168.1.100

ip routing

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

no switchport

ip address 10.0.0.1 255.0.0.0

duplex auto

speed auto

!

interface FastEthernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

ip address 192.168.10.1 255.255.255.0

!

interface Vlan20

ip address 192.168.20.1 255.255.255.0

!

router eigrp 10

network 192.168.10.0

network 10.0.0.0

network 192.168.20.0

auto-summary

!

ip classless

!

!

3750X on RIGHT

!

enable password cisco

!

!

!

ip routing

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/1

no switchport

ip address 10.0.0.2 255.0.0.0

duplex auto

speed auto

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 192.168.1.99 255.255.255.0

!

router eigrp 10

network 192.168.1.0

network 10.0.0.0

auto-summary

!

ip classless

!

!

Rising star

Re: how to Attach Wifi Modem with VLANs

Hi,

Thanks a lot for sharing confiration.

Last time you have mentioned that you have put a default route..Where is that you have put this default route?

How is your NAT and interface configuration looking like on Wifi router?

Also do you have an option of wifi router to put static route? If this is possible then you dont need any NAT.

Regards

Najaf

Please rate when applicable or helpful !!!

Beginner

how to Attach Wifi Modem with VLANs

ip route 0.0.0.0 0.0.0.0 192.168.2.1

Wrong configuration pasted ,

The modem that ISP provided me did not have any option of NAT and Static Route..

CreatePlease to create content
Content for Community-Ad