cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
6187
Views
5
Helpful
8
Replies

How to configure the Cisco Nexus 9300 two Switches in High availability Mode

Hi all,

 

Earlier we were using the Cisco 3600 Series type of fix port Switches. For providing the Switch level redundancy we connect two Switches with Stack Cable.

 

However, now in Cisco Nexus 9300 no Stack concept and need to configure the Port channel between two switches.

 

Please let us know in which document or Blog switch level redundancy is explained for Nexus 9300 fix port switches.

8 REPLIES 8
balaji.bandi
VIP Master

vPC for Nexus environment here is the quick reference guide : ( same works for any  nexus environment)

 

https://www.cisco.com/c/en/us/products/collateral/switches/nexus-5000-series-switches/configuration_guide_c07-543563.html

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Hi Balaji,

 

Thank you for your suggestion and will go through the suggested link.

 

Regards,

sumit 

Heres a working setup of my switches you could tweak easily to your own , 4 links between both nexus devices portC 1 for VPC peer link , then a heartbeat link as well over a vlan at l3 between both switches
VPC Config

vpc domain 200
role priority 200
system-priority 150
peer-keepalive destination x.x.x.x source x.x.x.x
delay restore 90

interface mgmt0
description OOB.TRUSTED.SERVER
vrf member management
ip address x.x.x.x

interface Vlan3005
description VPC Heartbeat
vrf member heartbeat
ip address 10.1.1.1/30

interface Ethernet1/44
description VPC Heartbeat
switchport access vlan 3003
logging event port link-status


interface port-channel1
description Peer_Link_To_xxxxxxxxx
switchport mode trunk
no lacp suspend-individual
switchport trunk allowed vlan 2,10-11,17-18,20,28,31,33-34,36-39,48,50,64-65,70,72,74,76,78,80,90-96,102-103,105,107,400,1226,2224
spanning-tree port type network
speed 10000
vpc peer-link


interface Ethernet1/45
description Peer_Link_1_of_4_to_xxxxxxxxxx
switchport mode trunk
switchport trunk allowed vlan 2,10-11,17-18,20,28,31,33-34,36-39,48,50,64-65,70,72,74,76,78,80,90-96,102-103,105,107,400,1226,2224
channel-group 1 mode active

interface Ethernet1/46
description Peer_Link_2_of_4_to_xxxxxxxxx
switchport mode trunk
switchport trunk allowed vlan 2,10-11,17-18,20,28,31,33-34,36-39,48,50,64-65,70,72,74,76,78,80,90-96,102-103,105,107,400,1226,2224
channel-group 1 mode active

interface Ethernet1/47
description Peer_Link_3_of_4_to_xxxxxxxxx
switchport mode trunk
switchport trunk allowed vlan 2,10-11,17-18,20,28,31,33-34,36-39,48,50,64-65,70,72,74,76,78,80,90-96,102-103,105,107,400,1226,2224
channel-group 1 mode active

interface Ethernet1/48
description Peer_Link_4_of_4_to_xxxxxxxxxxx
switchport mode trunk
switchport trunk allowed vlan 2,10-11,17-18,20,28,31,33-34,36-39,48,50,64-65,70,72,74,76,78,80,90-96,102-103,105,107,400,1226,2224
channel-group 1 mode active


##############################################################################

vpc domain 200
role priority 150
system-priority 150
peer-keepalive destination x.x.x.x source x.x.x.x
delay restore 90

interface mgmt0
description OOB.TRUSTED.SERVER
vrf member management
ip address x.x.x.x/x


interface Vlan3005
description VPC Heartbeat
vrf member heartbeat
ip address 10.1.1.2/30

interface Ethernet1/44
description VPC Heartbeat
switchport access vlan 3003
logging event port link-status

Hi Mark,

 

Thank you for sharing the details and below configuration is really helpful.

 

Regards,

Sumit

Hi Mark,

Is it necessary to configure both switches with routes and vlan of the entire network, or do I only configure the primary switch? and then this configuration is replicated to the secondary (like Stacking).
Thank you

 

I have this question too?  Any help ?

Thank you

You do not any configuration on stack member that is slave, master config is good enough to replicate.

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Hi Mark,

 

Yes if we configure the VPc the client switch or the secondary switch with less priority will get all the features from the primary switch, and please note this will be configured in SSO stateful switchover so if the primary goes down secondary will come up automatically

 

also, you will never able to login to client switch, as always primary will be active and it will forward the packets