cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1003
Views
0
Helpful
4
Replies

How to determine whether auto qos is working or not on a Catalyst 9200 switch

mat_rouch
Level 1
Level 1

I am deploying auto qos for cisco IP phones across my network.  I am having a little difficulty determining whether or not it is working properly.  On the ports with cisco phones attached I added "auto qos voip cisco phone", which generated the required config:

 

---------------------------------------

interface GigabitEthernet1/0/37
switchport access vlan 210
switchport mode access
switchport voice vlan 300
trust device cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AutoQos-4.0-CiscoPhone-Input-Policy
service-policy output AutoQos-4.0-Output-Policy

---------------------------------------

 

When I do "show policy-map int gi1/0/37" I see hits on the VoIP signaling class, so it appears to be working:

 

---------------------------------------

Class-map: AutoQos-4.0-Voip-Signal-CiscoPhone-Class (match-any)
   41487 packets
   Match: cos 3
   QoS Set
   dscp cs3

---------------------------------------

 

On the 9200s uplink port I added "auto qos voip trust", which generated the following output:

 

---------------------------------------

interface TenGigabitEthernet1/1/1
description Distribution Switch Uplink
switchport trunk native vlan 804
switchport trunk allowed vlan 10,28,210,300,404,455,471,480,804,807,902
switchport mode trunk
auto qos trust
service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
service-policy output AutoQos-4.0-Output-Policy

---------------------------------------

 

However, when I do "show policy map int te1/1/1" the only class-map that shows any matching packets at all is the inbound "class-default".  All others are zero.  Shouldn't the outbound class map show some hits for the frames coming from the phones connected to this switch?  The uplink te1/1/1 is the only egress from this switch, so voice frames must traverse it to get anywhere at all.

 

---------------------------------------

ERH-1D1-1st-ACCS-9200-2809#sh policy-map int te1/1/1
TenGigabitEthernet1/1/1

Service-policy input: AutoQos-4.0-Trust-Cos-Input-Policy

Class-map: class-default (match-any)
20341131 packets
Match: any
QoS Set
cos cos table AutoQos-4.0-Trust-Cos-Table

Service-policy output: AutoQos-4.0-Output-Policy

queue stats for all priority classes:
Queueing
priority level 1

(total drops) 0
(bytes output) 6708548

Class-map: AutoQos-4.0-Output-Priority-Queue (match-any)
0 packets
Match: dscp cs4 (32) cs5 (40) ef (46)
Match: cos 5
Priority: 30% (3000000 kbps), burst bytes 75000000,

Priority Level: 1

Class-map: AutoQos-4.0-Output-Control-Mgmt-Queue (match-any)
0 packets
Match: dscp cs2 (16) cs3 (24) cs6 (48) cs7 (56)
Match: cos 3
Queueing

queue-limit dscp 16 percent 80
queue-limit dscp 24 percent 90
queue-limit dscp 48 percent 100
queue-limit dscp 56 percent 100
(total drops) 0
(bytes output) 133361
bandwidth remaining 10%

queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Multimedia-Conf-Queue (match-any)
0 packets
Match: dscp af41 (34) af42 (36) af43 (38)
Match: cos 4
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 10%
queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Trans-Data-Queue (match-any)
0 packets
Match: dscp af21 (18) af22 (20) af23 (22)
Match: cos 2
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 10%
queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Bulk-Data-Queue (match-any)
0 packets
Match: dscp af11 (10) af12 (12) af13 (14)
Match: cos 1
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 4%
queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Scavenger-Queue (match-any)
0 packets
Match: dscp cs1 (8)
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 1%
queue-buffers ratio 10

Class-map: AutoQos-4.0-Output-Multimedia-Strm-Queue (match-any)
0 packets
Match: dscp af31 (26) af32 (28) af33 (30)
Queueing

(total drops) 0
(bytes output) 0
bandwidth remaining 10%
queue-buffers ratio 10

Class-map: class-default (match-any)
0 packets
Match: any
Queueing

(total drops) 0
(bytes output) 14986668893
bandwidth remaining 25%
queue-buffers ratio 25

---------------------------------------

 

Am I missing something?  According to the cisco doc "auto qos voip trust" is the command to put on uplinks to other trusted network devices and "auto qos voip cisco-phone" is the command to put on access ports connected to phones.  Is there some other piece of config I need, or is it working properly and there's just some other troubleshooting command I need to use in order to see it?  using "show policy-map" it looks like the QoS settings for frames are not even being preserved from the access port to the uplink on the same switch.

 

 

Thanks,

-Mat Rouch

 

4 Replies 4

mat_rouch
Level 1
Level 1

One thing I do notice: on class map "AutoQos-4.0-Output-Control-Mgmt-Queue" bound to the uplink port the "bytes output" is nonzero (133361) but the number of packets for that class map is 0.  What does that mean?  It looks like it is seeing something, but I cannot interpret it in a consistent way.

 

-Mat

It should show the number of packets as well. Something like this:

Class-map: AutoQos-ppm-Control-Mgmt-Queue (match-any)
1649498873 packets
Match: cos 3
413843931 packets
Match: dscp cs7 (56)
97794 packets
Match: dscp cs6 (48)
1208606581 packets
Match: dscp cs3 (24)
6822 packets
Match: dscp cs2 (16)
26752370 packets
Match: access-group name AutoQos-4.0-ACL-Signaling
191375 packets
Queueing
queue limit 264 packets
(queue depth/total drops) 0/0
(bytes output) 210067773
bandwidth remaining 10%

 

I am wondering if this a bug in the IOS or egress queues are not supported. Can't find any info regarding the 9200 series.

Does "show auto qos" show the ports that have qos enabled?

 

HTH

 

Yes, "show auto qos" does show it as applied on the uplink and on the access ports:

--------------------------------------------------

ERH-1D1-1st-ACCS-9200-2809#sh auto qos int te1/1/1
TenGigabitEthernet1/1/1
auto qos trust

ERH-1D1-1st-ACCS-9200-2809#sh auto qos int gi1/0/37
GigabitEthernet1/0/37
auto qos voip cisco-phone

--------------------------------------------------

 

and when I enabled auto qos on the corresponding port of the switch at the other end of the uplink, I get exactly the same results:  I see bytes output but no packets.  I call this interesting because that switch is a 9500, not a 9200.  Here's some sample output from the 9500:

 

------------------------------------------

ERH-1D1-DIST-9500XE-2787#sh policy-map int te1/0/15
TenGigabitEthernet1/0/15

Service-policy input: AutoQos-4.0-Trust-Cos-Input-Policy

Class-map: class-default (match-any)
66285678 packets
Match: any
QoS Set
cos cos table AutoQos-4.0-Trust-Cos-Table

Service-policy output: AutoQos-4.0-Output-Policy

queue stats for all priority classes:
Queueing
priority level 1

(total drops) 0
(bytes output) 17944

Class-map: AutoQos-4.0-Output-Priority-Queue (match-any)
0 packets
Match: dscp cs4 (32) cs5 (40) ef (46)
Match: cos 5
Priority: 30% (3000000 kbps), burst bytes 75000000,

Priority Level: 1

Class-map: AutoQos-4.0-Output-Control-Mgmt-Queue (match-any)
0 packets
Match: dscp cs2 (16) cs3 (24) cs6 (48) cs7 (56)
Match: cos 3
Queueing

queue-limit dscp 16 percent 80
queue-limit dscp 24 percent 90
queue-limit dscp 48 percent 100
queue-limit dscp 56 percent 100
(total drops) 0
(bytes output) 161723
bandwidth remaining 10%

queue-buffers ratio 10

------------------------------------------

 

Any ideas? 

 

 

Thanks,

-Mat

mat_rouch
Level 1
Level 1

Maybe the "0 packets" and "bytes output (133361)" means that packets are matching the class-map but there are zero packets *queued* because there is not currently any congestion on the network and things are just being forwarded (?)  Can anyone confirm?

 

Thanks,

-Mat

Review Cisco Networking products for a $25 gift card