cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
208
Views
0
Helpful
8
Replies
Beginner

How to extend the L2 Vlan

Hi All,

 

We need to create L2 Vlan, that needs to extend the Vlan from Source to destination. Please let me know how to do.

 

Here scenario was Server 1 wants to communicate with Server2. No L3 interface. Server team will assign one IP to specific ip to one Vlan, that Vlan we need to extend from SW1 to SW3. Please guide me how to do? Also please share troubleshooting command as well.

 

    SW1----------SW2---------------SW3

     |                                                             |

     |                                                             |

     |                                                             |

Server1                                                  Server2

8 REPLIES 8
VIP Mentor

Re: How to extend the L2 Vlan

Hi
if its just layer 2 each interface in path needs to have the layer 2 vlan added to each interface as an access port

If its more than 1 vlan it must be a trunk port to allow all vlans

Example
interface GigabitEthernet1/2/32
description xxxxxxxxxxxxxxxxxxxxxx
switchport trunk allowed vlan 1,35,1222,2225
switchport mode trunk



to check the trunk each side use show interface trunk , and make sure the port each end is in FWD state like below output

sh int trunk

Port Mode Encapsulation Status Native vlan
Gi1/2/32 on 802.1q trunking 1
Gi2/1/11 auto 802.1q trunking 1
Po100 on 802.1q trunking 1
Po101 on 802.1q trunking 1
Po107 on 802.1q trunking 1

Port Vlans allowed on trunk
Gi1/2/32 1,35,1222,2225
Gi2/1/11 1,35,151,1222,2225
Po100 1-4094
Po101 1-4094
Po107 1-1005,1222,2225,2239

Port Vlans allowed and active in management domain
Gi1/2/32 1,35,1222,2225
Gi2/1/11 1,35,151,1222,2225
Po100 1,32-36,38,51,54,59-60,110,126,151,154-160,164-166,169,196,200-202,324,1222,2225,2239,2991-2994
Po101 1,32-36,38,51,54,59-60,110,126,151,154-160,164-166,169,196,200-202,324,1222,2225,2239,2991-2994
Po107 1,32-36,38,51,54,59-60,110,126,151,154-160,164-166,169,196,200-202,324,1222,2225,2239

Port Vlans in spanning tree forwarding state and not pruned
Gi1/2/32 1,35,1222,2225
Gi2/1/11 1,35,151,1222,2225
Po100 none
Po101 none
Po107 1,32-36,38,51,54,59-60,110,126,151,154-160,164-166,169,196,200-202,324,1222,2225,2239

 

The vlan also needs to be set at layer 2 DB on each switch too between the servers as well as the interfaces

 

(conf t)vlan 10

          name example

 

Beginner

Re: How to extend the L2 Vlan

Hi Mark,

 

Thanks for your reply.

 

Server connected interface is trunk port, hence we extended Vlan from Source Server to Destination Server, include all switch trunk port. But SW1 we are seeing that Source server Mac, same mac it's not reflecting SW2. Why MAC not advertising to other SW2. Any reason.

 

VIP Mentor

Re: How to extend the L2 Vlan

Hi
ok so configuration part is complete vlan is on every trunk interface between source and destination thats good

Does both SW1 and SW3 see the mac addresses for the local server connected yes ? Just checking as that will confirm the NICs on server are broadcasting MAC to the switch correctly

If both those switches see the MAC address for their own server then the problem is between switches sharing the server MACs

is the vlan in FWD state in the trunk that these MACs belong too ? you can check with show int trunk.

Does the vlan even show up in the show mac address-table , when you check it on SW2, is it showing incomplete on either SW1 or SW3 , it should show static or dynamic

show mac address-table address 0180.c200.0005
Mac Address Table
-------------------------------------------

Vlan Mac Address Type Ports
---- ----------- -------- -----
All 0180.c200.0005 STATIC CPU

Beginner

Re: How to extend the L2 Vlan

Hi Mike,

 

Please find the output,

 


SW1
---

#sh mac add dyn
* 914 02a0.985e.d427 dynamic 30 F F Po2103


# sh spanning-tree vlan 914

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- -------
Po90 Desg FWD 200 128.4185 (vPC) P2p---------------------------------->sw2
Po2103 Desg FWD 200 128.6198 (vPC) Edge P2p-----------------------------> server

 


interface port-channel90
switchport mode trunk
switchport trunk allowed vlan 913-914
spanning-tree guard root
speed 1000
service-policy type qos input QOS-POLICY
vpc 90

 

SW2
---

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- ------
Po10 Desg FWD 10000 128.1674 P2p---------------------------------->SW3
Po90 Root FWD 5000 128.1686 P2p---------------------------------->SW1

 

#sh mac-address-table address 02a0.985e.d427
vlan mac address type learn age ports
------+----------------+--------+-----+----------+--------------------------
No entries present.

 

 

interface Port-channel90
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan add 913,914
switchport mode trunk
switchport nonegotiate
mtu 9216
no ip address
end

 

Beginner

Re: How to extend the L2 Vlan

Hi Mike / Friends,

 

It's urgent, anyone gives your suggestion. 

 

Note:

SW1 -- Nexus 5K

Sw2 --6506

VIP Mentor

Re: How to extend the L2 Vlan

Hi

So if you put another device like laptop as a test on either sw1 or sw3 is the same thing happening ? is the MAC being lost before it gets to the SW2

Has this worked before or its a new setup ?

 

if its a single link instead of VPC does it work ?

Have  your tried bounce the link ?

 

 

If its urgent and causing delays production issues  you should TAC it for support

Highlighted
Beginner

Re: How to extend the L2 Vlan

Hi Mark,

 

No,  its new, VPC up and running. We are not bounced. Ok sure will check. Thanks for your guidance.

VIP Mentor

Re: How to extend the L2 Vlan

Hi
Just thinking you have 2 nexus here in a full vpc domain setup is that correct if vpc is running ?

If so is that particular vpc showing correctly in show vpc brief ...

If this is not dual nexus and standalone then theres no requirement for vpc

The original topology just looks like few standard switches connected together by trunk ,please clarify as the issue could be in the design
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards