cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

278
Views
0
Helpful
6
Replies
Highlighted
Beginner

How to get more than one dhcp lease on VLAN1 with 887VA

Hi. I'm new to Cisco hardware though I have some experience in networking. I'm having trouble in configuring a small network where the afore mentioned router acts also as a switch.

In practice I need that all 4 fast ethernet ports are used by vlan1 and seen as one single LAN.

Right now I can connect a device (PC) to a single port and it works, but any other device attached doesn't receive any answer at all from the DHCP server. I can plug ONE pc at a time in EACH of the four plugs and it works. But when I plug two or more devices, only one gets configured by the DHCP server.

Thank you for any help.

Everyone's tags (2)
6 REPLIES 6
VIP Mentor

Re: How to get more than one dhcp lease on VLAN1 with 887VA

Hello, 

 

make the changes marked in bold to your configuration:

 

Current configuration : 2163 bytes
!
! No configuration change since last restart
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone Rome 1 0
clock summer-time Rome recurring last Sun Mar 2:00 last Sun Oct 3:00
network-clock-participate wic 0
!
!
!
!
!
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool dpool1
network 192.168.1.0 255.255.255.0
domain-name aYodia.local
dns-server 192.168.1.1 193.70.152.25 193.70.192.25
default-router 192.168.1.1
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
voice-card 0
!
license udi pid C887VA-V-K9 sn FCZ174690H8
!
controller VDSL 0
!
interface Ethernet0
no ip address
shutdown
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
no isdn termination multidrop
!
interface BRI1
no ip address
shutdown
!
interface BRI2
no ip address
shutdown
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5snap
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
ppp chap hostname benvenuto
ppp chap password 0 ospite
ppp pap sent-username benvenuto password 0 ospite
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
control-plane
!
voice-port 1
!
voice-port 2
!
voice-port 3
!
voice-port 4
!
voice-port 5
!
voice-port 6
!
mgcp profile default
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input all
!
ntp server it.pool.ntp.org prefer
!
end

Router#

Beginner

Re: How to get more than one dhcp lease on VLAN1 with 887VA

Hi Georg.

Thanks for the blazing quick replay! I checked your solution. I've added the line 

ip dhcp excluded-address 192.168.1.1 192.168.1.2 (I've a device on static address 192.168.1.2)

and changed

ip address pool dpool1

into

ip address 192.168.1.1 255.255.255.0

but to no avail.

Still any other device attached to the other ports, those not used by my statically bound device (the one with IP 192.168.1.2) aren't connecting.

That's strange because I've used a packet sniffer and I can see that 192.168.1.1 is offering a new IP but somehow the handshake isn't completing.

Maybe it's worth mentioning that the static IP is an OSX machine, while the other devices are Windows OS.

(In the attachment the packet capture with the only relevant packets)

VIP Mentor

Re: How to get more than one dhcp lease on VLAN1 with 887VA

Hello,

 

manually clear the DHCP bindings (clear ip dhcp binding) and/or reload the router.

 

How are your clients connected to the 887 ? Is there a switch in between ?

VIP Mentor

Re: How to get more than one dhcp lease on VLAN1 with 887VA

Also, to make sure the the DHCP service is active, type:

 

887#conf t

887(config)#service dhcp

Beginner

Re: How to get more than one dhcp lease on VLAN1 with 887VA

Hi, Georg,

sorry for the late reply but I had a problem with my PC. A power supply spike has corrupted the file system of my PC, making it unbootable. I had to reformat and restore everything from scratch.

Thank you for your suggestions, but they don't seem to be effective.

Actually I've discovered that DHCP is almost entirely not working, even with the OS X machine. I was induced in thinking it is working because of the manually configured IP address. But if I change to dynamically assigned IP address, even my mac client doesn't get configured.

I'm attaching two packet captures, one with a (working) DLink router, the other with the Cisco.

As you can see, apparently the Cisco router is not completing the DHCP handshake by not sending the final DHCP ACK packet.

The client keeps sending "Request" packets, awaiting forever an ACK from the router.

And it makes no difference wether I use 

  ip address pool dpool1

or

  ip address 192.168.1.1 255.255.255.0

in the Vlan1 configuration.

So apparently the DHCP server is up and running (it is offering a lease) but it doesn't complete the handshake.

Thank you again

Beginner

Re: How to get more than one dhcp lease on VLAN1 with 887VA


@Georg Pauwen wrote:

Hello,

 

manually clear the DHCP bindings (clear ip dhcp binding) and/or reload the router.

 

How are your clients connected to the 887 ? Is there a switch in between ?


No, no switch in between. Everything is attached directly to the router.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards