cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
324
Views
5
Helpful
6
Replies
kapydan88
Participant

how to move intelvlan routing from router-on-a-stick to l3 switch

Hello for everybody.

 

What is the best way to move intelvlan routing from router-on-a-stick to l3 switch without downtime?

For example, there is one site with intervlan routing on the ISR 4331. Also on this site there is a L3 switch catalyst 9300L, which implements l2 functionality.

 

R-01#sh ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0/0 1.1.1.1 YES NVRAM up up
GigabitEthernet0/0/1 unassigned YES NVRAM up up
GigabitEthernet0/0/1.2 10.17.2.1 YES NVRAM up up
Gi0/0/1.6 10.17.6.1 YES NVRAM up up
Gi0/0/1.10 10.17.10.1 YES NVRAM up up
Gi0/0/1.12 10.17.12.1 YES NVRAM up up
Gi0/0/1.13 10.17.13.1 YES NVRAM up up
Gi0/0/1.16 10.17.16.1 YES NVRAM up up
GigabitEthernet0/0/2 unassigned YES NVRAM down down
GigabitEthernet0 unassigned YES NVRAM administratively down down
R-01#

 

SW-01#sh ip in br
Interface IP-Address OK? Method Status Protocol
Vlan1 unassigned YES NVRAM up up
Vlan2 10.17.2.2 YES NVRAM up up
GigabitEthernet0/0 unassigned YES NVRAM administratively down down
GigabitEthernet1/0/1 unassigned YES unset up up
GigabitEthernet1/0/2 unassigned YES unset up up
GigabitEthernet1/0/3 unassigned YES unset up up
GigabitEthernet1/0/4 unassigned YES unset up up
GigabitEthernet1/0/5 unassigned YES unset up up
GigabitEthernet1/0/6 unassigned YES unset up up
GigabitEthernet1/0/7 unassigned YES unset up up
GigabitEthernet1/0/8 unassigned YES unset up up
GigabitEthernet1/0/9 unassigned YES unset up up
GigabitEthernet1/0/10 unassigned YES unset down down

 

interface Vlan2
description mgmt
ip address 10.17.2.2 255.255.255.0
end

6 REPLIES 6
balaji.bandi
VIP Expert

You need to create the same VLAN and SVI Interface on Switch and shutdown mode. When you have short downtime, like up to 60 seconds.

 

Shutdown Interface on Router side and no shut on switch side and test.

 

To get familiar you can have test VLAN to test, how the process works, so you learn lessons if anything goes wrong, the same will be applied on live VLAN 

 

Hope you have other arrangement of routing in place.

is that make sense?



BB


*** Rate All Helpful Responses ***

But if we need to add ospf to this site and tunnel to reserve data-center.

 

R-01#sh run | s ospf
router ospf 1
redistribute connected subnets
network 192.168.17.0 0.0.0.3 area 192.168.17.0
R-01#

 

R-01#sh ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0/0 1.1.1.1 YES NVRAM up up
GigabitEthernet0/0/1 unassigned YES NVRAM up up
GigabitEthernet0/0/1.2 10.17.2.1 YES NVRAM up up
Gi0/0/1.6 10.17.6.1 YES NVRAM up up
Gi0/0/1.10 10.17.10.1 YES NVRAM up up
Gi0/0/1.12 10.17.12.1 YES NVRAM up up
Gi0/0/1.13 10.17.13.1 YES NVRAM up up
Gi0/0/1.16 10.17.16.1 YES NVRAM up up
GigabitEthernet0/0/2 unassigned YES NVRAM down down
GigabitEthernet0 unassigned YES NVRAM administratively down down
Tunnel9 192.168.17.2 YES NVRAM up up tunnel to reserve dc
R-01#

R-01#sh run | s ospf
router ospf 1
redistribute connected subnets
network 192.168.17.0 0.0.0.3 area 192.168.17.0
R-01#

 

In this particular case i need to create ospf process in the l3 switch, like 

 

router ospf 1
redistribute connected subnets

and create SVI, smth like 

int vlan 10

ip add 10.17.10.1 255.255.255.0

int vlan12

ip add 10.17.12.1 255.255.255.0

...

 

and shutdown and delete same subinterface on the router?

 

So, this type of migration needs to be done in a maintenance window as almost always, (depending on how much planning you do)  you will have some downtime. This is particularly important If you want to use the current IP segments and assign the same IPs you have on the sub-interface to SVIs on the switch as you can't have duplicate IPs.  If you only have a couple of devices and it is a small network, there is no need for OSPF, you can simply use static routes. 

 

HTH 

Hello.

 

No, its only one of the sites in big network.

 

This is particularly important If you want to use the current IP segments and assign the same IPs you have on the sub-interface to SVIs on the switch as you can't have duplicate IPs. - yes, thats correct. We need to create SVI with same ip addresses on the core l3 switch.

The original formulation of the question was fairly straightforward: there is a site doing inter vlan routing using a 4331 doing router on a stick with a 9300 switch. The switch is configured with vlans and trunks the vlans to the 4331, where routing takes place. The objective is to transition to an environment where the 9300 does the intervlan routing. I believe that this is possible. 

 

The question does not tell us what will be the role of the 4331 when this transition takes place. Will the 4331 still be in the network to route to things that are not locally connected? Or will the routing to remote destinations be done on the 9300?

 

I would suggest these steps to make the transition:

1) this assumes that the 9300 has a management vlan interface that has IP connectivity to the 4331. If this is not the case then setting it up is the first step in the transition.

2) enable IP routing on the 9300.

3) configure a static default route on the 9300 with the 4331 as the next hop using the IP that had been specified in the default-gateway command.

4) for each of the vlans on the 9300 do these steps

** configure the vlan interface.

** on the vlan interface configure an IP address that is in the subnet but that is different from the IP used by the 4331.

** configure other appropriate interface parameters to match what might have been configured on the 4331.

5) as the vlan interfaces are configured the 9300 will be capable of routing between those vlans (in addition to the routing performed by the 4331).

6) when all the vlan interfaces are configured and operational you can begin to transition away from the 4331 for inter vlan routing.

7) on each vlan interface on the 9300 configure a secondary IP address that uses the IP address configured in that subnet on the 4331. (it will result in 2 devices claiming to have the same IP address, but I do not believe it would be a problem - and it will not last long)

when the secondary address has been configured on the 9300 then remove the IP address from the subinterface on the 4331. This will result in all of the inter vlan routing for that subnet being done on the 9300. And anything trying to access the IP that had been on the 4331 will find it on the 9300 secondary address.

9) in each vlan interface on the 9300 remove the IP address configured in step 4. This will result in the "secondary" address becoming the primary address (indeed the only IP address) for the interface.

10) after these steps it probably makes sense to remove the subinterfaces configured on the 4331 since they no longer serve any purpose.

 

I believe that these steps should successfully transition from the inter vlan routing on 4331 to 9300 with no (or at least minimal) interruption. It does not address the question of what to do about the static default route sending traffic to the 4331. Resolving the question of what ongoing role the 4331 will play may also help answer the additional aspect that emerged which was OSPF on the 4331. It seems to me that in step 4 part of the other interface parameters might include setting up OSPF and running it on each vlan interface.

HTH

Rick

Hello.

 

Thank you for detaliled answer.

 

The question does not tell us what will be the role of the 4331 when this transition takes place. Will the 4331 still be in the network to route to things that are not locally connected? Or will the routing to remote destinations be done on the 9300? - before purchasing l3 9300l switch, this router performed intervlan routing (router-on-a-stick) for this site and gre tunnel to reserve data center. Now it is planned to move intervlan routing to the l3 switch, and leave only the tunnel to reserve data center on the router.