cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

13773
Views
0
Helpful
7
Replies
Beginner

HP NIC Teaming with Cisco switch

Hi all,

currently we have a HP DL360 with 2* NC373i nic on the server and it is connected to the cisco 3750switch

on the server we have SLB setup and with auto loadbalaning (assuming it will use TCP to load balance)

on the switch have 1 portchannel setup with channel-group 1 mode active setup on the port.

we have seen, 2gb TX, RX showing on the HP software however

when we do a TX a large file toward one server (1ip, mac) the speed will stay at 1gb tx

when tx 2file to 2 server we will get 2gb tx speed.

however RX is always stay at 1gb no mater if i copy from single source or multi source. (cisco switch have setup load balanceing from source MAC)

i have question that if anyone have successfuly config

1. HP and cisco switch with a point to point file copy and achieve 2GB TX and RX speed? ( so we can save and not buying 10GB card/switch)

2. how to achieve a 2gb RX speed on this setup?

i have tried this doc, no luck with 802.3ad as the HP software will only reconize the RX port is 1gb only.

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a008089a821.shtml

thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Collaborator

Re: HP NIC Teaming with Cisco switch

I have this setup with the following command and selections.

On the Cisco switch...

interface Port-channel55
description HPServer EtherChannel
switchport
switchport access vlan 3
switchport mode access
spanning-tree portfast

interface GigabitEthernet5/10
description HPServer EtherChannel
switchport access vlan 3
switchport mode access
channel-group 55 mode active
spanning-tree portfast
!
interface GigabitEthernet5/11
description HPServer EtherChannel
switchport access vlan 3
switchport mode access
channel-group 55 mode active
spanning-tree portfast

On the server.....

Team Type Selection:
802.3ad Dynamic with Fault Tolerance

Transmit Load Balancing Method:
Destination IP Address


Go into the Infomation tab and verify
under the "Role" columb that both
NICs show Tx/Rx

Mike

7 REPLIES 7
Collaborator

Re: HP NIC Teaming with Cisco switch

I have this setup with the following command and selections.

On the Cisco switch...

interface Port-channel55
description HPServer EtherChannel
switchport
switchport access vlan 3
switchport mode access
spanning-tree portfast

interface GigabitEthernet5/10
description HPServer EtherChannel
switchport access vlan 3
switchport mode access
channel-group 55 mode active
spanning-tree portfast
!
interface GigabitEthernet5/11
description HPServer EtherChannel
switchport access vlan 3
switchport mode access
channel-group 55 mode active
spanning-tree portfast

On the server.....

Team Type Selection:
802.3ad Dynamic with Fault Tolerance

Transmit Load Balancing Method:
Destination IP Address


Go into the Infomation tab and verify
under the "Role" columb that both
NICs show Tx/Rx

Mike

Beginner

Re: HP NIC Teaming with Cisco switch

thanks heaps mike,

i'll give it a try soon.

also just want to know if you have achived 2gb speed TX and RX between 2 servers? ( a true 2gb nic output on copying to one destination, rather than load balancing 1gb to 1 server and 1gb to the 2nd server)

thanks

Jon

Collaborator

Re: HP NIC Teaming with Cisco switch

I did not personally test it but was told it did. if you look at yours under the infromation tab you will probally see one NIC is Tx/Rx and one link is Tx only, this is why you are seeing the Rx only doing 1Gb

Mike

Beginner

Re: HP NIC Teaming with Cisco switch

hi mike

thanks for the update, i managed to get it working with one server towards multi-dest RX/TX achieved 2gb speed.

i think with lacp, one to one copy will be limited to 1gb speed. (unless anyone know how???? would love to have my backup server copying at 2gb speed)

the only thing i think i did do before is shutdown both nic and and no sh again. also i have applied portfast on port-channel.

cheers

jon

Highlighted
Beginner

HP NIC Teaming with Cisco switch

Hey Mike -

Thanks for your corect answer above... almost 3 years ago but still helpful!  I used to force the Cisco switch to mode "on" (EtherChannel only) and then set the server side to "switch-assisted load balancing" by "destination MAC address" but that didn't seem to work with the 373i adapter (it's an HP ProLiant DL380 G5).

Here, I am using the exact settings as you stated, plus all other checkboxes are set to the defaults.  Yet, while network connectivity for the server is fine the NIC utility tells of a "Failed (LACP)" second team member.  It's very puzzling to me as I cannot find anything wrong... seen this before?

Thanks,

Matthias

Advisor

Re: HP NIC Teaming with Cisco switch

  Without seeing the switch  etherchannel config it is hard to say .  In a working   1 gig etherchannel ,any one single conversation will only transfer at 1 gig  as the given ip conversation will go down a single port in the port channel due the channel hashing algorithm . This is normal .

Beginner

Re: HP NIC Teaming with Cisco switch

Below is the config and some show commands.  Note how the second switch interface is up but line protocol down (monitoring):

>>>>>>>>>> relevant config details Cisco 3560G version  15.0(2)SE >>>>>>>>>>

!

interface Port-channel5

description CASSINI (LAN TEAM 1+2)

switchport access vlan 101

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/19

description CASSINI (LAN 1)

switchport access vlan 101

switchport mode access

spanning-tree portfast

channel-group 5 mode active

!

interface GigabitEthernet0/20

description CASSINI (LAN 2)

switchport access vlan 101

switchport mode access

spanning-tree portfast

channel-group 5 mode active

!

>>>>>>>>>> show etherchannel 5 detail >>>>>>>>>>

!

Group state = L2

Ports: 2   Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol:   LACP

Minimum Links: 0

                Ports in the group:

                -------------------

Port: Gi0/19

------------

Port state    = Up Mstr Assoc In-Bndl

Channel group = 5           Mode = Active          Gcchange = -

Port-channel  = Po5         GC   =   -             Pseudo port-channel = Po5

Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.

        A - Device is in active mode.        P - Device is in passive mode.

Local information:

                            LACP port     Admin     Oper    Port        Port

Port      Flags   State     Priority      Key       Key     Number      State

Gi0/19    SA      bndl      32768         0x5       0x5     0x114       0x3D

Partner's information:

                  LACP port                        Admin  Oper   Port    Port

Port      Flags   Priority  Dev ID          Age    key    Key    Number  State

Gi0/19    SA      0         0023.7db5.1718   2s    0x0    0x300  0x100   0x3D

Age of the port in the current state: 0d:00h:43m:59s

Port: Gi0/20

------------

Port state    = Down Not-in-Bndl

Channel group = 5           Mode = Active          Gcchange = -

Port-channel  = null        GC   =   -             Pseudo port-channel = Po5

Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.

        A - Device is in active mode.        P - Device is in passive mode.

Local information:

                            LACP port     Admin     Oper    Port        Port

Port      Flags   State     Priority      Key       Key     Number      State

Gi0/20    SA      down      32768         0x5       0x0     0x115       0x45

Age of the port in the current state: 0d:21h:02m:11s

                Port-channels in the group:

                ---------------------------

Port-channel: Po5    (Primary Aggregator)

------------

Age of the Port-channel   = 0d:21h:02m:11s

Logical slot/port   = 2/5          Number of ports = 1

HotStandBy port = null

Port state          = Port-channel Ag-Inuse

Protocol            =   LACP

Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits

------+------+------+------------------+-----------

  0     00     Gi0/19   Active             0

Time since last port bundled:    0d:00h:43m:59s    Gi0/19

Time since last port Un-bundled: 0d:00h:44m:14s    Gi0/19

!

>>>>>>>>>> show interface Port-Channel 5 >>>>>>>>>>

!

Port-channel5 is up, line protocol is up (connected)

  Hardware is EtherChannel, address is 0024.c4c1.ea93 (bia 0024.c4c1.ea93)

  Description: CASSINI (LAN TEAM 1+2)

  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link type is auto, media type is unknown

  input flow-control is off, output flow-control is unsupported

  Members in this channel: Gi0/19

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:01, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 57000 bits/sec, 13 packets/sec

  5 minute output rate 516000 bits/sec, 59 packets/sec

     4419609 packets input, 1640918832 bytes, 0 no buffer

     Received 20574 broadcasts (18849 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 18849 multicast, 0 pause input

     0 input packets with dribble condition detected

     9881826 packets output, 12568928384 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

!

>>>>>>>>>> show interface GigabitEthernet0/19 >>>>>>>>>>

!

GigabitEthernet0/19 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 0024.c4c1.ea93 (bia 0024.c4c1.ea93)

  Description: CASSINI (LAN 1)

  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:23, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 69000 bits/sec, 16 packets/sec

  5 minute output rate 534000 bits/sec, 62 packets/sec

     4430108 packets input, 1643006942 bytes, 0 no buffer

     Received 27552 broadcasts (25468 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 25468 multicast, 0 pause input

     0 input packets with dribble condition detected

     10036411 packets output, 12593153545 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

!

>>>>>>>>>> show interface GigabitEthernet0/20 >>>>>>>>>>

!

GigabitEthernet0/20 is up, line protocol is down (monitoring)

  Hardware is Gigabit Ethernet, address is 0024.c4c1.ea94 (bia 0024.c4c1.ea94)

  Description: CASSINI (LAN 2)

  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:47:43, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 1565000 bits/sec, 736 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     76035912 packets output, 19136874989 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

##### end #####

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards