cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
852
Views
0
Helpful
4
Replies
Highlighted
Beginner

HSRP certain groups staying active on both sides?

So i have to 4900's running..cat4500e-IPBASE-M), Version 12.2(46)S

i've set up HSRP and it's running fine for some groups.. but other wont init properly for other grps...

There are over 20 groups that need to be functioning, most have come up fine but the final few wont sync..

For some of the other groups that i need functionallity, i've removed the standy feature on both sides, and just had one SVI and was able to ping across,

so i know there is connectivity between them...

its a live enviroment so i can only do a limited amount of debugging....

is there a limitation to the number of groups i can active on a single switch ??

any help would be great...

cheers

DR

CGSC-EXT-SW01a#sh standby brief

Vl225       225  200 P Active  local           unknown         172.30.225.1
Vl226       226  200 P Active  local           172.30.226.3    172.30.226.1
Vl227       227  200 P Active  local           unknown         172.30.227.1
Vl230       230  200 P Active  local           172.30.230.3    172.30.230.1
Vl231       231  200 P Active  local           172.30.231.3    172.30.231.1
Vl232       232  200 P Active  local           172.30.232.3    172.30.232.1
Vl250       250  200 P Active  local           172.30.250.3    172.30.250.1
Vl251       251  200 P Active  local           unknown         172.30.251.1
Vl252       252  200 P Active  local           unknown         172.30.251.33
Vl561       165  200 P Active  local           172.30.244.3    172.30.244.1

A-side grp 227

interface Vlan227
description TCE vlan227
ip address 172.30.227.2 255.255.255.0
ip helper-address 172.30.245.15
no ip redirects
standby version 2
standby 227 ip 172.30.227.1
standby 227 priority 200
standby 227 preempt delay reload 180
standby 227 name TCE

Vlan227 - Group 227 (version 2)
  State is Active
    2 state changes, last state change 4d21h
  Virtual IP address is 172.30.227.1
  Active virtual MAC address is 0000.0c9f.f0e3
    Local virtual MAC address is 0000.0c9f.f0e3 (v2 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.832 secs
  Preemption enabled, delay reload 180 secs
  Active router is local
  Standby router is unknown
  Priority 200 (configured 200)
  Group name is "TCE" (cfgd)

b-side grp 227

interface Vlan227
description TCE vlan227
ip address 172.30.227.3 255.255.255.0
ip helper-address 172.30.245.15
no ip redirects
standby version 2
standby 227 ip 172.30.227.1
standby 227 preempt delay reload 180
standby 227 name TCE

Vlan227 - Group 227 (version 2)
  State is Active
    20 state changes, last state change 00:06:17   (** thats me, reseting the intf**)
  Virtual IP address is 172.30.227.1
  Active virtual MAC address is 0000.0c9f.f0e3
    Local virtual MAC address is 0000.0c9f.f0e3 (v2 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.672 secs
  Preemption enabled, delay reload 180 secs
  Active router is local
  Standby router is unknown
  Priority 100 (default 100)
  Group name is "TCE" (cfgd)

4 REPLIES 4
Highlighted
Hall of Fame Master

Hello Dave,

verify if  Switch A has an ARP entry for SwitchB SVI IP address in same vlan this allows you to verify if there is direct connectivity between the two.

Verify if the L2 trunks between the two devices or between the devices and  access layer switches are permitting the Vlans that are showing this behaviour.

usually this behaviour means that there isn't a direct L2 end-to-end path between the two HSRP speakers.

>>> is there a limitation to the number of groups i can active on a single switch ??

in some low end models a limitation is present, and multilayer switches allow for re-use of HSRP group numbers on different SVIs with no problems, and this is a recommended way to achieve scalability.

However, C4900 should have a limit higher then 20.

in the data sheet the exact number of HSRP groups is not reported

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps6021/product_data_sheet0900aecd8017a72e.html

Hope to help

Giuseppe

Highlighted

Thanks..Giuseppe

There is a serious lack of entries in the arp table, (so they dont see each other, why??) all the groups were created in the same way and most came up..

I noticed a few had some silly errors,  but the code looks alright now.

i might just forget about redundancy for certain vlans...i'd like to get it working though..

thanks again...

Highlighted
Beginner

Right so sorted this eventually, and only because the switch collapsed with H/W error

I had a backup of the config, loaded the new 4900m copied over the config and everything came up..

like i planned..sweet..

here is the failure

https://supportforums.cisco.com/thread/2070730

Highlighted
Beginner

,,

Content for Community-Ad