cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
371
Views
0
Helpful
11
Replies
guillermo.ruiz
Beginner

HSRP - information about other participants in a group

Hi,

I'd like to know if there is a CLI command or some way  to get some information about which switches (or devices) are participating in a specific HRSP group.

For example, using ''show standby vlan xx'', I asume I only see the active and the standby switches information.......(am I correct?)....what about some information about the other participants?

That is because of I need to modify some HSRP parameters (priority, authentication, timers) in some VLANs switches, but I am not sure if there are some other participants on each HSRP groups that can be affected with the changes....

Any help?

Thanks for any comment.

Best regards,

guruiz

11 REPLIES 11
Reza Sharifi
Hall of Fame Expert

Hi,

What type of device are you using

If you issue "sh hsrp group" you should be to see the active and stand-by devices.

HTH

Hi Reza,

Thanks for your reply.

Unfortunately I do not have that command on my switches.

switch#show h?

heartbeat  history  hm  hosts  html

hw-module 

switch#sh standby ?

  GigabitEthernet     GigabitEthernet IEEE 802.3z

  Port-channel        Ethernet Channel of interfaces

  TenGigabitEthernet  Ten Gigabit Ethernet

  Vlan                Catalyst Vlans

  all                 Include groups in disabled state

  brief               Brief output

  capability          HSRP capability

  delay               Group initialisation delay

  internal            Internal HSRP information

  redirect            HSRP ICMP redirect information

  |                   Output modifiers

 

I am using 6509-E platform with s72033-advipservicesk9_wan-mz.122-33.SXH8b.bin....

Any ideas?

guruiz

Hi,

How about "show stand vlan xx"?

HTH

Hi Reza,

That is the command that I am using, but I just only see active and standby information, and I need to be sure if there are other members on each standby group.

switch#  sh standby vlan xyz 

Vlanxyz - Group 1

  State is Active

    2 state changes, last state change 48w2d

  Virtual IP address is a.b.c.1

  Active virtual MAC address is 0000.0c07.ac01

    Local virtual MAC address is 0000.0c07.ac01 (v1 default)

  Hello time 1 sec, hold time 3 sec

    Next hello sent in 0.224 secs

  Authentication text ""

  Preemption enabled, delay min 60 secs

  Active router is local

  Standby router is a.b.c.3, priority 100 (expires in 3.232 sec)

  Priority 110 (configured 110)

  IP redundancy name is "hsrp-Vlxyz-1" (default)

Regards,

guruiz

Hi,

I have never had more then one stand-by router, but I would think if you have more then one you would see this section once per stand-by

Standby router is a.b.c.3, priority 100 (expires in 3.232 sec)

HTH

Thanks Reza !

So, if I just see one line like ''Standby router is....'', I will be sure that there is not another member in the specific HSRP group.

That helped me a lot !!

Thanks again.

guruiz

Hi Reza !

I have created a brief lab on GNS3....3 routers (R1, R2, and R3) connected through a switch.

Here is the info:

-------------------------------------------

R1#sh run int f1/0

Building configuration...

Current configuration : 164 bytes

!

interface FastEthernet1/0

ip address 10.1.1.1 255.255.255.0

speed auto

duplex auto

standby 66 ip 10.1.1.100

standby 66 priority 120

standby 66 preempt

end

R1#sh standby

FastEthernet1/0 - Group 66

  State is Active

    4 state changes, last state change 00:04:56

  Virtual IP address is 10.1.1.100

  Active virtual MAC address is 0000.0c07.ac42

    Local virtual MAC address is 0000.0c07.ac42 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 0.336 secs

  Preemption enabled

  Active router is local

  Standby router is 10.1.1.2, priority 110 (expires in 9.264 sec)

  Priority 120 (configured 120)

  Group name is "hsrp-Fa1/0-66" (default)

-------------------------------------------

R2#sh run int f1/0

Building configuration...

Current configuration : 164 bytes

!

interface FastEthernet1/0

ip address 10.1.1.2 255.255.255.0

speed auto

duplex auto

standby 66 ip 10.1.1.100

standby 66 priority 110

standby 66 preempt

end

R2#sh standby

FastEthernet1/0 - Group 66

  State is Standby

    6 state changes, last state change 00:05:42

  Virtual IP address is 10.1.1.100

  Active virtual MAC address is 0000.0c07.ac42

    Local virtual MAC address is 0000.0c07.ac42 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.376 secs

  Preemption enabled

  Active router is 10.1.1.1, priority 120 (expires in 10.944 sec)

  Standby router is local

  Priority 110 (configured 110)

  Group name is "hsrp-Fa1/0-66" (default)

-------------------------------------------

R3#sh run int f1/0

Building configuration...

Current configuration : 164 bytes

!

interface FastEthernet1/0

ip address 10.1.1.3 255.255.255.0

speed auto

duplex auto

standby 66 ip 10.1.1.100

standby 66 priority 105

standby 66 preempt

end

R3#sh stan

R3#sh standby

FastEthernet1/0 - Group 66

  State is Listen

    2 state changes, last state change 00:07:47

  Virtual IP address is 10.1.1.100

  Active virtual MAC address is 0000.0c07.ac42

    Local virtual MAC address is 0000.0c07.ac42 (v1 default)

  Hello time 3 sec, hold time 10 sec

  Preemption enabled

  Active router is 10.1.1.1, priority 120 (expires in 9.952 sec)

  Standby router is 10.1.1.2, priority 110 (expires in 9.168 sec)

  Priority 105 (configured 105)

  Group name is "hsrp-Fa1/0-66" (default)

As you can see from R1 or R2 perpective there is no way to know about R3 !!.

Do you know if could it be a way, a command or a procedure that can help to get information from the other members on the group?, i.e. from R1 or R2 perspective?...(because in customer network I need to be sure if some other members (devices) are connected (or not) in each hsrp group)..

Any help is very appreciated.

Regards,

guruiz

Hi,

R3#sh standby

FastEthernet1/0 - Group 66

  State is Listen

So, router 1 is active, router 2 is on stand-by and router 3 is in listen mode until the stand-by fails.  And you are correct, there is no where that you can see on the active router that you have 2 stand-by devices and I guess that is because the 3rd one is in listen mode and not stand-by.

Thanks for posting the configs

Reza

Pefectly answered Reza.

Guirez,

The third/fouth standby router will stuck in the listen state as in HSRP at a given point of time there can only be one Active and other as standby. If you confiugred the third or fouth it will be i the listen state and once the standby goes down the one wich is in the listen state of that HSRP group will take the standby role.

Example:

=========

R1 is the configured primary, R2 secondary and R3 tertiary. Note that that the state of R3 is listen until a failover occurs.

Pre failover

R1#

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.0

standby 10 ip 192.168.1.1

standby 10 priority 250

standby 10 preempt

end

R1#show standby

FastEthernet0/0 - Group 10

State is Active

   1 state change, last state change 00:03:33

Virtual IP address is 192.168.1.1

Active virtual MAC address is 0000.0c07.ac0a

   Local virtual MAC address is 0000.0c07.ac0a (v1 default)

Hello time 3 sec, hold time 10 sec

   Next hello sent in 2.704 secs

Preemption enabled

Active router is local

Standby router is 192.168.1.3, priority 200 (expires in 9.560 sec)

Priority 250 (configured 250)

Group name is "hsrp-Fa0/0-10" (default)

R2#

interface FastEthernet0/0

ip address 192.168.1.3 255.255.255.0

standby 10 ip 192.168.1.1

standby 10 priority 200

standby 10 preempt

end

FastEthernet0/0 - Group 10

State is Standby

Virtual IP address is 192.168.1.1

Active virtual MAC address is 0000.0c07.ac0a

   Local virtual MAC address is 0000.0c07.ac0a (v1 default)

Hello time 3 sec, hold time 10 sec

   Next hello sent in 1.988 secs

Preemption enabled

Active router is 192.168.1.2, priority 250 (expires in 9.156 sec)

Standby router is local

Priority 200 (configured 200)

Group name is "hsrp-Fa0/0-10" (default)

R3#

interface FastEthernet0/0

ip address 192.168.1.4 255.255.255.0

standby 10 ip 192.168.1.1

standby 10 priority 150

standby 10 preempt

end

FastEthernet0/0 - Group 10

State is Listen

Virtual IP address is 192.168.1.1

Active virtual MAC address is 0000.0c07.ac0a

   Local virtual MAC address is 0000.0c07.ac0a (v1 default)

Hello time 3 sec, hold time 10 sec

Preemption enabled

Active router is 192.168.1.2, priority 250 (expires in 8.360 sec)

Standby router is 192.168.1.3, priority 200 (expires in 8.196 sec)

Priority 150 (configured 150)

Group name is "hsrp-Fa0/0-10" (default)

Post Failover

R1#

FastEthernet0/0 - Group 10

State is Init (interface down)

   1 state change, last state change 00:07:21

Virtual IP address is 192.168.1.1

Active virtual MAC address is unknown

   Local virtual MAC address is 0000.0c07.ac0a (v1 default)

Hello time 3 sec, hold time 10 sec

Preemption enabled

Active router is unknown

Standby router is unknown

Priority 250 (configured 250)

Group name is "hsrp-Fa0/0-10" (default)

R2#

FastEthernet0/0 - Group 10

State is Active

   1 state change, last state change 00:00:44

Virtual IP address is 192.168.1.1

Active virtual MAC address is 0000.0c07.ac0a

   Local virtual MAC address is 0000.0c07.ac0a (v1 default)

Hello time 3 sec, hold time 10 sec

   Next hello sent in 0.236 secs

Preemption enabled

Active router is local

Standby router is 192.168.1.4, priority 150 (expires in 8.228 sec)

Priority 200 (configured 200)

Group name is "hsrp-Fa0/0-10" (default)

R3#

FastEthernet0/0 - Group 10

State is Standby

Virtual IP address is 192.168.1.1

Active virtual MAC address is 0000.0c07.ac0a

   Local virtual MAC address is 0000.0c07.ac0a (v1 default)

Hello time 3 sec, hold time 10 sec

   Next hello sent in 0.068 secs

Preemption enabled

Active router is 192.168.1.3, priority 200 (expires in 9.092 sec)

Standby router is local

Priority 150 (configured 150)

Group name is "hsrp-Fa0/0-10" (default)

HTH

Regards

Inayath.

Reza & Inayath,

Your information and feedback are very appreciated.

Thank you a lot..

Take care.

regards,

guruiz

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

As you can see from R1 or R2 perpective there is no way to know about R3 !!.

Do you know if could it be a way, a command or a procedure that can help to get information from the other members on the group?, i.e. from R1 or R2 perspective?...(because in customer network I need to be sure if some other members (devices) are connected (or not) in each hsrp group)..

Any help is very appreciated.

If you activate debug for HSRP you might see the other group members announce themselves.