cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
138
Views
0
Helpful
3
Replies
Beginner

HSRP issue?

Hello! 

 

Im having an issue where traffic is coming in CE1, and leaving CE2. 

 

What am I missing? And on PE its static routes.

 

Thanks in advanced. 

 

 

CE1 konfig:

standby 100 ip xx.xx.xx.246
standby 100 priority 105
standby 100 preempt
standby 100 name xxxxxx
standby 100 track 10 decrement 90

 

Track 10
List boolean or
Boolean OR is Up
2 changes, last change 00:49:17
object 11 Up
object 12 Up
Tracked by:
HSRP GigabitEthernet0/0/1.57 100
Track 11
IP SLA 11 state
State is Up
1 change, last change 00:50:00
Latest operation return code: OK
Latest RTT (millisecs) 1
Tracked by:
Track List 10
Track 12
IP SLA 12 state
State is Up
1 change, last change 00:49:59
Latest operation return code: OK
Latest RTT (millisecs) 1
Tracked by:
Track List 10

 

ce1#sh standby brief
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 07:38:13.562 CEST Mon Apr 22 2019
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Gi0/0/1.57 100 105 P Active local xx.xx.xx.245 xx.xx.xx.246

 

ce1#sh run | section ip route
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0 WAN
ip route vrf ABCl --> LAN 

 

 

ce1#sh run int Gi0/0/1.57
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 07:41:42.066 CEST Mon Apr 22 2019

Building configuration...

Current configuration : 307 bytes
!
interface GigabitEthernet0/0/1.57
encapsulation dot1Q 57
ip vrf forwarding ABC
ip address XX.XX.XX.244 255.255.255.248
ip rip advertise 15
standby 100 ip xx.xx.xx.246
standby 100 priority 105
standby 100 preempt
standby 100 name ABC
standby 100 track 10 decrement 90
end

 

CE2

 

ce2#sh standby brief
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 07:40:35.022 CEST Mon Apr 22 2019
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Gi0/0/1.57 100 95 P Standby xx.xx.xx.244 local xx.xx.xx.246

 

psn-cr057-ce2#SH RUN INT Gi0/0/1.57
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 07:42:48.059 CEST Mon Apr 22 2019

Building configuration...

Current configuration : 271 bytes
!
interface GigabitEthernet0/0/1.57
encapsulation dot1Q 57
ip vrf forwarding ABC
ip address XX.XX.XX.245 255.255.255.248
ip rip advertise 15
standby 100 ip XX.XX.XX.246
standby 100 priority 95
standby 100 preempt
standby 100 name ABC
end

 

I know that "standby 100 track 10 decrement 90" is missing from CE2, but i have other sites where who also don't have track on, and works perfectly.

ce2#sh run | section ip route
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0 XX.XX.XX.73
ip route vrf ABC XX.XX.XX.0 255.255.255.0 XX.XX.XX.241

 

Outgoing.JPGIncoming.JPG

3 REPLIES 3
Highlighted
VIP Mentor

Re: HSRP issue?

Hello,

 

I cannot figure out from your post what you are asking or what your problem is. Can you elaborate and possibly post a schematic drawing of your topology ?

Beginner

Re: HSRP issue?

CE1 is is the active router in HSRP, so all traffic should enter and leave that router. Now traffic is "incoming" in CE and "outgoing" in CE. 

Cisco Employee

Re: HSRP issue?

Hello Seany_85,

 

It would be helpful if you can clarify which direction is seeing an issue. PE to CE? Or LAN to CE? Where is the traffic ingressing from? Also, a simple topology diagram would help.

 

HSRP active/standby status usually doesn't factor into routing decisions. Try checking routing table to see what CE1 will pick as next hop for example traffic flow. Use "show ip route x.x.x.x" and "show ip cef x.x.x.x". Remember to specify VRF as necessary.

 

Also, is STP involved on CE1 or CE2? It could cause traffic to utilize CE2 for traffic flowing to LAN if CE2 was STP root bridge and LAN facing ports were L2 switchports.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards