cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
4656
Views
0
Helpful
3
Replies

HSRP VLAN Interface Flapping on 6509-E

I am facing problem on Catalyst 6500 Series switches. We are using 6500 series switches core switches in our network and 4500 series as access switches. We have created multiple vlans according to departments. For all the vlans we created the vlan interfaces and configured HSRP for the same. Now one of the vlan interface among that (vlan 24) started flapping as in HSRP started changing states. One thing that i had observed that time was that from active core switch i was not able to ping the vlan 24 interface ip of the  standby core switch. Also vice versa was not happening.

Due to that both the switches had become active HSRP for VLAN 24 and due to that packets were getting lost. But all the other vlan interfaces were behaving properly.

Primary Core Switch

interface Vlan24
ip address 172.16.24.2 255.255.255.0
standby 24 ip 172.16.24.1
standby 24 priority 250
standby 24 preempt

!

Standby Core Switch

interface Vlan24
ip address 172.16.24.3 255.255.255.0
standby 24 ip 172.16.24.1
standby 24 priority 200
standby 24 preempt

Connectivity between core to core is via 10G:

interface TenGigabitEthernet4/3
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
!

Also HSRP logs were observed on Standby Core Switch only:

May 10 07:11:17.292: %HSRP-5-STATECHANGE: Vlan24 Grp 24 state Active -> Speak
*May 10 07:11:38.320: %HSRP-5-STATECHANGE: Vlan24 Grp 24 state Standby -> Active
*May 10 07:15:23.080: %HSRP-5-STATECHANGE: Vlan24 Grp 24 state Active -> Speak
*May 10 07:15:43.848: %HSRP-5-STATECHANGE: Vlan24 Grp 24 state Standby -> Active
*May 10 07:16:34.284: %HSRP-5-STATECHANGE: Vlan24 Grp 24 state Active -> Speak
*May 10 07:16:55.952: %HSRP-5-STATECHANGE: Vlan24 Grp 24 state Standby -> Active
*May 10 07:23:02.356: %HSRP-5-STATECHANGE: Vlan24 Grp 24 state Active -> Speak
*May 10 07:23:25.516: %HSRP-5-STATECHANGE: Vlan24 Grp 24 state Standby -> Active

Regards

Fazleabbas

3 REPLIES 3
Calin C.
Contributor

You have there a communication problem there in VLAN 24. That's why you see the the flapping when the 2 switches lose connection over VLAN 24.

I suspect a loop, but since I don't know your topology, it's hard to troubleshoot this. Also check the spanning-tree for errors. If you are using PVST, check the spanning-tree only for VLAN 24. Best practice would be to have the root bridge on the same switch which is active in the HSRP.

Let me know if you found any loop or STP errors.

Cheers,

Calin

I have already checked Spanning-tree for vlan 24 and My ROot Bridge is Active Core.  Regarding Looping i have not found any loops in the network.

My toplogy is we have two core switches 6509 connected to 4507 the access switch via 10G Fiber uplink.

Turn on debug and see what are the errors and events.