cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
206
Views
10
Helpful
3
Replies
nadbal07
Beginner

I have problem with protocol down, HSRP not working too

Hello,

 

I have problem with "Router1".

When I run "show ip interface brief" its says the protocol is down but the status is up. I don't know whats the problem and what I did wrong, but maybe because of this I can't make HSRP between Router 3 and Router 1.

Please if someone could check the topology and troubleshooting would be helpful, because I need it for project.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Georg Pauwen
VIP Master

Hello,

 

the subinterfaces are configured on the wrong interface, GigabitEthernet0/1 instead of GigabitEthernet0/0.

 

GigabitEthernet0/1 is not active, there is nothing connected.

 

Make sure the configuration of Router1 looks like below. Attached the revised, working file.

 

Router#sh run
Building configuration...

Current configuration : 1429 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524USUP-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.3 255.255.255.0
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.3 255.255.255.0
!
interface GigabitEthernet0/0.30
encapsulation dot1Q 30
ip address 192.168.30.3 255.255.255.0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/0/1
ip address 200.100.20.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/0
no ip address
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
passive-interface GigabitEthernet0/0
network 200.100.20.0 0.0.0.3 area 0
network 192.168.10.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 0
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

View solution in original post

3 REPLIES 3
Georg Pauwen
VIP Master

Hello,

 

the subinterfaces are configured on the wrong interface, GigabitEthernet0/1 instead of GigabitEthernet0/0.

 

GigabitEthernet0/1 is not active, there is nothing connected.

 

Make sure the configuration of Router1 looks like below. Attached the revised, working file.

 

Router#sh run
Building configuration...

Current configuration : 1429 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524USUP-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.3 255.255.255.0
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.3 255.255.255.0
!
interface GigabitEthernet0/0.30
encapsulation dot1Q 30
ip address 192.168.30.3 255.255.255.0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/0/1
ip address 200.100.20.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/0
no ip address
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
passive-interface GigabitEthernet0/0
network 200.100.20.0 0.0.0.3 area 0
network 192.168.10.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 0
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

nadbal07
Beginner

Oh my god!

Thank you for your help, I tried to find solution for days, and you helped me! Thank you again!

Hello,

 

glad it is resolved !